Question

Openflow Controller issue

  • 19 November 2020
  • 3 replies
  • 49 views

I have summit x440. Floodlight controller connect my switch. I see topology on floodlight. But PC is not connect to network. how am i fix issue? (EXOS Firmware version 16.2.4.5)

 

My switch openflow config:

configure openflow default-rule bddp controller
configure openflow default-rule lldp controller
configure openflow default-rule iparp controller
configure openflow default-rule miss controller
enable openflow
configure openflow tables fdb on
enable openflow vlan "VLAN_4000"
configure openflow controller primary out-of-band active ipaddress 10.0.0.141 6653

 

I have error on floodlight:

2020-11-19 14:49:55.332 ERROR [n.f.c.i.OFSwitchHandshakeHandler] OFBadRequestErrorMsgVer13(xid=23, code=BAD_PORT, data=[unparsed: 04 0d 00 68 00 00 00 17 ff ff ff ff 00 00 00 01 00 10 00 00 00 00 00 00 00 00 00 10 ff ff ff fb ff ff 00 00 00 00 00 00 ff ff ff ff ff ff 14 da e9 c0 72 8b 08 06 00 01 08 00 06 04 00 01 14 da]) from switch OFSwitch DPID[00:00:00:04:96:98:70:01] in state net.floodlightcontroller.core.internal.OFSwitchHandshakeHandler$MasterState@373a5924
2020-11-19 14:49:56.352 ERROR [n.f.c.i.OFSwitchHandshakeHandler] OFBadRequestErrorMsgVer13(xid=24, code=BAD_PORT, data=[unparsed: 04 0d 00 68 00 00 00 18 ff ff ff ff 00 00 00 01 00 10 00 00 00 00 00 00 00 00 00 10 ff ff ff fb ff ff 00 00 00 00 00 00 ff ff ff ff ff ff 14 da e9 c0 72 8b 08 06 00 01 08 00 06 04 00 01 14 da]) from switch OFSwitch DPID[00:00:00:04:96:98:70:01] in state net.floodlightcontroller.core.internal.OFSwitchHandshakeHandler$MasterState@373a5924
2020-11-19 14:49:57.378 ERROR [n.f.c.i.OFSwitchHandshakeHandler] OFBadRequestErrorMsgVer13(xid=25, code=BAD_PORT, data=[unparsed: 04 0d 00 68 00 00 00 19 ff ff ff ff 00 00 00 01 00 10 00 00 00 00 00 00 00 00 00 10 ff ff ff fb ff ff 00 00 00 00 00 00 ff ff ff ff ff ff 14 da e9 c0 72 8b 08 06 00 01 08 00 06 04 00 01 14 da]) from switch OFSwitch DPID[00:00:00:04:96:98:70:01] in state net.floodlightcontroller.core.internal.OFSwitchHandshakeHandler$MasterState@373a5924


3 replies

Userlevel 3

Hi,

Are there any logs on the switch that correlate with those logs on the controller?

 

Thanks,

Chris Thompson

No, there aren’t any logs.

The problem is exactly like this:
I am using the following configuration. PCs in VLAN(VLAN_400) get ip address if Openflow is disable. PING is responding. But when I enable VLAN's openflow, the computer cannot receive ip address.It is not responding to PING.

configure vlan default delete ports all
configure vr VR-Default delete ports 1-24
configure vr VR-Default add ports 1-24
configure vlan default delete ports 1-24
create vlan "VLAN_0003"
configure vlan VLAN_0003 tag 3
create vlan "VLAN_4000"
configure vlan VLAN_4000 tag 4000
configure vlan VLAN_0003 add ports 24 tagged
configure vlan VLAN_4000 add ports 24 tagged
configure vlan VLAN_4000 add ports 1-23 untagged
configure vlan VLAN_0003 ipaddress 10.0.0.135 255.255.255.0
enable ipforwarding vlan VLAN_0003
configure vr VR-Default delete protocol mpls


configure iproute add default 10.0.0.254

configure openflow default-rule bddp controller
configure openflow default-rule lldp controller
configure openflow default-rule iparp controller
configure openflow default-rule miss controller
enable openflow
configure openflow tables fdb on
enable openflow vlan "VLAN_4000"
configure openflow controller primary out-of-band active ipaddress 10.100.1.141 6653

 

Also the controller works with mininet.

 

Reply