Question

Random EXOS question involving a summit x440

  • 14 July 2020
  • 3 replies
  • 170 views

I recently picked up a used/Refurbished Summit x440 that came with ExtremeOS 15.2.1b5  preloaded.  

A LOT of students are wanting to use this with Ansible and/or  netmiko/napalm/nornir for network automation.

Ansible does still has a couple of EXOS network modules,  but the platforms options mentions you could use "httpapi" in the vars,  instead of "network_cli"    (the "network_os" is still specified at "exos", though).

Do that image on that x440 actually support this (and would using httpapi be better), would I need to get a support contract to get a more recent one,   or amI just be spinning my wheels, and better off trying to walk them through importing the  EXOSVM in CML-P instead? 


3 replies

Userlevel 6

I’m not sure how to integrate EXOS into CML-P.  If CML-P supports Qemu images it shouldn't be too hard.  You can also build EXOS from the .iso files on github and use any VM format you want.

I had a hunch that was the case. 

I don’t mind using the virtual EXOS VMs for the lab.  However, I’m trying to migrate all of the students away from GNS3  (it’s  support nightmare, since nobody on the GNS3 forums helps them). 

 

Is there anything on y’all github showing how to import the virtual EXOS   Qemu VM into Cisco’s CML-P.    I’ haven’t had a time to go through all of their docs (and then tend to ignore folks too).     I prefer using/. CML-P of latem but the last time I tried creating a custom template an importing a non-Cisco switching VM,  it basically nuked IOSvL2.   

 

Any thoughts?  

 

Userlevel 4

Hi,

 

15.2 was introduced in 2014, so a lot has changed since then regarding automation.  If you and/or the students are interested in automating with EXOS and exploring the newer feature sets, check out the following link where you can use EXOS virtual images:

 

https://github.com/extremenetworks/ansible-extreme/blob/master/GettingStartedwithAnsibleusingGNS3.md

Thanks,

Chris Thompson

Reply