Solved

ISIS routes not being advertised into OSPF

  • 3 December 2020
  • 11 replies
  • 274 views

Userlevel 6
Badge

Hi,

Must be missing some configuration but can’t see it.

In summary I’m trying to redistribute ISIS routes into OSPF with this command:

router ospf
   redistribute isis
   redistribute isis enable
exit
ip ospf apply redistribute isis

There is basically one P2P link between a VSP and S8 that has a full adjacency and is sharing the OSPF routing table. I can ping anything from the VSP on the S8 network, so thats all working well.

The IP addresses I can ping from the S8 to the VSP are only the OSPF networks I have configured on the VSP, basically I can not ping anything that’s in the ISIS routing table that includes the CLIP’s and Mgmt CLIP.

Here is the view of the ISIS routing table on the VSP:

Por-DC1-Core1:1#% show ip route protocol isis
************************************************************************************
                Command Execution Time: Thu Dec 03 23:07:49 2020 GMT
************************************************************************************
=====================================================================================================
                                       IP Route - GlobalRouter
=====================================================================================================
                                                     NH                      INTER
DST             MASK            NEXT                 VRF/ISID         COST   FACE     PROT AGE TYPE PRF
-----------------------------------------------------------------------------------------------------
172.22.0.212    255.255.255.255 Por-DC1-Core2        GlobalRouter     10     4051     ISIS 0   IBS  7
172.22.0.221    255.255.255.255 Por-DC2-Core1        GlobalRouter     10     4051     ISIS 0   IBS  7
172.22.0.222    255.255.255.255 Por-DC2-Core2        GlobalRouter     20     4051     ISIS 0   IBS  7
172.22.1.212    255.255.255.252 Por-DC2-Core1        GlobalRouter     10     4051     ISIS 0   IBS  7
172.22.1.220    255.255.255.252 Por-DC1-Core2        GlobalRouter     10     4051     ISIS 0   IBS  7
172.22.1.244    255.255.255.252 Por-DC1-Core2        GlobalRouter     10     4051     ISIS 0   IBS  7
192.168.200.212 255.255.255.255 Por-DC1-Core2        GlobalRouter     10     4051     ISIS 0   IBS  7
192.168.200.221 255.255.255.255 Por-DC2-Core1        GlobalRouter     10     4051     ISIS 0   IBS  7
192.168.200.222 255.255.255.255 Por-DC2-Core2        GlobalRouter     20     4051     ISIS 0   IBS  7

 

The VLAN being used to connect the VSP and S8 is 3901, on the S8 you can see I’m only learning OSPF interfaces that I have configured on the VSP’s, none of the ISIS routes are being learnt?

PorLANCore01(su)->show ip route ospf |find vlan.0.3901
O      172.22.1.208/30     [110/20]     via       172.22.1.201     vlan.0.3901              55m26s
O      172.22.1.212/30     [110/30]     via       172.22.1.201     vlan.0.3901              55m26s
O      172.22.1.216/30     [110/20]     via       172.22.1.201     vlan.0.3901              55m26s
O      172.22.1.220/30     [110/30]     via       172.22.1.201     vlan.0.3901              55m26s

Here is a bit more of a snapshot of the VSP config

interface GigabitEthernet 1/16
   encapsulation dot1q
exit

router isis
   spbm 1
   spbm 1 nick-name d.02.11
   spbm 1 b-vid 4051-4052 primary 4051
   spbm 1 multicast enable
   spbm 1 ip enable
   spbm 1 smlt-virtual-bmac 00:00:84:04:01:01
   spbm 1 smlt-peer-system-id 020d.0020.0221
exit

mlt 501 enable name "NNI-QSFP-DC1"
mlt 501 member 1/18
mlt 501 encapsulation dot1q
mlt 503 enable name "NNI-DC1-DC2"
mlt 503 member 1/17
mlt 503 encapsulation dot1q

ip prefix-list "suppressIST" 172.22.1.240/30 id 1 ge 29 le 29
ip prefix-list "suppressIST" 172.22.1.244/30 id 1 ge 29 le 29

vlan members remove 1 1/1-1/18 portmember

vlan create 3401 name "OSP P2P DC1-CR1 to DC1-CR2" type port-mstprstp 0
vlan i-sid 3401 123401
interface Vlan 3401
   ip address 172.22.1.209 255.255.255.252 2
   ip ospf enable
exit
vlan create 3403 name "OSP P2P DC-CR1 to DC2-CR1" type port-mstprstp 0
vlan i-sid 3403 123403
interface Vlan 3403
   ip address 172.22.1.217 255.255.255.252 3
   ip ospf enable
exit
vlan create 3901 name "OSPF P2P Legacy to CR1" type port-mstprstp 0
vlan members 3901 1/16 portmember
vlan i-sid 3901 123901
interface Vlan 3901
   ip address 172.22.1.201 255.255.255.252 1
   ip ospf enable
exit
vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan
vlan create 4053 type port-mstprstp 0
vlan i-sid 4053 124053
interface Vlan 4053
   ip address 172.22.1.241 255.255.255.252 0
exit
mgmt clip vrf GlobalRouter
   ip address 192.168.200.211/32
   enable
exit
virtual-ist  peer-ip 172.22.1.242 vlan 4053
interface mlt 501
   isis
   isis spbm 1
   isis enable
exit
interface mlt 503
   isis
   isis spbm 1
   isis enable
exit
interface GigabitEthernet 1/16
   default-vlan-id 0
   no shutdown
exit
interface GigabitEthernet 1/17
   default-vlan-id 0
   no shutdown
   no spanning-tree mstp  force-port-state enable
   no spanning-tree mstp msti 62 force-port-state enable
exit
interface GigabitEthernet 1/18
   default-vlan-id 0
   no shutdown
   no spanning-tree mstp  force-port-state enable
   no spanning-tree mstp msti 62 force-port-state enable
exit
route-map "suppressIST" 1
   no permit
   enable
   match network "suppressIST"
   set metric-type type2
   set nssa-pbit enable
exit
route-map "suppressIST" 2
   permit
   enable
   match protocol local
exit
ip route 0.0.0.0 0.0.0.0 172.22.1.202 weight 1
interface loopback 1
   ip address 1 172.22.0.111/255.255.255.255
exit
router isis
   sys-name "Por-DC1-Core1"
   is-type l1
   system-id 020d.0020.0211
   manual-area 49.0001
exit
router isis enable

cfm spbm mepid 811
cfm spbm enable

router ospf enable
router ospf
   router-id 172.22.0.211
exit
router ospf
   redistribute isis
   redistribute isis enable
exit
router isis
   redistribute direct
   redistribute direct route-map "suppressIST"
   redistribute direct enable
exit
end
ip ospf apply redistribute isis
isis apply redistribute direct

 

Appreciate any help in advance.

Many thanks

 

icon

Best answer by Martin Flammia 4 December 2020, 05:32

Thanks Jay and Mig, that worked when I added ASBR config and did a 

ip ospf apply redistribute isis

Did get the following error, running version 8.2, when using the route-policy command:

Por-DC2-Core1:1(config-ospf)#redistribute isis route-policy isis-internal
This command is deprecated/obsolete. Please use 'route-map' instead.


Found this article though:

https://gtacknowledge.extremenetworks.com/articles/Solution/000048823

So the final config looked like the below:
 

router ospf
as-boundary-router enable
redistribute direct
redistribute direct enable
exit

route-map "isis-internal" 1
permit
enable
match metric-type-isis internal

route-map "isis-internal" 1
permit
enable
match metric-type-isis internal

router ospf
redistribute isis metric-type type1 
redistribute isis route-map "isis-internal"

ip ospf apply redistribute isis

Many thanks for your help, really appreciated it.

Cheers,

Martin

View original

This topic has been closed for comments

11 replies

Userlevel 6
Badge +1

Martin,

Shouldn’t you enable asbr on the VSP and assign the area corresponding to the S8?

router ospf

as-boundary-router enable

area 0.0.0.1

exit

As debug commands, please share:

show ip route

show ip route alternative

show ip route proto ospf

show ip ospf ase

show ip ecmp

show ip ospf neighbor

 

Mig

Userlevel 6
Badge

Hi Mig,

Thanks for posting.

These are both in area 0.0.0.0. The reason is the network is migrating from S8’s to VSP’s, so the area needs to stay the same for when the S8’s disappear and as subnets get moved across.

The outputs of those commands are too large to post here, maybe 100’s or 1000’s of entries.

Only one with a subset of data is as follows, the first adjacency is the one to the S8. The other two are to other VSP switches.

Por-DC1-Core1:1#% show ip ospf neighbor
************************************************************************************
Command Execution Time: Thu Dec 03 23:30:41 2020 GMT
************************************************************************************

====================================================================================================
OSPF Neighbors - GlobalRouter
====================================================================================================
INTERFACE NBRROUTERID NBRIPADDR PRIO STATE RTXQLEN PERM TTL
----------------------------------------------------------------------------------------------------
172.22.1.201 0.119.255.141 172.22.1.202 1 Full 0 Dyn 34
172.22.1.217 172.22.0.221 172.22.1.218 1 Full 0 Dyn 36
172.22.1.209 172.22.0.212 172.22.1.210 1 Full 0 Dyn 36

Show ip ecmp doesn’t seem to take.

Is there anything in the routing table that you specifically need to see, suffice to say there is a lot of routes being shared via OSPF between the S8 and VSP.

Appreciate you might need more context or detail, so let me know if you need anything else.

Cheers,

Martin

Userlevel 6
Badge

Ah, I’ve had an idea. Think I need a network statement on the S8 side. Let me try and get back to you.

Thanks

Userlevel 6
Badge +1

Martin,

Where is located your default route?

can we have the 5 first lines of “show ip route” and “show ip route alternative”?

You could need to redistribute direct and static routes depending on your needs. Analyze this carefully to avoid injecting routes from ospf to isis to ospf to isis ...:

#

# IP REDISTRIBUTION CONFIGURATION - GlobalRouter

#

router ospf

redistribute isis

redistribute static

redistribute static enable

redistribute direct

redistribute direct enable

exit

router isis

redistribute static

redistribute static enable

redistribute direct

redistribute direct enable

exit

ip ospf apply redistribute static

ip ospf apply redistribute direct

isis apply redistribute static

isis apply redistribute direct

If your default route is on isis side with a static route, just redistribute the static routes and not the direct routes

Mig

Userlevel 6
Badge

Hi Mig,

Looking at those commands redistribute direct and static are both being applied to router ISIS and Router OSPF.

My understanding could be wrong but my thought process was if I have redistribute direct on the ISIS router, then redistribute ISIS on the OSPF router, then that would achieve the goal of getting the ISIS routes into OSPF via the redistribution between the two. Once the ISIS routes are in OSPF then the rest of the network would be able to reach it.

I think I could have the concept of the redistribute ISIS in the router OSPF wrong?

Additionally the static route configure on the VSP currently point all traffic to the S8’s, as this is currently where everything is still connected. So I didn’t want to distribute that default route into the S8 network and possibly poison the default route that's currently on their. It should not matter as will have a higher cost, but just playing safe

Por-DC1-Core1:1#% show ip route
************************************************************************************
Command Execution Time: Thu Dec 03 23:48:30 2020 GMT
************************************************************************************
=====================================================================================================
IP Route - GlobalRouter
=====================================================================================================
NH INTER
DST MASK NEXT VRF/ISID COST FACE PROT AGE TYPE PRF
-----------------------------------------------------------------------------------------------------
0.0.0.0 0.0.0.0 172.22.1.202 GlobalRouter 1 3901 STAT 0 IB 5
1.1.1.1 255.255.255.255 172.22.1.202 GlobalRouter 20 3901 OSPF 0 IB 125
2.2.2.2 255.255.255.255 172.22.1.202 GlobalRouter 20 3901 OSPF 0 IB 125
x.x.x.x 255.255.255.255 172.22.1.202 GlobalRouter 100 3901 OSPF 0 IB 125
x.x.x.x 255.255.255.255 172.22.1.202 GlobalRouter 100 3901 OSPF 0 IB 125
Por-DC1-Core1:1#% show ip route alternative
************************************************************************************
Command Execution Time: Thu Dec 03 23:50:13 2020 GMT
************************************************************************************
=====================================================================================================
IP Route - GlobalRouter
=====================================================================================================
NH INTER
DST MASK NEXT VRF/ISID COST FACE PROT AGE TYPE PRF
-----------------------------------------------------------------------------------------------------
0.0.0.0 0.0.0.0 172.22.1.202 GlobalRouter 1 3901 STAT 0 IB 5
0.0.0.0 0.0.0.0 172.22.1.202 GlobalRouter 20 3901 OSPF 0 IA 125
1.1.1.1 255.255.255.255 172.22.1.202 GlobalRouter 20 3901 OSPF 0 IB 125
2.2.2.2 255.255.255.255 172.22.1.202 GlobalRouter 20 3901 OSPF 0 IB 125

Many thanks

Userlevel 6
Badge +1

Martin,

In the current situation, what you want is to distribute the directe routes from isis to ospf.

And certainly not the statics.

Mig

Userlevel 6
Badge

Hi Mig,

Sure, that is the intention, whether that is the best way or not I don’t know?

In principle I can’t see why it shouldn’t work as the configuration is above?

Possibly it can’t be done this way, only if you configure OSPF as a ASBR, as you have mentioned and in this article:

https://gtacknowledge.extremenetworks.com/articles/Solution/ISIS-doesn-t-redistribute-learned-routes-into-OSPF/?l=en_US&fs=RelatedArticle
 

That wouldn’t work in my case?

Maybe I forget redistributing ISIS into OSPF altogether and just redistribute direct into OSPF instead. Sure I tried this and the CLIP and Mgmt CLIP still didn’t appear in OSPF, but will try again unless any other ideas are suggested?

Thanks

Userlevel 1

Hey Martin, 

 

Turn on ASBR on the VSP like stated in the GTAC case. Also redistribute your direclty connected interfaces into both ISIS and OSPF. 

Userlevel 6
Badge

Thanks Jay and Mig, that worked when I added ASBR config and did a 

ip ospf apply redistribute isis

Did get the following error, running version 8.2, when using the route-policy command:

Por-DC2-Core1:1(config-ospf)#redistribute isis route-policy isis-internal
This command is deprecated/obsolete. Please use 'route-map' instead.


Found this article though:

https://gtacknowledge.extremenetworks.com/articles/Solution/000048823

So the final config looked like the below:
 

router ospf
as-boundary-router enable
redistribute direct
redistribute direct enable
exit

route-map "isis-internal" 1
permit
enable
match metric-type-isis internal

route-map "isis-internal" 1
permit
enable
match metric-type-isis internal

router ospf
redistribute isis metric-type type1 
redistribute isis route-map "isis-internal"

ip ospf apply redistribute isis

Many thanks for your help, really appreciated it.

Cheers,

Martin

Userlevel 6
Badge +1

:metal:

Userlevel 4
Badge

In addition to this thread, there is a limitation, regarding redistribution, when using VRFs.

It’s not important for the root cause of this thread but maybe interessting for someone.

You can’t pickup routes in GRT which you got via ISIS from a VRF and redistribute them into OSPF.

OS was VOSS 8.1.5

I don’t know if this is/would changed in a future release.