Question

Run virtual Voss in Vmware or Virtualbox

  • 14 January 2021
  • 3 replies
  • 152 views

I need to get virtual Voss and EXOS up and running in a virtual environment. EXOS runs fine in both Virtualbox and Vmware Workstation Player, but I can’t find any documentation at all on how to run virtual VOSS without GNS3.  I’ve been able to get VOss 8.1.5 to boot, but the OS restarts in an eternal loop. For Voss 8.2, I barely get passed GRUB before the OS get stuck at ‘Booting the kernel’. 

Any ideas on how to get Voss and EXOS running in a stock out-of-the-box virtual environment?


3 replies

Userlevel 5

It should work; you can get the VOSS images here:

https://github.com/extremenetworks/Virtual_VOSS

I noticed the DRAM needs to be at least 2048MB for the VM to load since 8.2.

I already found the VOSS images on Github... It’s the first out of very few useful hits in Google.

 

Unfortunately, my attempts to boot Voss in Virtualbox fails.  This is with VOSS 8.2 configured with 64 bit Linux as OS and 2048 Mb RAM. Same result with converting image from qcow2 to vmdk and importing qcow2 directly to Virtualbox.

(..)

 

00:00:01.068669 emR3Debug: rc=VERR_INVALID_STATE

00:00:01.545360 GUI: UIMachineViewNormal::resendSizeHint: Restoring guest size-hint for screen 0 to 800x600

00:00:02.884983 GUI: User request to power VM off on Guru Meditation.

00:00:02.885007 GUI: Passing request to power VM off from machine-logic to UI session.

00:00:02.885011 GUI: Powering VM down on UI session power off request...

00:00:02.885256 Console: Machine state changed to 'Stopping'

00:00:02.885915 Console::powerDown(): A request to power off the VM has been issued (mMachineState=Stopping, InUninit=0)

00:00:02.886906 Changing the VM state from 'GURU_MEDITATION' to 'POWERING_OFF'

 

Can you elaborate on the steps needed to boot Voss in Virtualbox? I’m probably just missing a subtle detail.

I have Exos 30 running in Virtualbox.  For the sake of consistency, it would be beneficial if you provide documentation on how to run both Exos and Voss in the same virtual environment.

No information at all on the internet how to boot Voss in virtualbox? I am almost sure that I found a topic about this on a site, can't remember which one though. You can check this source about .vmdk, the steps are almost the same, it can help you to boot the Voss. I didn't try it before, but according to people from the commentary section it worked perfectly, so it can work for you as well. The process is described in details, so you should have no problems with it, everything is very clear.

Reply