Solved

VSP 7254 XSQ Software Upgrade fails

  • 28 April 2021
  • 5 replies
  • 79 views

Hi all, I’ve got an issue upgrading my VSP 7254 XSQ software. I’m getting an error message which doesn’t really tell me much. Has anyone had any experience with this? 

I’m currently sitting on an old software release VOSS7K.6.0.1.1.GA (Primary Release), and I am attempting to go up to 8.3.0.0; 

I tried doing the “next major upgrade up” from 6.0.1.1 to 6.1.0.0 but that didn’t help. Still saying the same thing. 

Slot 1: Could not update Kernel image for flash bank 1. IM error code: -1

 

Any info will be greatly appreciated. 

icon

Best answer by poddy 30 April 2021, 05:52

It turned out to be a brain error on my end. I was indeed not following the proper upgrade path. Started again at 6.0.x->6.1.x and then followed it all the way to 8.3 - no problems. 

 

Thanks all. 

View original

5 replies

It turned out to be a brain error on my end. I was indeed not following the proper upgrade path. Started again at 6.0.x->6.1.x and then followed it all the way to 8.3 - no problems. 

 

Thanks all. 

Have you verified the upgrade path is correct?

I would say in your case you would have to do:

6.0.x->6.1.x->7.1.x->8.1.x->8.3.x

Hi Dany, yea like I said in my original post, I tried going to 6.1. It didn’t work. 

Userlevel 5

The Linux kernel changes in VOSS 7.0. You need to first upgrade to a 6.1.x version, then you should be able to upgrade directly to 8.3. If that still does not work, try going from 6.1.x to 7.0.x first.

Userlevel 6
Badge +1

From release notes:

 

Mig

Userlevel 2

Have you verified the upgrade path is correct?

I would say in your case you would have to do:

6.0.x->6.1.x->7.1.x->8.1.x->8.3.x

Reply