Question

Error: Cannot config SPBM ISIS interface on MLT port

  • 4 December 2018
  • 5 replies
  • 644 views

Userlevel 5
Just starting to get to grips with VOSS, and initially creating a lab based on some training notes I have.

The intention is to have 4 VOSS switches connected togther but two pairs are connected via an MLT. The configuration I have got to at this point following the training configuration is as follows:

code:
boot config flag factorydefaults
save config
reset –y

snmp-server name VSP01

vlan ports 1/1,1/2 tagging tagall
vlan create 4053 type port-mstprstp 0
vlan mem add 4053 1/1,1/2
mlt 10
mlt 10 encap dot
mlt 10 mem 1/1,1/42
mlt 10 vlan 4053

spbm
router isis
spbm 1
spbm 1 b-vid 4051,4052 primary 4051
spbm 1 nick-name e.51.00
system-id 000e.4851.0000
manual-area 49.0001
exit

vlan create 4051 type spbm-bvlan
vlan create 4052 type spbm-bvlan

vlan member remove 1 1/1-1/4
interface Gigabitethernet 1/1-1/4
no spanning-tree mstp force-port-state enable
isis
isis spbm 1


When I put that last command in I get the following:

code:
Error: Cannot config SPBM ISIS interface on MLT port

Error: SPBM NNI port/MLT port cannot be in VLAN which is not SPBM BVLAN.


Here is a quick snapshot of the network:



Appreciate any advice in advance.

5 replies

Userlevel 5
Hello Martin,

Just a quick try: your interface 1/1 is in VLAN 4053 and there is 'mlt 10 vlan 4053', where 4053 is not a BVID for your SPB cloud. Try to remove those 4053 occurences and it should be ok. SPBM NNIs can only operate with BVIDs and no other VIDs.
I don't have any VSP reachable right now so please let me know the results.

Hope that helps,
Tomasz
Userlevel 5
Hi Tomasz,

Ah, that makes sense. I still have my traditional networking hat on thinking that I need VLAN 4053 in the sense I would for an MLAG ISC link.

Its telling me that in the error wording, just couldn't understand it.

I've messed around with the config a little since, but will post back when i get back to it.

Thanks
vlan member remove 1 1/1-1/4
interface Gigabitethernet 1/1-1/4
no spanning-tree mstp force-port-state enable
isis
isis spbm 1

Port 1/1 and 1/2 is part of CVLAN and SPBM VLANS are 4051 and 4052. NNI links cannot be part of any other vlan apart from BVLAN.

Please try with below command

int gig 1/3,1/4
isis
isis spbm 1
isis enable
Userlevel 1
Hello,

I think the problem might be that you are trying to configure ISIS on physical interface which is the member of MLT. If the ports in MLT are meant to be NNI ports, you must configure MLT as an ISIS interface.

For example:

code:
interface mlt 10
isis
isis spbm 1
isis enable
exit


The other message means that ISIS enabled interfaces must not be the members of other VLANs but B-VLANs. In your example B-VLANs are 4051 and 4052, but you add vlan 4053 to ports 1/1 and 1/2 and later you try to enable ISIS on those ports. That is also not correct.
Hello,

I think the problem might be that you are trying to configure ISIS on physical interface which is the member of MLT. If the ports in MLT are meant to be NNI ports, you must configure MLT as an ISIS interface.

For example:

code:
interface mlt 10
isis
isis spbm 1
isis enable
exit




The other message means that ISIS enabled interfaces must not be the members of other VLANs but B-VLANs. In your example B-VLANs are 4051 and 4052, but you add vlan 4053 to ports 1/1 and 1/2 and later you try to enable ISIS on those ports. That is also not correct.

That's correct,

Remove c-vlans from the ports and disable spanning tree. Then add the ISIS SPBM config to the MLT as Martin describes.

Reply