Solved

SPBM Setup with OSPF/ISIS and Local

  • 27 March 2019
  • 8 replies
  • 638 views

Hi Everyone,

Just had a question...

I am currently setting up an SPBM environment. I have a VSP-8404C setup with a x.x.x.2 address and another with a x.x.x..3 - VRRP for x.x.x.1.

When a VLAN is on both I can ping the relative x.x.x.1,2,3. But when a VLAN with an IP is only on one VSP-8404C and the default gateway is set to x.x.x.1, I am unable to ping it.

Is there a command to redistribute static or local IP's over SPBM/ISIS?

Thanks!
icon

Best answer by Paul A. Leroux 27 March 2019, 17:53

I would take your ISIS links down to one. I see you have four links.

but what you are tying to do is extremely straight forward, I think you have just missed a command somewhere.

here is a sample of a working config.


en
conf t
boot config flags rlogind
boot config flags telnetd
web-server en
no web-server sec
sys name 4003

spbm
prompt 4003
router isis
spbm 1
spbm 1 nick-name 0.40.03
spbm 1 b-vid 4051-4052 primary 4051
spbm 1 multicast enable
manual-area 49.0001

vlan create 4051 name "BVLAN-1" type spbm-bvlan
vlan create 4052 name "BVLAN-2" type spbm-bvlan




ip ecmp

router isis en


interface loopback 1
ip address 1 172.16.40.3/32
router isis
ip-source-address 172.16.40.3
spbm 1 ip en
router isis
redistribute direct
redistribute direct enable
exit
isis apply redistribute direct


cfm spbm en

vlan mem remove 1 1/1-1/50

interface gigabitEthernet 1/49,1/50
isis
isis spbm 1
isis en
no spanning-tree mstp force-port-state enable
y
untagged-frames-discard
no shut



vlan create 100 type port-mstprstp 0
vlan i-sid 100 100000
interface Vlan 100
ip address 10.1.1.4/24
ip spb-multicast en
ip vrrp version 2
ip vrrp address 1 10.1.1.1
ip vrrp 1 adver-int 30 backup-master enable holddown-timer 60
ip vrrp 1 priority 100
ip vrrp 1 enable

vlan members add 100 1/1-1/24
int gig 1/1-1/24
no shut
View original

8 replies

Userlevel 2
are the switches in a vIST pair?

make sure ISIS is running.

I would make sure all your vlans have an I-SID.

make sure you have local routes redistributed into the fabric.

router isis
redistribute direct
redistribute direct enable
exit
isis apply redistribute direct
Hi Paul,

Thanks for the quick reply.

They aren't in a vIST pair - I ran the SPBM run command and configured both VSP's and they are able to communicate with VLANs that have I-SID's on both, but its not redistributing local routes.

I've ran the commands listed and I am unable to ping a local interface, unless I add a static route.
Userlevel 2
lets look at the following from the switch with both vlans.

SHOW ISIS
show i-sid
Show ip routes
show isis adj
show isis interfaces
Hi Paul,


Nothing from NOC-Core3 and vice versa are available on either switch.

Here is the output:

show isis


====================================================================================================
ISIS General Info
====================================================================================================
AdminState : enabled
RouterType : Level 1
System ID : 646a.face.0002
Max LSP Gen Interval : 900
Metric : wide
Overload-on-startup : 20
Overload : false
Csnp Interval : 10
PSNP Interval : 2
Rxmt LSP Interval : 5
spf-delay : 100
Router Name : NOC-Core2
ip source-address : 10.0.255.1
ipv6 source-address :
ip tunnel source-address :
Tunnel vrf :
ip tunnel mtu :
Num of Interfaces : 5
Num of Area Addresses : 1

inband-mgmt-ip :
backbone : enabled
Dynamically Learned Area : 00.0000.0000
FAN Member : No

NOC-Core2:1#show i-sid

NOC-Core2:1#show i-sid


==========================================================================================
Isid Info
==========================================================================================
ISID ISID PORT MLT ORIGIN
ID TYPE VLANID INTERFACES INTERFACES
------------------------------------------------------------------------------------------
2 CVLAN 2 1/16,2/16 11-14,21-24, CONFIG
26-27,29
3 CVLAN 3 - 11-13,15 CONFIG
4 CVLAN 4 - 11-13,21 CONFIG
5 CVLAN 5 - 11-13 CONFIG
6 CVLAN 6 - - CONFIG
7 CVLAN 7 - 23 CONFIG
8 CVLAN 8 - 11-14,21-27,29 CONFIG
10 CVLAN 10 - 11-13,22,29 CONFIG
11 CVLAN 11 1/16 11-15,21-27, CONFIG
29-30
12 CVLAN 12 - 22-23,27 CONFIG
13 CVLAN 13 - 11-13,21,23,25 CONFIG
15 CVLAN 15 - 11-14 CONFIG
16 CVLAN 16 - 11-13,21-22,27 CONFIG
18 CVLAN 18 - 23 CONFIG

19 CVLAN 19 - 23 CONFIG
20 CVLAN 20 - 11-13,27,29 CONFIG
21 CVLAN 21 - 11-13,21-22 CONFIG
22 CVLAN 22 - 11-14 CONFIG
23 CVLAN 23 - 11-13,21-22 CONFIG
24 CVLAN 24 - 11-13,22 CONFIG
25 CVLAN 25 - 11-13,21-23,25 CONFIG
26 CVLAN 26 - 11-13 CONFIG
27 CVLAN 27 - 24-25 CONFIG
28 CVLAN 28 - 26-27,29 CONFIG
29 CVLAN 29 - 26 CONFIG
30 CVLAN 30 - 11-13,27,29 CONFIG
31 CVLAN 31 - 27,29 CONFIG
32 CVLAN 32 - 11-14,29 CONFIG
33 CVLAN 33 - 11-14,21-24, CONFIG
26-27,29
34 CVLAN 34 - 11-13,21,27 CONFIG
35 CVLAN 35 - 21 CONFIG
36 CVLAN 36 - 23 CONFIG
37 CVLAN 37 - 23 CONFIG
38 CVLAN 38 - 24-25 CONFIG
39 CVLAN 39 - 26-27,29 CONFIG
40 CVLAN 40 - 26 CONFIG

41 CVLAN 41 - 27,29 CONFIG
60 CVLAN 60 - 29 CONFIG
64 CVLAN 64 - 11-14,21-27,29 CONFIG
89 CVLAN 89 - 21-22,30 CONFIG
110 CVLAN 110 1/4 - CONFIG
128 CVLAN 128 - 11-14,21-27,29 CONFIG
371 CVLAN 371 1/5 - CONFIG
1003 CVLAN 1003 - - CONFIG
2000 CVLAN 2000 - 11-13 CONFIG
4000 CVLAN 4000 2/18 11-14,250 CONFIG
16777001 ELAN N/A - - CONFIG

c: customer vid u: untagged-traffic

All 47 out of 47 Total Num of i-sids displayed
NOC-Core2:1#show ip route

=====================================================================================================
IP Route - GlobalRouter
=====================================================================================================
NH INTER
DST MASK NEXT VRF/ISID COST FACE PROT AGE TYPE PRF
-----------------------------------------------------------------------------------------------------
10.0.0.0 255.255.255.0 10.0.0.2 - 1 15 LOC 0 DB 0
10.0.1.0 255.255.255.0 10.0.1.2 - 1 10 LOC 0 DB 0
10.0.2.0 255.255.255.0 10.0.2.2 - 1 2 LOC 0 DB 0
10.0.3.0 255.255.255.0 10.0.3.2 - 1 3 LOC 0 DB 0
10.0.5.0 255.255.255.0 10.0.5.2 - 1 5 LOC 0 DB 0
10.0.6.0 255.255.255.0 10.0.6.2 - 1 6 LOC 0 DB 0
10.0.7.0 255.255.255.0 10.0.7.2 - 1 7 LOC 0 DB 0
10.0.8.0 255.255.254.0 10.0.8.2 - 1 8 LOC 0 DB 0
10.0.11.0 255.255.255.0 10.0.11.2 - 1 11 LOC 0 DB 0
10.0.13.0 255.255.255.0 10.0.13.2 - 1 13 LOC 0 DB 0
10.0.15.0 255.255.255.0 10.0.15.2 - 1 12 LOC 0 DB 0
10.0.16.0 255.255.255.0 10.0.16.2 - 1 16 LOC 0 DB 0
10.0.19.0 255.255.255.0 10.0.19.2 - 1 19 LOC 0 DB 0
10.0.21.0 255.255.255.0 10.0.21.2 - 1 21 LOC 0 DB 0
10.0.23.0 255.255.255.0 10.0.23.2 - 1 23 LOC 0 DB 0
10.0.24.0 255.255.255.0 10.0.24.2 - 1 24 LOC 0 DB 0
10.0.25.0 255.255.255.0 10.0.25.2 - 1 25 LOC 0 DB 0

10.0.27.0 255.255.255.0 10.0.27.2 - 1 27 LOC 0 DB 0
10.0.28.0 255.255.255.0 10.0.28.2 - 1 28 LOC 0 DB 0
10.0.29.0 255.255.255.0 10.0.29.2 - 1 29 LOC 0 DB 0
10.0.30.0 255.255.255.0 10.0.30.2 - 1 30 LOC 0 DB 0
10.0.31.0 255.255.255.0 10.0.31.2 - 1 31 LOC 0 DB 0
10.0.32.0 255.255.255.0 10.0.32.2 - 1 32 LOC 0 DB 0
10.0.33.0 255.255.255.0 10.0.33.2 - 1 33 LOC 0 DB 0
10.0.34.0 255.255.255.0 10.0.34.2 - 1 34 LOC 0 DB 0
10.0.35.0 255.255.255.0 10.0.35.2 - 1 35 LOC 0 DB 0
10.0.36.0 255.255.255.0 10.0.36.2 - 1 36 LOC 0 DB 0
10.0.37.0 255.255.255.0 10.0.37.2 - 1 37 LOC 0 DB 0
10.0.38.0 255.255.255.0 10.0.38.2 - 1 38 LOC 0 DB 0
10.0.39.0 255.255.255.0 10.0.39.2 - 1 39 LOC 0 DB 0
10.0.40.0 255.255.255.0 10.0.40.2 - 1 40 LOC 0 DB 0
10.0.41.0 255.255.255.0 10.0.41.2 - 1 41 LOC 0 DB 0
10.0.64.0 255.255.240.0 10.0.64.2 - 1 64 LOC 0 DB 0
10.0.80.0 255.255.240.0 10.0.89.2 - 1 89 LOC 0 DB 0
10.0.96.0 255.255.240.0 10.0.110.2 - 1 110 LOC 0 DB 0
10.0.128.0 255.255.224.0 10.0.128.2 - 1 128 LOC 0 DB 0
10.0.255.1 255.255.255.255 10.0.255.1 - 1 0 LOC 0 DB 0
10.37.4.0 255.255.255.0 10.37.4.2 - 1 60 LOC 0 DB 0
172.20.200.0 255.255.254.0 172.20.200.2 - 1 4000 LOC 0 DB 0
172.23.20.0 255.255.255.0 172.23.20.181 - 1 20 LOC 0 DB 0

172.23.22.0 255.255.255.0 172.23.22.2 - 1 22 LOC 0 DB 0
172.23.26.0 255.255.255.0 172.23.26.181 - 1 26 LOC 0 DB 0
192.168.9.8 255.255.255.248 192.168.9.9 - 1 3009 LOC 0 DB 0
192.168.12.8 255.255.255.248 192.168.12.9 - 1 3012 LOC 0 DB 0
192.168.21.8 255.255.255.248 192.168.21.9 - 1 3021 LOC 0 DB 0
192.168.29.0 255.255.255.248 192.168.29.1 - 1 1029 LOC 0 DB 0
192.168.42.8 255.255.255.248 192.168.42.9 - 1 3042 LOC 0 DB 0
192.168.49.0 255.255.255.248 192.168.49.1 - 1 1049 LOC 0 DB 0
192.168.50.0 255.255.255.248 192.168.50.1 - 1 2050 LOC 0 DB 0
192.168.51.0 255.255.255.248 192.168.51.1 - 1 2051 LOC 0 DB 0
192.168.53.0 255.255.255.248 192.168.53.1 - 1 2053 LOC 0 DB 0
192.168.54.0 255.255.255.248 192.168.54.1 - 1 1054 LOC 0 DB 0
192.168.55.0 255.255.255.248 192.168.55.1 - 1 2055 LOC 0 DB 0
192.168.56.0 255.255.255.248 192.168.56.1 - 1 2056 LOC 0 DB 0
192.168.57.0 255.255.255.248 192.168.57.1 - 1 2057 LOC 0 DB 0
192.168.58.0 255.255.255.248 192.168.58.1 - 1 2058 LOC 0 DB 0
192.168.60.0 255.255.255.248 192.168.60.1 - 1 2060 LOC 0 DB 0
192.168.61.0 255.255.255.248 192.168.61.1 - 1 2061 LOC 0 DB 0
192.168.62.0 255.255.255.248 192.168.62.1 - 1 1062 LOC 0 DB 0
192.168.63.0 255.255.255.248 192.168.63.1 - 1 2063 LOC 0 DB 0
192.168.64.8 255.255.255.248 192.168.64.9 - 1 3064 LOC 0 DB 0
192.168.65.0 255.255.255.248 192.168.65.1 - 1 1065 LOC 0 DB 0
192.168.67.0 255.255.255.248 192.168.67.1 - 1 2067 LOC 0 DB 0

109 out of 109 Total Num of Route Entries, 109 Total Num of Dest Networks displayed.
--------------------------------------------------------------------------------------------------
TYPE Legend:
I=Indirect Route, D=Direct Route, A=Alternative Route, B=Best Route, E=Ecmp Route,
U=Unresolved Route, N=Not in HW, F=Replaced by FTN, V=IPVPN Route, S=SPBM Route
PROTOCOL Legend:
v=Inter-VRF route redistributed
NOC-Core2:1#show isis adj


====================================================================================================
ISIS Adjacencies
====================================================================================================
INTERFACE L STATE UPTIME PRI HOLDTIME SYSID HOST-NAME STATUS
----------------------------------------------------------------------------------------------------
Port1/1 1 UP 1d 03:11:11 127 25 646a.face.0003 NOC-Core3 ACTIVE
Port1/2 1 UP 1d 03:11:04 127 23 646a.face.0003 NOC-Core3 BACKUP
Port2/1 1 UP 1d 03:10:45 127 21 646a.face.0003 NOC-Core3 BACKUP
Port2/2 1 UP 1d 03:10:58 127 24 646a.face.0003 NOC-Core3 BACKUP

--------------------------------------------------------------------------------
4 out of 4 interfaces have formed an adjacency
--------------------------------------------------------------------------------

NOC-Core2:1#show isis inter

NOC-Core2:1#show isis interface


====================================================================================================
ISIS Interfaces
====================================================================================================
IFIDX TYPE LEVEL OP-STATE ADM-STATE ADJ UP-ADJ SPBM-L1-METRIC
----------------------------------------------------------------------------------------------------
Port1/1 pt-pt Level 1 UP UP 1 1 10
Port1/2 pt-pt Level 1 UP UP 1 1 10
Port2/1 pt-pt Level 1 UP UP 1 1 10
Port2/2 pt-pt Level 1 UP UP 1 1 10
Port1/6 pt-pt Level 1 DOWN UP 0 0 10

--------------------------------------------------------------------------------
5 out of 5 Total Num of ISIS interfaces
--------------------------------------------------------------------------------

NOC-Core2:1#
Userlevel 2
I would take your ISIS links down to one. I see you have four links.

but what you are tying to do is extremely straight forward, I think you have just missed a command somewhere.

here is a sample of a working config.


en
conf t
boot config flags rlogind
boot config flags telnetd
web-server en
no web-server sec
sys name 4003

spbm
prompt 4003
router isis
spbm 1
spbm 1 nick-name 0.40.03
spbm 1 b-vid 4051-4052 primary 4051
spbm 1 multicast enable
manual-area 49.0001

vlan create 4051 name "BVLAN-1" type spbm-bvlan
vlan create 4052 name "BVLAN-2" type spbm-bvlan




ip ecmp

router isis en


interface loopback 1
ip address 1 172.16.40.3/32
router isis
ip-source-address 172.16.40.3
spbm 1 ip en
router isis
redistribute direct
redistribute direct enable
exit
isis apply redistribute direct


cfm spbm en

vlan mem remove 1 1/1-1/50

interface gigabitEthernet 1/49,1/50
isis
isis spbm 1
isis en
no spanning-tree mstp force-port-state enable
y
untagged-frames-discard
no shut



vlan create 100 type port-mstprstp 0
vlan i-sid 100 100000
interface Vlan 100
ip address 10.1.1.4/24
ip spb-multicast en
ip vrrp version 2
ip vrrp address 1 10.1.1.1
ip vrrp 1 adver-int 30 backup-master enable holddown-timer 60
ip vrrp 1 priority 100
ip vrrp 1 enable

vlan members add 100 1/1-1/24
int gig 1/1-1/24
no shut
Thanks for your help!
I was missing the "spbm 1 ip enable command"
Userlevel 2
@aksidents No problem. I had a feeling it was something small.


that feature is called "IP Shortcuts". And it needs to be running if you want to route IP between vlans through the fabric.

https://gtacknowledge.extremenetworks.com/articles/How_To/000036109

Reply