Question

Dell Wireless 1820A & AP230, only connect at 400Mbps

  • 20 February 2021
  • 24 replies
  • 166 views

Replaced (same physical place, same wifi in laptop)

Zyxel NWA1123-ACv2 with AP230

On 5Ghz connection speed dropped from 768Mbps to only 400Mbps (that is HALF)

Not something I expected.

Played with all the settings available in Connect, no difference, cannot make it nowhere near the same speed.

Anybody has any ideas?

 

Thanks

 

sebus


24 replies

Userlevel 7
Badge +1

Hello Sebus,

768Mbps to 400Mbps looks a littebit like one AP uses 80MHz and the other 40MHz wide channels. I assume that the client supports 2x2 MIMO with 802.11ac and that this is configured in the driver.

Im am not sure because in my opinion 768 is no speed in the MCS for VHT (802.11ac).

To be sure, the easiest way is to do a Wireshark trace in the air and check the settings used in the packets.

 

Using 80MHz configured on AP230 radio profile, I cannot connect at all to the 5Ghz network (get connected to 2.4Ghz only)

Dropping to 40MHz I get the 400Mbps

 

SSID:    *************
Protocol:    802.11ac
Security type:    WPA2-Personal
Network band:    5 GHz
Network channel:    44
Link-local IPv6 address:    fe80::ac24:f0af:755a:a0b9%11
IPv4 address:    192.168.88.98
Manufacturer:    Broadcom
Description:    Dell Wireless 1820A 802.11ac
Driver version:    1.555.0.0
Physical address (MAC):    30-52-CB-**-**-**
 

Name:    Wi-Fi
Description:    Dell Wireless 1820A 802.11ac
Physical address (MAC):    30:52:cb:**:**:**
Status:    Operational
Maximum transmission unit:    1500
Link speed (Receive/Transmit):    144/400 (Mbps)
DHCP enabled:    Yes
 

 

The latest Broadcom driver for this card 1.555.0.0 (from 26/11/2015) does not have any configurable settings for 2x2 MIMO (and not even a setting for Prefer 5Ghz, hence I needed to do it in CLI of the AP)

Yet with Zyxel it was working oob at full expected speed

 

 

Userlevel 7
Badge +1

If you the client uses 2.4 or 5 Ghz is a client decision, not the decision of the AP (all solutions to force a client to sepcific frequency from the AP side is vendor proprietary). The easiest way to force a client to 2.4 or 5 Ghz is to use different SSIDs for 2.4 und 5 Ghz.

This is a good approch to test the speed on 5 Ghz.

 

 

It is not client decision if the driver has no such option!

Client will go for 2.4 because that is easier.

Only way to get it using 5Ghz is to have in config:

radio profile uknh_radio_ng_ng0 band-steering enable
radio profile uknh_radio_ng_ng0 band-steering mode force-5g

which works well and makes the client connect to 5Ghz (as show above - Network band:    5 GHz)

So there is no issue where client connects!

I have ofcourse tested also with differently named SSID for 5Ghz (getting exactly the same results = 400Mbps)

Dell 1820A connection to AP230

But the whole point of this exercise was to NOT have separate SSIDs, but a single blanket one that covers everywhere. Which is fine, apart from the speed of connection

AP230 can do 1.3 Gbps in the 5 GHz 802.11ac mode

Zyxel config is:

 

Dell 1820A connection to Zyxel

 

Anybody has any idea to what CLI command this translates (on AC radio profile)?

 

Enable Aggregate MAC Protocol Data Units: Select the check box to enable AMPDU (Aggregate MAC Protocol Data Unit) transmissions to reduce overhead when the transmission channel is busy. When you enable AMPDU, the HiveAP combines data frames into fewer, larger frames before transmitting them and is able to recognize the format of larger frames when it receives them. Generally, enabling AMPDU increases performance. Clear the check box to disable AMPDU. By default, it is enabled.

 

 

My full radio profile for 802.11ac:

 

radio profile uknh_AP230_radio_ng_ac0
radio profile uknh_AP230_radio_ng_ac0 phymode 11ac
radio profile uknh_AP230_radio_ng_ac0 dfs
radio profile uknh_AP230_radio_ng_ac0 channel-width 40
radio profile uknh_AP230_radio_ng_ac0 acsp max-tx-power 15
radio profile uknh_AP230_radio_ng_ac0 acsp access channel-auto-select time-range 01:00 04:00
radio profile uknh_AP230_radio_ng_ac0 acsp interference-switch enable
radio profile uknh_AP230_radio_ng_ac0 scan access client power-save
radio profile uknh_AP230_radio_ng_ac0 max-client 50
radio profile uknh_AP230_radio_ng_ac0 interference-map enable
radio profile uknh_AP230_radio_ng_ac0 interference-map cu-threshold 35
radio profile uknh_AP230_radio_ng_ac0 interference-map crc-err-threshold 35
radio profile uknh_AP230_radio_ng_ac0 deny-client 11b
radio profile uknh_AP230_radio_ng_ac0 short-guard-interval
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11b rate 11 success 60 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11b rate 5.5 success 70 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11g rate 36 success 70 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11g rate 24 success 80 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11a rate 36 success 70 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11a rate 24 success 80 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11n rate mcs4/2 success 80 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11n rate 54 success 70 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11ac rate mcs2/2 success 80 usage 50
radio profile uknh_AP230_radio_ng_ac0 benchmark phymode 11ac rate 54 success 70 usage 50
radio profile uknh_AP230_radio_ng_ac0 frameburst
radio profile uknh_AP230_radio_ng_ac0 acsp power-maxdrop 9

 

 

Userlevel 7
Badge +1

Anybody has any idea to what CLI command this translates (on AC radio profile)?

 

Enable Aggregate MAC Protocol Data Units: Select the check box to enable AMPDU (Aggregate MAC Protocol Data Unit) transmissions to reduce overhead when the transmission channel is busy. When you enable AMPDU, the HiveAP combines data frames into fewer, larger frames before transmitting them and is able to recognize the format of larger frames when it receives them. Generally, enabling AMPDU increases performance. Clear the check box to disable AMPDU. By default, it is enabled.

 

 

There are two settings regarding frame aggregation:

 

radio profile <sting> ampd  for a-mpdu

and

radio profile <sting> amsd for a-msdu

Userlevel 7
Badge +1

T

It is not client decision if the driver has no such option!

Client will go for 2.4 because that is easier.

Just because the client does not offer an option to select a frequency does not mean that the client does not make the decision. The AP can offer the client the SSID and connection options, but it cannot decide which of the options the client has to uses, nor which frequency band it uses. 

This also applies when band steering is switched on. 

Userlevel 7
Badge +1

To enable frame aggregation there are two CLI commands:

radio profile <string> ampdu for A-MPDU

and

radio profile <string> amsdu for A-MSDU

 

Well, what can I say to convince you?

With no option in driver, withOUT “band-steering mode force-5g” in AP config client will connect only to 2.4Ghz, WITH “band-steering mode force-5g” in AP config, same client will connect to 5Ghz

 

While I know the commands for A-MPDU & A-MSDU because the lot is available ie here

I have checked my enterprise config & while Enable aggregate... is checked in ac radio profile, it does not reflect in the actual config, it only shows in the ng radio profile (hence the question, because it makes no sense to me)

Also tested another different machine, which also “locks” at max 400Mbps on 5Ghz

So something is definitely not correct

Userlevel 7
Badge +1

Hello,

You don't have to convince me. I understand that you cannot set the channel selection on your client and that therefore only bandsteering on the AP helps (since you want to use one SSID in both frequency bands).

I just wanted to point out, that by wifi standard, it is a decision of your client and therefore bandsteering is only a workaround. But it's nice if it works.

Regarding frame aggregation: According to standard 802.11ac, frame aggregation is ALWAYS used here and therefore it does not have to be explicitly turned on. For example see here:

 

https://www.oreilly.com/library/view/80211ac-a-survival/9781449357702/ch03.html


Specifically: "802.11ac, however, adds an interesting new take on aggregation: all frames transmitted use the aggregate MPDU (A-MPDU) format. Even a single frame transmitted in one shot is transmitted as an aggregate frame."

 

 

 

Userlevel 7
Badge +1

As I said, if you want to know what is happening look at the packets in the air, they don't lie and in the beacons you can see what the AP offers and what the client chooses from the offer.

Userlevel 6
Badge

Hi Sebus,

 

MCS data rate is chosen by a transmitting device algorithm (client or AP - it’s independent in each direction) based on several criteria, in particular RF-related indicators such as SNR. Are both APs in the same distance to the client device, ie. is the RSSI on the client equal? Are both APs on the same channel or not? If not, what other traffic (nearby APs, client devices) appears on the channels?

Just FYI, you won’t get 1.3 Gbps datarate unless you have 3x3 MIMO WLAN on a device, here you can find some examples: clients.mikealbano.com

BTW forcing 5 GHz might produce other issues when a dual-band device keeps trying to connect to the SSID on 2.4 GHz band because of its internal algorithm decision flow. Without that, clients are going to jump between bands occasionally though. So if separate SSIDs are not an option, I’d recommend to consider ‘Encourage’ instead of ‘Force’.

 

Hope that helps,

Tomasz

Thanks guys, but still none of the above changes the fact that cheap-er Zyxel AP seems to provide way better connection speed than AP130/AP230 (tested with both), which does not look correct to me.

I do not expect 1.3 Gbps, but at least would like to match the Zyxel 866.5…

I compared AP230/AP130 to Zyxel in exactly the same physical conditions (disconnect one, connect the other one)

Userlevel 6
Badge

Hi Sebus,

 

That sounds totally reasonable that you’d like to see the highest achievable data rate for your client device on both, and that is in fact possible for 1820A chipset to reach 866.7 Mbps. We can definitely aim for this in lab environment. I have never had a problem to get it so far on any Extreme APs (IdentiFi/WiNG/XIQ). There is less WLAN chipset manufacturers than WLAN infrastructure/client vendors. Datarate-related components are pretty basic in that terms, so if there are no sw bugs (on either side) or misconfig or bad environment it should work rather similar on any AP/STA equipment pair (assuming same characteristics: MIMO, channel width, RSSI and so on). To be clear, 80 MHz is a must for 866.7 Mbps datarate to be achievable with 2x2 MIMO 11ac device, see here: https://mcsindex.net/

Please let me make perfectly sure about this: is RSSI on the client the same for the signals from both XIQ/Zyxel during testing? Like -50 dBm vs -50 dBm? I’m asking for this as I see some glimpses of ACSP on the XIQ side. Moreover (maybe it’s because of late hour) I don’t see TxP setting on Zyxel. As a good practice, TxP should not be set to maximum and it should not be too low if we aim for both high datarate and effective throughput.

If that potential testing environment issue mentioned above was checked, I would only recommend contacting GTAC so they can assist in narrowing down possible causes with XIQ AP (AP software bug, client device driver issue, RF thing, configuration thing). Or, if it’s nothing urgent, maybe few others will have some food for thoughts as well. @Sam Pirok@Christoph S.@Ovais Qayyum

 

Hope that helps,

Tomasz

It is not urgent. And I do not think for Connect (no license) I will get any support from GTAC...

As stated above, with explicitly specified 80 Mhz in AP radio profile in AP230, I cannot connect at ALL to this network. I can only connect with either 20 or 40

Userlevel 6
Badge

Hi Sebus,

 

I’d say we should focus on troubleshooting 80 MHz issue with AP230 then. I’ll try to reproduce the issue to look around the AP logs myself but hopefully someone already fell into that problem before.

Could you please tell us the firmware version currently running on that AP?

 

Take care,
Tomasz

Latest available for this AP in ExtremeCloudIQ - 10.0.10.2

Anybody? Or am I the only one with this issue?

 

sebus

Userlevel 6
Badge

Hi Sebus,

 

Sorry for keeping you waiting. I was trying to reproduce the issue on my equipment but no luck.

I was also lurking around and saw Dell 1820A is using BCM94350ZAE chipset as its core. Someone had reported some issues when trying to use it for 80 MHz Wi-Fi and there was some country-code related stuff that seems too much hassle:https://osxlatitude.com/forums/topic/11322-broadcom-bcm4350-cards-under-high-sierramojavecatalinabig-sur/

Unfortunately such issue cannot be excluded. Also it might be an issue due to some newer features enabled that are not understood by the client device chipset. I had such situations with 802.11k for some VoIP phones which, I thought, just doesn’t support that; but when I enabled it for other stations, the phones started loosing connection with their server quite frequently and audio was in one direction only.

If it’s not an issue, I’d try to double-check 1820A’s drivers, I could see version 1.566.0.0 at Dell’s website. Or call GTAC so they could deep-dive to determine the possible reason based on their experience and more digging in some diagnostic traces.

I hope someone here had similar issue with this card though.

 

Cheers,

Tomasz

In business setup 80 Mhz is never enabled by any Extreme Partners (did check it with one we using)

So nobody really cares if it works or does not.

It is different for home use, but still wonder how many people actually care how they connect (as long as they do)

Thanks, there is indeed 1.566.0.0 driver (which needs to be installed manually, because otherwise one gets an: “[ERROR]  No compatible hardware found. The software you are attempting to install is not supported on this system. The software will not be installed."

Will need to re-test the 80 Mhz setup soon

 

sebus

 

Userlevel 7
Badge +1

Hello Sebus,

as already written, I recommend creating a trace in the air when testing, this usually helps to see what goes wrong when negotiating the speed.

Userlevel 6
Badge

Hi Sebus,

 

You are totally right, 80 MHz is unlikely to be used in an enterprise, I see few people using XIQ at home (or home office) however, so I hope there is someone with similar issue on Earth. ;)

But yeah, noone seeing this topic probably had such issue, we can try to gather some data from 802.11 captures or AP logs (or client device WLAN driver logs if possible to gather) and review it together too see possible causes but GTAC will do the same, plus there’s a chance they have already encountered something similar in the past.

 

Kind regards,

Tomasz

Reply