Question

The 5G band steering doesn't works.


Userlevel 1

 

I have been read a lot of posts here and materials about how to encourage client to associated 5G radio, but failed.

these are the config:

additional settings - optional settings

1. turnoff 2.4Ghz 1-24, set 36 to be basic

2. turnoff 5Ghz    1-18, set 18 to be basic

radio profile
3. ng0_clone 2.4Ghz
 deny-client: 80211b
 maximum transmit power: 10
 band-streeing: encourage 5 ghz band usage
 number of connection attempts from 2.4Ghz client to ignore before responding: 3
 weak signal probe request suppression: off
 safety net: off
 enable frame burst: off
 enable short guard interval: on
 enable aggregate mac protocol data units: on
 enable VHT for 2.4Ghz: off


2. ac0_clone 5Ghz

 maximum transmit power: 14
 number of connection attempts from 2.4Ghz client to ignore before responding: 3
 high density configuration: off
 client load balancing: off
 radio load balancing: off
 weak signal probe request suppression: off
 safety net: off
 enable frame burst: on
 enable short guard interval: on
 enable aggregate mac protocol data units: on
 enable transmit beamforming: on


but the nearly half of clients choose to associated 2.4Ghz band, how to solve this problem?

 


14 replies

Userlevel 7

It is ultimately a client side decision on which radio to use. There may be devices specific settings influencing that behavior. You’ve set the radio profile to encourage 5GHz use, if the device is able to use 5GHz it will comply, otherwise it will use 2.4GHz instead after rejecting the 5GHz suggestion 3 times. 

 

As a side note, I wouldn’t personally get that aggressive with turning off the data rates. You might have clients with a weaker connection that could typically still connect but are now blocked because they don’t meet the basic data rate you’ve set. Just something to think about. 

Userlevel 1

hi, sam

I tried to turn both radio profile’s band-steering mode to prefer-5g, but it seems doesn’t help anyway, hmm, I would like to capture the frame received on ap which sent from client to check if it could omit both 2.4Ghz and 5Ghz probe request. how to do that?

Userlevel 7

I’d recommend a wireless packet capture so we can see the rejection message from the device. The easiest way to do this would be to test with an open SSID, just to make the packet capture easier to work with. If you can open a case and attach the packet capture file to the case, we can assist you with reading the packet capture and forming the next needed steps. 

Userlevel 1

@Sam Pirok I don’t have service contracts, could I open a case?

the situation is even worse now. almost half of the clients are attached to the 2.4G wifi

AH230-492bc0(jkzq-core)#show sta
Chan=channel number; Pow=Power in dBm;
A-Mode=Authentication mode; Cipher=Encryption mode;
A-Time=Associated time; Auth=Authenticated;
UPID=User profile Identifier; Phymode=Physical mode;

Ifname=wifi0.1, Ifindex=14, SSID=aerohive:
Mac Addr IP Addr Chan Tx Rate Rx Rate Pow(SNR) A-Mode Cipher A-Time Phymode LDPC Tx-STBC Rx-STBC SM-PS Chan-width Release S
-------------- --------------- ---- ------- ------- -------- -------------- -------- --------
4c34:887c:9ceb 192.168.10.36 6 86.7M 58.5M -56(39) wpa2-psk aes ccmp 00:02:23 11ng Yes Yes Yes static 20MHz No Good
4403:2c7c:0466 192.168.9.32 6 144.4M 144.4M -38(57) wpa2-psk aes ccmp 00:05:11 11ng Yes Yes Yes static 20MHz No Good
3402:86aa:4042 192.168.8.33 6 65M 54M -42(53) wpa2-psk aes ccmp 00:25:37 11ng Yes Yes Yes static 20MHz No Good

Ifname=wifi1.1, Ifindex=16, SSID=aerohive:
Mac Addr IP Addr Chan Tx Rate Rx Rate Pow(SNR) A-Mode Cipher A-Time Phymode LDPC Tx-STBC Rx-STBC SM-PS Chan-width Release S
-------------- --------------- ---- ------- ------- -------- -------------- -------- -------- ------- ---- ------- ------- -------- ---------- ------- -
2016:b965:c674 192.168.9.58 40 173.3M 173.3M -48(47) wpa2-psk aes ccmp 00:06:00 11ac Yes Yes Yes static 20MHz No Good
4403:2c79:b4ae 192.168.9.42 40 173.3M 115.6M -50(45) wpa2-psk aes ccmp 00:06:06 11ac Yes Yes Yes static 20MHz No Good
40a1:08e3:5fc0 192.168.10.31 40 144.4M 12M -59(36) wpa2-psk aes ccmp 00:17:50 11ac Yes Yes Yes static 20MHz No Good
5c3a:454d:f3d5 192.168.9.61 40 144.4M 6M -42(53) wpa2-psk aes ccmp 01:05:40 11ac Yes Yes Yes static 20MHz No Good

AH230-492bc0(jkzq-core)#show int wifi0
AC=access category; be=best-effort; bg=background; vi=video; vo=voice;
AIFS=Arbitration Inter-Frame Space; Txoplimit=transmission opportunity limit;
IDP=Intrusion detection and prevention; BGSCAN=background scan; PS=Power save;
HT=High throughput; A-MPDU=Aggregate MAC protocol data unit;
DFS=Dynamic Frequency Selection; CU=Channel Utilization;
EIRP=Effective Isotropic Radiated Power (Transmit Power + Max Antenna Gain + Max TX Chains Gain);
OFDMA=Orthogonal Frequency Division Multiple Access;
BSS_Color= Basic Service Set Color; TWT=Target Wake Time;

Summary state=High collision;
...
Radio profile=rp_ng0; IDP profile=N/A;
Presence profile=N/A; Presence state=disabled;
Beacon interval=100; Max clients number=30;
Phymode=11ng; Short preamble mode=enabled;
Tx Chain=static 3; Rx Chain=static 3;
....
Rx packets=17227247; errors= 2803; dropped= 2;
Tx packets=19127910; errors=78449; dropped=241299;
Rx bytes=2749837283 (2.561 GB); Tx bytes=1054004608 (1005.177 MB);
...
Rx airtime=255.33 s; Tx airtime=6698.12 s; CRC error airtime=1740.43 s;
Rx airtime percent=0.16%; Tx airtime percent=0.71%; CRC error airtime percent=1.76%;
Tx utilization=1%; Rx utilization=29%; Interference utilization=9%; Total utilization=39%;
Backhaul failover=enable; Trigger time=2s;
Benchmark 11a score=222000; 11b score=50500; 11g score=222000; 11n score=501000; 11ac score=889000;
A-MSDU=disabled; A-MPDU limit=1048575;
VHT support in 2.4G interface=disabled;
Frameburst=disabled;
Alternate radio profile=disabled;


AH230-492bc0(jkzq-core)#show int wifi1
...

Summary state=Good;
Mode=access; Radio disabled=no;
...
Tx range=300m; Noise floor=-95dBm; Tx power control=disabled;
...
Rx packets=9120723; errors= 9396; dropped= 49;
Tx packets=6837867; errors=19651; dropped=4851;
Rx bytes=3420290074 (3.185 GB); Tx bytes=1997795997 (1.861 GB);
ACSP use last selection=disabled;
...
Rx airtime percent=0.17%; Tx airtime percent=1.36%; CRC error airtime percent=0.02%;
Tx utilization=1%; Rx utilization=1%; Interference utilization=3%; Total utilization=5%;
Backhaul failover=enable; Trigger time=2s;
Running average Tx CU=1%; Rx CU=2%; Interference CU=1%; Noise=-94dBm;
Short term means average Tx CU=1%; Rx CU=3%; Interference CU=1%; Noise=-95dBm;
Snapshot Tx CU=1%; Rx CU=3%; Interference CU=1%; Noise=-95dBm;
CRC error rate=1%;

 

Userlevel 4

What are the TX power levels for the 2.4 and 5GHz interface of that AP? Also I presume those clients are 5GHz capable?

Userlevel 1

Hi, ash

the tx power level of 2.4 is 10, and 5 is 14.

yes, of coz, those client which associated with 2.4 are capable of 5Ghz except this one 3402:86aa:4042

Userlevel 1

well, there is another question, how to change the tx power level below 10? It seems the xiq do not allow to do that.

Userlevel 7

Without a support contract you would not be able to open a case. You can adjust the power level on the AP by going to Monitor> Devices> Click on the blue host name of the AP> Choose Configure on the left hand side menu> Go to Interface Settings> Scroll down to the Transmission Power section, change this to manual if it isn’t there already, then use the slider bar to set the power level from 1-20dBm. 

 

You could also try disabling 2.4Ghz on some APs depending on how many APs you have broadcasting. That would leave the 2.4GHz signal for devices that can’t use 5GHz, but at the same time it will make the 2.4GHz signal significantly weaker than the 5GHz signal.

 

Is there a particular reason you don’t want clients on 2.4GHz? 

Userlevel 1

@Sam Pirok look at the preview comments. the 2.4G’s Summary state=High collision, that is the reason I would like to encourage clients to 5G.

Userlevel 1

thanks @Sam Pirok , I disable 2.4 on same ap, and change the 2.4G tx power to 5 and going to observe the effect. I have another quesiton.

`show int wifi1` has CRC error rate, but `show int wifi0` doesn’t have it. how to check the CRC error rate of wifi0?

Userlevel 7

You should see the CRC error rate with the command “show int wifi0” and/or “show int wifi0 _count”. This guide goes in to more detail on how to read the outputs of those commands and what you can do to help reduce the amount of interference on your radios. 

Userlevel 1

wow, extreme did a good job on document, the article was updated a lot info recently after I check it couple weeks ago.

Userlevel 1

@Sam Pirok a problem with that article, some pictures are not distinct enough.

Userlevel 7

Thank you for letting me know, I’ve flagged that article for an update so we can get some clear pictures in there. I appreciate the feedback!

Reply