Header Only - DO NOT REMOVE - Extreme Networks

ap automatically downgrading


Hi

We are trying to upgrade 3805i Access Point from 9.15.x to 9.21.x , AP GETS UPGRADED to 9.21.x BUT Immediately degrades to 9.15.x automatically.

12 replies

Userlevel 7
Sorry but that is hard to believe without any screenshots, logs ...which you didn't provide.

My assumption is that the upgrade failed and that is the reason the AP is still on 9.15 after the upgrade attempt.

Set the log level to informational and check the output from the log.
What is the controller settings for AP maintenance mode - controlled upgrade enabled or disabled.
Userlevel 7
The controller is on 9.21 - correct ?
yes
Userlevel 7
arabinda mohanty wrote:

yes

please provide the exact version .... 9.21.x.x

Userlevel 7
OK so the AP is running 9.15, but I don't see any proof that there is a upgrade and also a downgrade after that as you've described the issue.
i thought why dont i put one more wifi ...
is it solution?
Userlevel 1
Hi Aravind

You said AP upgraded to 9.21.x.x and immediately it rolled back to 9.15.x.x

Which means AP has upgraded successfully..

You try to delete the AP from controller, again the ap gets adopted , then retry to upgrade the AP
Userlevel 7
Let's do it step by step....

1) in the controller GUI go to > wireless APs > Global Settings > AP maintenance > is the upgrade bevahior set to ...
a) Upgrade when AP connects using settings from Controlled Upgrade
OR
b) Always upgrade AP to default image

2) go to > Controller > Logs >set "Wireless Controller Log Level:" AND "Wireless AP Log Level:" to informational

3) try again to upgrade the AP and after the whole process go to > Logs > Severity: All
copy/paste the result here or take a screenshot to post
Userlevel 4
Let assume the upgrade worked before..then the solely posibility that the AP revert his code back is
if he resets 3 times . In this case the AP will take his 2nd image / backup image.
If you upgrade the AP twice then yo will have the same code as your primary code and for your secondary / backup code.
In this situation it shouldn't back after a reset.
FYI.

But till get this approved it's the best you try it wit controlled upgarde.
If your AP are behing Cloud/Internet/VPN reduce the MTU size to 1400.
Maybe tftp(upgrade) is maybe forbidden or the MTU size was to big?!

Good luck

Umut
According to your suggestion i replaced one ap and automatically it upgraded to my firmware...
now it working fine.......
Userlevel 1
Great !!

It worked for you ...... 😉

Reply