AP3935i error message "BEACON_EVENT_SWBA_SEND_FAILED"


We are deploying 3935i access points and having issues. Many of them are showing an error in the ap.log "BEACON_EVENT_SWBA_SEND_FAILED"

It looks to me like a firmware issue. Any idea what it really means?

7 replies

Userlevel 7
Please provide the software version that is running on the controller.
Userlevel 4
Intermittent messages usually ok if no other symptoms. If there is a flood, then there may be an issue.

Would be nice to see the ap.log to see the msg in context. Can get that from logs->ap traces->select the ap and retrieve trace.
We were on 10.01.04 firmware, went back to 10.01.03 but no change. After the "Beacon Event" msg starts the access point reboots.

May 19 23:07:24 kernel: ieee80211_wireless.c:5735-ieee80211_ioctl_setparam()-IEEE80211_PARAM_AUTHMODE error=0 origval=5 value=5
May 19 23:07:29 hostapd0: 03083:m2TaskApp.c:355-m2CreateQue_cmn()-name=/tHostapd0 max=32 size=1500
May 19 23:07:29 kernel: m2TaskDrv.c:1538-drvIoctl()-IOCTL_M2TASK_DRV_REGISTER: tid = 32
May 19 23:07:29 kernel: m2TaskDrv.c:542-m2CreateQ()-dsttid 32
May 19 23:07:29 kernel: m2TaskDrv.c:555-m2CreateQ()-FULL queue creation for tid = 32
May 19 23:07:29 kernel: m2TaskDrv.c:580-m2CreateQ()-dsttid 32 tabtid 32 now initialized
May 19 23:07:29 hostapd0: 03083:m2TaskApp.c:428-m2CreateQue_cmn()-m2CreateQue_cmn: tid 32 MDr 40 WDr 41 Devr 43 name /tHostapd0W
May 19 23:07:38 kernel: [wifi1] FWLOG: [96609] VDEV_MGR_HP_START_TIME ( 0x2, 0x96c, 0x3d9f001 )
May 19 23:07:38 kernel: [wifi1] FWLOG: [96609] RESMGR_OCS_GEN_PERIODIC_NOA ( 0x1 )
May 19 23:07:38 kernel: [wifi1] FWLOG: [96609] RESMGR_OCS_GEN_PERIODIC_NOA ( 0x0 )
May 19 23:07:38 kernel: [wifi1] FWLOG: [96609] VDEV_MGR_AP_TBTT_CONFIG ( 0x2, 0x96c, 0x0, 0x0 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136052] WAL_DBGID_SECURITY_ENCR_EN ( 0x5ae0 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136052] WAL_DBGID_SECURITY_MCAST_KEY_SET ( 0x1 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136053] WAL_DBGID_SECURITY_ENCR_EN ( 0x5ae0 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136053] WAL_DBGID_SECURITY_MCAST_KEY_SET ( 0x2 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136053] WAL_DBGID_SECURITY_ENCR_EN ( 0x5ae0 )
May 19 23:07:41 kernel: [wifi0] FWLOG: [136053] WAL_DBGID_SECURITY_MCAST_KEY_SET ( 0x1 )
May 19 23:07:45 kernel: [wifi1] FWLOG: [97387] BEACON_EVENT_SWBA_SEND_FAILED ( )
May 19 23:07:45 kernel: [wifi1] FWLOG: [98040] BEACON_EVENT_SWBA_SEND_FAILED ( )
May 19 23:07:45 kernel: [wifi1] FWLOG: [98426] BEACON_EVENT_SWBA_SEND_FAILED ( )
May 19 23:07:48 kernel: [wifi1] FWLOG: [99473] BEACON_EVENT_SWBA_SEND_FAILED ( )
May 19 23:07:51 kernel: [wifi1] FWLOG: [99739] BEACON_EVENT_SWBA_SEND_FAILED ( )
May 19 23:07:51 kernel: [wifi1] FWLOG: [100128] BEACON_EVENT_SWBA_SEND_FAILED ( )
Userlevel 4
It would be good to see the entire ap trace file ( the bundle contains many files ). Perhaps best way is to open a gtac case to track the issue, and attach the trace file of the problem ap(s) to the case.
Userlevel 4
Hi,

there is similar known bug.
Please open a case by the GTAC.

Provide techsupport_all and from at leaset 3 AP's the AP Trace log.

Please try reduce multicast and broadcast as a workaround.
You can use rate limit on the switch port and also on the AP side.

Change on the radios setting
DTIM to 2 and in the Multicast Settings
Max % of non-unicast traffic per Beacon period
set it to 10%.

This should provide some stability.

Regards

Umut
If you check the uptime on the access points, do the APs appear to be rebooting? There is an issue with the current v10 firmware that causes the access points to reboot randomly when they experience a high volume of broadcast traffic. We received an early release of the new AP image and it's resolved that and other issues with a customer of ours.
Thanks all, we have GTAC involved now and they are working on it.

Reply