Apple iPhones Connections hidden SSID


Hi there,

i got an problem here with Apple iPhones 4 & 5 if they should join an wifi network whose ssid is hidden.
If the ssid of this network is broadcasted the phones are joining the network without problems.
If the ssid is set to hidden on the v4110 controller the iPhones are not connecting to this network.
Any suggestions to solve that issue?

Thank you very much.

Best regards

9 replies

Userlevel 6
Hi, Gerry!

What version of iOS?
There is a lot of problems with apple devices in different wireless vendors (Extreme, Aruba, Motorola).

Thank you!
Hello,

always the latest available.

Thank you.

Best regards
Userlevel 6
Here is the same problem with Cisco AP's, Apple discussion:
https://discussions.apple.com/thread/1805392?tstart=0
https://support.apple.com/en-us/HT203211
http://community.spiceworks.com/topic/496829-apple-and-hidden-ssids-on-wifi
Userlevel 6
Gerry

In general hidden SSID's are not recommended.

Can you confirm which firmware you are on, prior to 8.32.05 and 9.12.01 there was an issue with iphones, see release notes:

wns0010056 - Corrected an issue that prevented some Apple devices from connecting to a hidden SSID.

-Gareth
Userlevel 4
Gareth Mitchell wrote:

Gerry

In general hidden SSID's are not recommended.

Can you confirm which firmware you are on, prior to 8.32.05 and 9.12.01 there was an issue with iphones, see release notes:

wns0010056 - Corrected an issue that prevented some Apple devices from connecting to a hidden SSID.

-Gareth

iPhones inherently have wireless issues and adding a hidden SSID just adds to the the problems
Hello

thanks for the replies.

Software: 09.15.04.0011

Gerry
Userlevel 6
Gerry wrote:

Hello

thanks for the replies.

Software: 09.15.04.0011

Gerry

Gerry

As already stated, there are many client problems with hidden SSID's some of these go unresolved. Hiding the SSID adds no useful additional security.

You could try to upgrade to the latest firmware (9.15.08) on the controller to rule out other issues, after that get in touch with GTAC and open a case, taking some realcap traces would be useful: https://gtacknowledge.extremenetworks.com/articles/How_To/Using-Real-Capture-to-capture-wireless-traces-from-the-wireless-interface

-Gareth
Hello

So there is not really an solution because Apples iOS is the problem .

I will reenable the SSID and upgrade to 9.15.08.

Thanks@all

Gerry
Userlevel 2
Gerry

To be honest 99 times out of 100 Wi-Fi connectivity issues will be down to the client device. Their drivers and the way the device is controlled is different for each device vendor. As a Wi-Fi engineer my first port of call for connectivity problems is always the device and this is almost always where the problem lies. You can usually prove it with packet captures. Try and capture the wireless Auth and Assoc frames to see whats going on between client and AP 🙂

Reply