Solved

Can I prevent an Identifi AP from rebooting after 5 minutes?


  • Anonymous
  • 0 replies
Hello,

Is there a way to prevent an Identifi access point from rebooting after 5 minutes? The access point isn't connected to an controller at that time (he do not know any suitable controller), therefore he is rebooting after 5 minutes and start the discovery again. But I will do an manual update (the image download lasts longer than 5 minutes) before I connect the AP to an controller.

SSH access is available

Regards
Stephan
icon

Best answer by Ronald Dvorak 19 November 2018, 14:36

Ron wrote:

Jason is right you'd need to enable mode persistance so the AP doesn't reboot every 5min to try the controller dicovery.

I think that's the CLI command but I haven't tried whether it works only with this one command....

cset modePersistence enable
capply
csave

OK you need a little bit more..... looks like it only works if you've a SSID configured.

First I've enabled link/mode persistance, set a static controller IP (free IP in the subnet) and then I've one bridge@AP untagged SSID - might be that some commands are missing or not needed but the AP doesn't reboot with the following setup..

cset modePersistence enable
cset linkPersistence enable
cset authip 1 192.168.0.250
capply
csave

#SSID
cset vapMode 0:1 bridge
cset vapVlanId 0:1 24876
cset uapsd 0:1 disable
cset vlanLegacy 0:1 disable
cset vapVidAc 0:1 22
cset vapSsid 0:1 "openone"
cset vapGroupKeyUpdate 0:1 0
cset vapWdsParentAP 0:1 ""
cset vapWdsBackParentAP 0:1 ""
cset vapWdsName 0:1 "AP3705i-1"
cset vapUcastFilterCos 0:1 add opennone no-rule
cset vapCos 0:1
cset vapMuInitPeriodBehaviour 0:1 defaultPolicy
cset vapDynamicEgressVlanList 0:1 45053 0
cset vapPolicyFlag 0:1 4
cset vapDefaultAction 0:1 4
cset vapDefaultContainVlan 0:1 45053
capply
csave
reboot

View original

13 replies

Userlevel 5
Hello Stephan,

This article describes how the access point can be configured to maintain service when it cannot contact the controller.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Maintain-Wireless-Services-upon-an-...

For this to work, the AP must be brought up and configured on a controller and then would have to maintain power as well.

Regards,
Jason
Userlevel 5
Hello Jason,

thank you for your fast response. But that not my intend. I have to update the AP before of I create the contact to an controller, to update the access point image.

Regards
Stephan
Userlevel 5
Hello Stephan,

If the AP needs to be upgraded, it can be done with a TFTP server and console or SSH access to the CLI. This KB will help - https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-upgrade-IdentiFi-Wireless-AP-firmwa...

Regardless of the version, if the AP is not registered to a controller, it will continue to reboot every 5 minutes.

Regards,
Jason
Userlevel 7
Jason is right you'd need to enable mode persistance so the AP doesn't reboot every 5min to try the controller dicovery.

I think that's the CLI command but I haven't tried whether it works only with this one command....

cset modePersistence enable
capply
csave
Userlevel 5
Jason wrote:

Hello Stephan,

If the AP needs to be upgraded, it can be done with a TFTP server and console or SSH access to the CLI. This KB will help - https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-upgrade-IdentiFi-Wireless-AP-firmwa...

Regardless of the version, if the AP is not registered to a controller, it will continue to reboot every 5 minutes.

Regards,
Jason

I think his concern was that he cannot upgrade the firmware because the AP is rebooting on him while he is connected via ssh. I have been in that position before.

The article that Jason linked will help with this.

Doing this in the ssh console should break the reboot loop and allow you to upgrade the firmware ...

cset sshtimeout 0
capply
csave

[/code]
Userlevel 5
Ron wrote:

Jason is right you'd need to enable mode persistance so the AP doesn't reboot every 5min to try the controller dicovery.

I think that's the CLI command but I haven't tried whether it works only with this one command....

cset modePersistence enable
capply
csave

Hello Ron,

I will give your command an try.

Regards
Stephan
Userlevel 7
Jason wrote:

Hello Stephan,

If the AP needs to be upgraded, it can be done with a TFTP server and console or SSH access to the CLI. This KB will help - https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-upgrade-IdentiFi-Wireless-AP-firmwa...

Regardless of the version, if the AP is not registered to a controller, it will continue to reboot every 5 minutes.

Regards,
Jason

That only set the ssh timout to unlimited but doens't stop the countdown for the reboot AFAIK
Userlevel 5
Ron wrote:

Jason is right you'd need to enable mode persistance so the AP doesn't reboot every 5min to try the controller dicovery.

I think that's the CLI command but I haven't tried whether it works only with this one command....

cset modePersistence enable
capply
csave

Hello Ron,

that's not enough. I enabled modePersistence but after 5 minutes the AP reboots 😞.
Userlevel 5
Jason wrote:

Hello Stephan,

If the AP needs to be upgraded, it can be done with a TFTP server and console or SSH access to the CLI. This KB will help - https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-upgrade-IdentiFi-Wireless-AP-firmwa...

Regardless of the version, if the AP is not registered to a controller, it will continue to reboot every 5 minutes.

Regards,
Jason

I can confim that. This is only for the ssh session, not for the reboot to start discovery again.
Userlevel 7
Ron wrote:

Jason is right you'd need to enable mode persistance so the AP doesn't reboot every 5min to try the controller dicovery.

I think that's the CLI command but I haven't tried whether it works only with this one command....

cset modePersistence enable
capply
csave

OK you need a little bit more..... looks like it only works if you've a SSID configured.

First I've enabled link/mode persistance, set a static controller IP (free IP in the subnet) and then I've one bridge@AP untagged SSID - might be that some commands are missing or not needed but the AP doesn't reboot with the following setup..

cset modePersistence enable
cset linkPersistence enable
cset authip 1 192.168.0.250
capply
csave

#SSID
cset vapMode 0:1 bridge
cset vapVlanId 0:1 24876
cset uapsd 0:1 disable
cset vlanLegacy 0:1 disable
cset vapVidAc 0:1 22
cset vapSsid 0:1 "openone"
cset vapGroupKeyUpdate 0:1 0
cset vapWdsParentAP 0:1 ""
cset vapWdsBackParentAP 0:1 ""
cset vapWdsName 0:1 "AP3705i-1"
cset vapUcastFilterCos 0:1 add opennone no-rule
cset vapCos 0:1
cset vapMuInitPeriodBehaviour 0:1 defaultPolicy
cset vapDynamicEgressVlanList 0:1 45053 0
cset vapPolicyFlag 0:1 4
cset vapDefaultAction 0:1 4
cset vapDefaultContainVlan 0:1 45053
capply
csave
reboot
Userlevel 5
Hello Jason,

the file transfer for the AP image lasts more than 5 minutes (if I do it manual like described in the mentioned link).

If I add the AP to the controller, the AP did an update immediately, no matter if I enable controlled updated or not. It seem while this update the AP reboots, too. But the image is not transferred completed.

Therefore I hoped I can change the 5 minutes do check if there is timeout problem really.
Userlevel 5
Hello Ron,

you suggestion works very good! Thank you for your help you are a Identifi hero.

Best regards
Stephan

Reply