Question

Can not get any surface pros to connect to wifi


Anyone who comes to my company as a wifi guest and is using a surface pro, cannot connect to my wifi. They see the SSID, but connecting to it takes forever; then it finally says limited connectivity.

I check my EWC and see what my report says for that AP and it shows the client trying to connect with a 169.254.x.x address. Everyone else is fine on every other device, but these devices are not working at all. I cannot find any settings that specifically are sorting out any security features added to windows 10 or the surface pros, so I don't know which is the problem.

I found an article that suggested to try looking under VNS, Virtual Networks, my SSID, Privacy tab and change the "Management Frame protection" drop down box to Disabled, but I'm not using WPA...my selection is None, so this article https://gtacknowledge.extremenetworks.com/articles/Solution/Surface-Pro-4-does-not-connect-to-SSID-w... does not help me.

Any ideas would be most appreciated.

3 replies

Userlevel 4
Hi Fritz,

please check this .

https://gtacknowledge.extremenetworks.com/articles/Solution/Surface-Pro-clients-unable-to-get-an-IP-address-from-their-DHCP-server-connections-drop-off-at-random-intervals

https://gtacknowledge.extremenetworks.com/articles/Q_A/What-are-some-general-troubleshooting-steps-I-can-take-on-the-Microsoft-Surface



Do you use the internal DHCP or a relay?

Increase your dhcp lease time.

Does it work if you use a static IP on your machine?

Does it happen on both radios?

Does it happen on different AP types?

FW ?

Check your driver version on your surface and update if needed.

Regards

Umut Aydin
Are you using band-steering by any chance?
Userlevel 7
What version is installed on the controller ?

Reply