DHCP option 78 for IdentiFi APs


Userlevel 1
Hi.

If a customer has 2 controllers in HA mode connected to S4 and wishes to delegate the DHCP services for the APs at the S4, if he wants to use option 78 in order to tell the APs what are the controllers IP address (2 IP addresses), what is the CLI command regarding option 78 at the S4 under dhcp pool?

Let's say the controllers IP addresses are 10.113.5.5 and 10.113.5.6. Must the values be entered in hex?...

Or, since the controllers data port and APs are in the same VLAN/subnet (same broadcast domain - 10.113.5.0/24), it is better to use the controllers data port DHCP server capabilities in order to assign IPs to the APs (allowing AP registration in the data port, of course)?

Thanks in advance.

6 replies

Userlevel 4
To start, I am providing option 78

--Option 78 broken down...
Dec to Hex
You have to do 01 then each value broken out... c0=192 -- a8=168 -- 2e=46 -- 03=3
option 78 instance 0 hex 01c0a82e03

-Config that we used on a S to be a DHCPserver

S3 Chassis(su)->show run

!configure terminal
interface vlan.0.196
ip address 10.58.196.241 255.255.255.0 primary
ip dhcp server
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.26.196.1 interface vlan.0.196 1
!
ip dhcp send-all-options
ip local pool Extremenetworks 10.58.196.0 255.255.255.0
exclude 10.58.196.1 20
exclude 10.58.196.241 1
exit
ip dhcp pool Extremenetworks

bootfile dhcpboot
domain-name Extremenetworks.com
lease 100 0 0
option 78 instance 0 hex 01c0a82e03
default-router 10.58.196.241

dns-server 1.1.1.1
exit

Jason
Jason Parker wrote:

To start, I am providing option 78

--Option 78 broken down...
Dec to Hex
You have to do 01 then each value broken out... c0=192 -- a8=168 -- 2e=46 -- 03=3
option 78 instance 0 hex 01c0a82e03

-Config that we used on a S to be a DHCPserver

S3 Chassis(su)->show run

!configure terminal
interface vlan.0.196
ip address 10.58.196.241 255.255.255.0 primary
ip dhcp server
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.26.196.1 interface vlan.0.196 1
!
ip dhcp send-all-options
ip local pool Extremenetworks 10.58.196.0 255.255.255.0
exclude 10.58.196.1 20
exclude 10.58.196.241 1
exit
ip dhcp pool Extremenetworks

bootfile dhcpboot
domain-name Extremenetworks.com
lease 100 0 0
option 78 instance 0 hex 01c0a82e03
default-router 10.58.196.241

dns-server 1.1.1.1
exit

Jason

Hey guys, sorry to revive a year old thread, but do you know if this same approach would be used on an extreme XOS switch? Doing some research about setting up the x460 switch as a dhcp server for some APs and came across this thread. I see the user guides show the setup for windows server and using the byte code/array option and couldn't figure out how to map that to XOS. Hoping I can just use HEX as you've described above?
Userlevel 7
Jason Parker wrote:

To start, I am providing option 78

--Option 78 broken down...
Dec to Hex
You have to do 01 then each value broken out... c0=192 -- a8=168 -- 2e=46 -- 03=3
option 78 instance 0 hex 01c0a82e03

-Config that we used on a S to be a DHCPserver

S3 Chassis(su)->show run

!configure terminal
interface vlan.0.196
ip address 10.58.196.241 255.255.255.0 primary
ip dhcp server
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.26.196.1 interface vlan.0.196 1
!
ip dhcp send-all-options
ip local pool Extremenetworks 10.58.196.0 255.255.255.0
exclude 10.58.196.1 20
exclude 10.58.196.241 1
exit
ip dhcp pool Extremenetworks

bootfile dhcpboot
domain-name Extremenetworks.com
lease 100 0 0
option 78 instance 0 hex 01c0a82e03
default-router 10.58.196.241

dns-server 1.1.1.1
exit

Jason

Here we go...

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-DHCP-option-78-on-EXOS-sw...
Jason Parker wrote:

To start, I am providing option 78

--Option 78 broken down...
Dec to Hex
You have to do 01 then each value broken out... c0=192 -- a8=168 -- 2e=46 -- 03=3
option 78 instance 0 hex 01c0a82e03

-Config that we used on a S to be a DHCPserver

S3 Chassis(su)->show run

!configure terminal
interface vlan.0.196
ip address 10.58.196.241 255.255.255.0 primary
ip dhcp server
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.26.196.1 interface vlan.0.196 1
!
ip dhcp send-all-options
ip local pool Extremenetworks 10.58.196.0 255.255.255.0
exclude 10.58.196.1 20
exclude 10.58.196.241 1
exit
ip dhcp pool Extremenetworks

bootfile dhcpboot
domain-name Extremenetworks.com
lease 100 0 0
option 78 instance 0 hex 01c0a82e03
default-router 10.58.196.241

dns-server 1.1.1.1
exit

Jason

Thank you sir!
Userlevel 5
Goncalo,

I believe the CLI command would be similar to this below, and in hex.

option 78 instance 0 hex [i]

This is taken from a test config from a S3, but I believe the syntax would be the same:

S3 Chassis(su)->show run
!configure terminal
interface vlan.0.196
ip address 10.58.196.241 255.255.255.0 primary
ip dhcp server
no shutdown
exit
!
# Static routes configured on routed interfaces
ip route 0.0.0.0/0 10.26.196.1 interface vlan.0.196 1
!
ip dhcp send-all-options
ip local pool ap 10.58.196.0 255.255.255.0
exclude 10.58.196.1 20
exclude 10.58.196.241 1
exit
ip dhcp pool ap

bootfile dhcpboot
domain-name test.com
lease 100 0 0
option 78 instance 0 hex 01c0a82e03
option 72 ip 10.1.1.1
default-router 10.58.196.241

dns-server 1.1.1.1
exit

Thanks,
Jason
Userlevel 5
I should have "refreshed" - Thanks Jason!

Reply