Header Only - DO NOT REMOVE - Extreme Networks

Flapping on Cisco switch when connected to Extreme Wireless Controller lag2 ports


Userlevel 5
On my C5210 Extreme Wireless Controller, I have a lag2 which consists of esa2 and esa3. These are filled with fiber SFP's which connect to a Cisco C3750 (ports 51, and 51 on a 48 port switch).

On my Cisco side, I am seeing MAC flapping between the two lag ports ...
.Mar 9 14:52:19.071: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.67d0.5b54 in vlan 72 is flapping between port Gi1/0/52 and port Gi1/0/51.Mar 9 14:52:23.374: %SW_MATM-4-MACFLAP_NOTIF: Host 00cd.fe77.18c7 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:52:44.673: %SW_MATM-4-MACFLAP_NOTIF: Host 4088.05bf.4a47 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:52:48.850: %SW_MATM-4-MACFLAP_NOTIF: Host 001e.67d0.5b54 in vlan 72 is flapping between port Gi1/0/52 and port Gi1/0/51
.Mar 9 14:52:52.650: %SW_MATM-4-MACFLAP_NOTIF: Host 00cd.fe77.18c7 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:53:05.477: %SW_MATM-4-MACFLAP_NOTIF: Host 4088.05bf.4a47 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:53:22.128: %SW_MATM-4-MACFLAP_NOTIF: Host 00cd.fe77.18c7 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:53:34.786: %SW_MATM-4-MACFLAP_NOTIF: Host 4088.05bf.4a47 in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 14:53:46.212: %SW_MATM-4-MACFLAP_NOTIF: Host 6045.bdcc.f4c0 in vlan 76 is flapping between port Gi1/0/51 and port Gi1/0/52[/code]
Here is what my Cisco config looks like ...
interface Port-channel2 description EXTREME WIRELESS PORT-CHANNEL
switchport trunk encapsulation dot1q
switchport mode trunk
interface GigabitEthernet1/0/51 description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
!
interface GigabitEthernet1/0/52
description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on[/code]
From what I am reading, this is usually caused by an etherchannel protocol mis-match. I am assuming that both sides are using LACP. But is that not the case? I can change that on my Cisco side. I have tried on, desireable, and passive. But they all give me the same problem.
switch-serveroomb(config-if)#channel-group 2 mode ? active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected[/code]

8 replies

Userlevel 3
You should have use passive.

mode "on" is neither PAgP or LACP.

Refer to Cisco description below

EtherChannel On ModeEtherChannel on mode can be used to manually configure an EtherChannel. The on mode forces a port to join an EtherChannel without negotiations. The on mode can be useful if the remote device does not support PAgP or LACP. In the on mode, a usable EtherChannel exists only when the switches at both ends of the link are configured in the on mode.

Ports that are configured in the on mode in the same channel group must have compatible port characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they are configured in the on mode.
Userlevel 5
Mel78, CISSP, ECE wrote:

You should have use passive.

mode "on" is neither PAgP or LACP.

Refer to Cisco description below

EtherChannel On ModeEtherChannel on mode can be used to manually configure an EtherChannel. The on mode forces a port to join an EtherChannel without negotiations. The on mode can be useful if the remote device does not support PAgP or LACP. In the on mode, a usable EtherChannel exists only when the switches at both ends of the link are configured in the on mode.

Ports that are configured in the on mode in the same channel group must have compatible port characteristics, such as speed and duplex. Ports that are not compatible are suspended, even though they are configured in the on mode.

Hello Wong,

Using passive on these two ports gives me the same flapping issue.
interface GigabitEthernet1/0/51 description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
!
interface GigabitEthernet1/0/52
description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
![/code]switch-serveroomb#term monswitch-serveroomb#
.Mar 9 17:14:40.623: %SW_MATM-4-MACFLAP_NOTIF: Host 6045.bdcc.f4c0 in vlan 76 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 17:14:50.362: %SW_MATM-4-MACFLAP_NOTIF: Host a866.7fb1.a11c in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 17:14:52.081: %SW_MATM-4-MACFLAP_NOTIF: Host 3412.98ef.72a0 in vlan 76 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 17:15:11.526: %SW_MATM-4-MACFLAP_NOTIF: Host 6045.bdcc.f4c0 in vlan 76 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 17:15:20.343: %SW_MATM-4-MACFLAP_NOTIF: Host a866.7fb1.a11c in vlan 190 is flapping between port Gi1/0/51 and port Gi1/0/52
.Mar 9 17:15:20.963: %SW_MATM-4-MACFLAP_NOTIF: Host 3412.98ef.72a0 in vlan 76 is flapping between port Gi1/0/51 and port Gi1/0/52[/code]
You should set
channel-group 2 mode active
Userlevel 5
Jeremy Gibbs wrote:

You should set
channel-group 2 mode active

Unfortunately, I am still flapping with this setting.
Jeremy Gibbs wrote:

You should set
channel-group 2 mode active

Can you post some show spantree stuff:

show spanning-tree summary

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst3750/software/release/12-2_55_se/commmand...
Userlevel 5
Jeremy Gibbs wrote:

You should set
channel-group 2 mode active

Hello Jeremy, this is what my spanning-tree summary looks like ...

switch-serveroomb#show spanning-tree summary Switch is in pvst mode Root bridge for: none Extended system ID is enabled Portfast Default is disabled PortFast BPDU Guard Default is disabled Portfast BPDU Filter Default is disabled Loopguard Default is disabled EtherChannel misconfig guard is enabled UplinkFast is disabled BackboneFast is disabled Configured Pathcost method used is short Name Blocking Listening Learning Forwarding STP Active ---------------------- -------- --------- -------- ---------- ---------- VLAN0001 0 0 0 31 31 VLAN0002 0 0 0 26 26 VLAN0003 0 0 0 26 26 VLAN0005 0 0 0 26 26 VLAN0007 0 0 0 26 26 VLAN0008 0 0 0 26 26 VLAN0010 0 0 0 26 26 VLAN0011 0 0 0 26 26 VLAN0015 0 0 0 32 32 VLAN0020 0 0 0 26 26 VLAN0030 0 0 0 26 26 VLAN0032 0 0 0 26 26 VLAN0035 0 0 0 26 26 VLAN0040 0 0 0 26 26 VLAN0045 0 0 0 26 26 VLAN0050 0 0 0 26 26 VLAN0060 0 0 0 26 26 VLAN0070 0 0 0 28 28 VLAN0072 0 0 0 26 26 VLAN0076 0 0 0 26 26 VLAN0080 0 0 0 26 26 VLAN0085 0 0 0 26 26 VLAN0090 0 0 0 26 26 VLAN0095 0 0 0 26 26 VLAN0100 0 0 0 26 26 VLAN0110 0 0 0 26 26 VLAN0120 0 0 0 26 26 VLAN0130 0 0 0 26 26 VLAN0140 0 0 0 26 26 VLAN0172 0 0 0 26 26 VLAN0190 0 0 0 26 26 VLAN0200 0 0 0 26 26 VLAN0201 0 0 0 26 26 VLAN0205 0 0 0 26 26 VLAN0209 0 0 0 26 26 VLAN0210 0 0 0 26 26 VLAN0211 0 0 0 26 26 VLAN0212 0 0 0 26 26 VLAN0215 0 0 0 26 26 VLAN0220 0 0 0 26 26 VLAN0230 0 0 0 26 26 VLAN0240 0 0 0 26 26 VLAN0250 0 0 0 26 26 VLAN0260 0 0 0 26 26 VLAN0265 0 0 0 26 26 VLAN0270 0 0 0 26 26 VLAN0280 0 0 0 26 26 VLAN0290 0 0 0 26 26 VLAN0300 0 0 0 26 26 VLAN0305 0 0 0 26 26 VLAN0307 0 0 0 26 26 VLAN0308 0 0 0 26 26 VLAN0320 0 0 0 26 26 VLAN0325 0 0 0 26 26 VLAN0330 0 0 0 26 26 VLAN0340 0 0 0 26 26 VLAN0350 0 0 0 26 26 VLAN0355 0 0 0 26 26 VLAN0410 0 0 0 26 26 VLAN0420 0 0 0 26 26 VLAN0425 0 0 0 26 26 VLAN0430 0 0 0 26 26 VLAN0440 0 0 0 26 26 VLAN0450 0 0 0 26 26 VLAN0460 0 0 0 26 26 VLAN0462 0 0 0 26 26 VLAN0463 0 0 0 26 26 VLAN0465 0 0 0 26 26 VLAN0470 0 0 0 28 28 VLAN0475 0 0 0 26 26 VLAN0480 0 0 0 26 26 VLAN0483 0 0 0 26 26 VLAN0485 0 0 0 26 26 VLAN0490 0 0 0 31 31 VLAN0493 0 0 0 26 26 VLAN0495 0 0 0 26 26 VLAN0510 0 0 0 26 26 VLAN0520 0 0 0 26 26 VLAN0525 0 0 0 26 26 VLAN0550 0 0 0 26 26 VLAN0560 0 0 0 26 26 VLAN0570 0 0 0 26 26 VLAN0625 0 0 0 26 26 VLAN0630 0 0 0 27 27 VLAN0650 0 0 0 26 26 VLAN0661 0 0 0 26 26 VLAN0666 0 0 0 33 33 VLAN0700 0 0 0 26 26 VLAN0720 0 0 0 26 26 VLAN0730 0 0 0 26 26 VLAN0740 0 0 0 26 26 VLAN0745 0 0 0 26 26 VLAN0760 0 0 0 26 26 VLAN0777 0 0 0 26 26 VLAN0800 0 0 0 26 26 VLAN0900 0 0 0 27 27 VLAN0950 0 0 0 26 26 VLAN0975 0 0 0 26 26 VLAN0999 0 0 0 26 26 VLAN1000 0 0 0 26 26 ---------------------- -------- --------- -------- ---------- ---------- 100 vlans 0 0 0 2629 2629
[/code]
Userlevel 5
Jeremy Gibbs wrote:

You should set
channel-group 2 mode active

GTAC got me straightened out. I think I was running into a wall trying to change through the various settings without downing the ports in the process. GTAC tells me that the correct mode for the channel-group is "on". The Wireless LAG ports do *NOT* use LACP, and so this needed to be configured as a "static lag".

Here is that article.

And here is the config that worked!

interface Port-channel2 switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/51
description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
!
interface GigabitEthernet1/0/52
description EXTREME WIRELESS CONTROLLER LAG2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
![/code]
Ohh yes, that is true! So you wouldn't be able to use a control protocol. I was thinking of the LACP issues I had between our S4 and a Cisco 6509..

Reply