HP Comware based switches and Identifi Wireless issue

I am looking for a little help getting our Identifi Wireless working with HP Comware based switches. We currently have older Hp Procurve switches that work just fine but the newer HP switches are running Comware. I have provisied the port just as I would on the Procurve. We leave the Management vlan untagged and the user vlans tagged.

We have it as such now on the Procurve.

vlan 12 mgmt untagged
vlan 102 staff tagged
vlan 104 apple tagged
vlan 108 android tagged
vlan 112 laptop tagged
vlan 116 gaming tagged

I have all the vlans setup exactly the same on the Comware switches.
I have tried using both Hybrid and Trunk ports and neither will allow the access point to communicate with the wireless controller.
Does anyone have any ideas on what I could do.

12 replies

Userlevel 5
Hi Steve

I presume that vlan 12 (Management) is the vlan that the AP uses to discover the Controller

Can you give me the port config on the comware device?
The port should be configured as a trunk port allowing vlan 102,104,108,112 and 116.
Then you will have to ensure that the native vlan (Untagged) is configured for vlan 12.

That shoudl replicate the config from the procurve.
GE2/0/32 12 102, 104, 108, 112, 116

This is what it is setup in the Comware config. I have this port configured as a trunk port at the moment.

VLAN 12 is the Management VLAN that talk to our controllers.
Userlevel 7
Could you please provide the exact model name of the switch.

HP 5130-48G-PoE+-4SFP+ (370W) EI JG937A
Userlevel 7
Looks like a old Huawei CLI command set.

Please add "port trunk permit vlan 12" to the port config and try it again.


That worked, Thank you very much. I have been beating my head off a wall trying to figure this out.
Userlevel 5
So as I understand your AP's are in VLAN 12 (untagged) right? Do you want AP communicate on the same VLAN with Wireless Controller ? If so , which controller port is in this VLAN?
Userlevel 7
No problem, I am glad I was able to help.
Wish u a great day.
Userlevel 7
Just as a reference if someone is looking for an example in the future - I assume the config looks now like this ....

interface Ethernet1/0/48
port link-type trunk
port trunk pvid vlan 12
port trunk permit vlan 12,102,104,108,112,1161
Userlevel 5

Thank you for sharing your knowledge! That's a great example what The Hub was intended for when it was started.

I have created a knowledge article to document this particular situation and resolution - https://gtacknowledge.extremenetworks.com/articles/Solution/Access-Points-not-communicating-with-Ide...

Let us know if that looks accurate or needs further editing, etc.

Thanks again,
Jason (and the GTAC)
Userlevel 7
Hi Jason,

could you please edit the symptoms to "can't ping" 🙂

Userlevel 5

Done. Thanks! Got that confused with another issue 🙂

- Jason