I can't seem to make 3rd Party AP work.



Show first post

34 replies

Userlevel 7
Hi Rahman,

I am looking at this a bit more in my lab today and will contact you about looking your configuration remotely so we can get this working for you.

Regards,
Jason
Hello Rahman,

I just sent you an update on this ticket, the next steps at this point would be to setup a remote session so we can review your controller and debug the solution live.
Userlevel 3
Hi Rahman,

I am looking at this a bit more in my lab today and will contact you about looking your configuration remotely so we can get this working for you.

Regards,
Jason
Thank you, I am waiting for remote session for about one month now 🙂 I just want to make sure it is not forgotten.
Userlevel 3
Hi,

Sorry to bump this old thread but I can't get any answers in GTAC case:01138086 anymore.

Here is the last tip I got from GTAC;

Hello Rahman,
Is it possible for you to route the 3rd party VNS outside of the controller? This VNS should be kept separate from the rest of the controller, so that there is a route BACK to this VNS on the network, but not "through" the controller. Is it possible for you to configure it this way and re-test?
Regards,
Jason
So anyone uses 3rd Party VNS can explain me how should be the physical topology? The 3rd party vns clients uses controller ip as their gateway so how is it possible to "not route through controller"?

Thanks,
Rahman
Userlevel 5
Hello Rahman,

I apologize for not getting back to you on this question. I re-read what I wrote and it is confusing! I don't think I was explaining my thoughts clearly. I wanted to make sure there was no other duplicate interface for your VLAN 60 on the network.

I have attached the topology that I am using in our lab.



Regards,
Jason
Userlevel 3
Hello Jason,

Thanks for the sample. And the router will route back the return traffic as I show with green arrows, right (via static route to port 1 ip)? IIRC the first setup was like this. But I will reimplement it and return back to you.


Thanks,
Rahman
Userlevel 3
Hi,

I have to bump this but after more than 1 year passed, I am still having this problem. I opened GTAC ticket 1.5 year ago, it is very slow progress and still no solution.

So before I give up trying to use this feature, maybe some veterans here can help.

As a summary there are two problems. First changing anything in 3rd party WLAN settings breaks all other WLAN communications and all clients loses connectivity. Second the 3rd party captive portal never shows up even it is configured as suggested.

The Aruba APs have several SSIDs on them that uses different vlans and different IP blocks. I only want one of them to be routed through EWC which is vlan 60. So the AP's have different management IP than vlan 60.

I don't get why we need to configure the mac and ip addresses of the third party APs on EWC? What is the purpose of it? As far as I see, the 3rd party vlan traffic passes through EWC only beacuse 3rd party vlan clients uses EWC L3 IP as their default gateway. EWC doesn't and can't know the mac addresses or the ip addreses of the 3rd party APs as their management traffic does not pass through EWC.

Thanks,

Rahman
Hi Rahaman

From your above comment

"The Aruba APs have several SSIDs on them that uses different vlans and different IP blocks. I only want one of them to be routed through EWC which is vlan 60. So the AP's have different management IP than vlan 60."

Q: Is there multiple IAP's deployed,they already formed a cluster [IAPs listed in Virtual controller IAP],they are broadcasting multiple SSIDs ? excluding guest SSID with Vlan 60 ?

Refer the below and let me know if that helps
https://www.youtube.com/watch?v=AZoliDUNGR8
https://www.youtube.com/watch?v=AeZ7pOultMw

Regards
Rajesh
Userlevel 3
Hi Rahaman

From your above comment

"The Aruba APs have several SSIDs on them that uses different vlans and different IP blocks. I only want one of them to be routed through EWC which is vlan 60. So the AP's have different management IP than vlan 60."

Q: Is there multiple IAP's deployed,they already formed a cluster [IAPs listed in Virtual controller IAP],they are broadcasting multiple SSIDs ? excluding guest SSID with Vlan 60 ?

Refer the below and let me know if that helps
https://www.youtube.com/watch?v=AZoliDUNGR8
https://www.youtube.com/watch?v=AeZ7pOultMw

Regards
Rajesh

Hi Rajesh,

There is 15 Aruba IAPs, their cluster communication and management vlan is 20. Yes there are 4 SSIDs that they broadcast. One named "ACU" on vlan 20, one named "INFO" on vlan 21, one named "VOIP" on vlan 61 and last one is "TEST" on vlan 60.

Regardless of Aruba APs, I also test by hooking up a PC to a switch port with vlan 60. It gets correct IP adress and gateway information via DHCP so its traffic is routed to EWC vlan 60 ip. But even this does not work. It does not redirect to Captive Portal Page.

edit: About the links you provided, it is not what I try to do. I already use CP on Aruba APs. But my purpose was to broadcast an Open guest SSID on Aruba and use EWC 3rd party captive portal feature. So I can see the users statistics on EWC.

PS: "As a summary there are two problems. First changing anything in 3rd party WLAN settings breaks all other WLAN communications and all clients loses connectivity. Second the 3rd party captive portal never shows up even it is configured as suggested."

If this confused you, I mean "changing 3rd party WLAN settings under EWC, breaks all SSIDs on EWC. So all clients connected to Extreme APs looses connection.

I hope it is clear for you now.

Thanks,

Rahman

Reply