IdentiFi Wi-Fi doesn't work with some HP laptops with RALink wireless onboard (RT3290)


Userlevel 4
Hello, everybody!

Today I am experienced a strange issue. I have small wi-fi network (V2110 9.21 + 3 APs 3805i), 7 SSIDs with WPA-PSK auth. More than 70 users (laptops, phones) work fine, but two guys with HP notebooks (which have the same wifi-adapter RALink RT3290) have a problem:

1) The first guy with Windows 10 doesn't see any of Extreme SSIDs, but see many other (from different hardware vendors). Driver of wifi adapter was published in 2014.
2) The second guy with Windows 8 could see all the networks, but can't get an IP-address from required Extreme's SSID. When I've connected him with a cable to an appropriate VLAN, he's received IP without problem. Driver of wifi adapter was published in 2013.

Have anybody ever experienced such a thing? What most likely could be the problem?

Many thanks in advance,

Ilya

5 replies

Userlevel 7
Hi Ilya,

1) is the SSID hidden ? Have you tried it with a manual profile on the HP laptop ?
2) please re-enter the PSK, if the key is wrong you are able to connect but don't get an IP.

-Ron
Userlevel 4
Hello, Ron! All the SSIDs were NOT hidden. I haven’t tried any manual profiles, cause it was c time-critical task to give a guy internet access.

The key was correct, cause there were at least five guys who worked without problems. I’ve entered it by myself and the same result – netcard didn’t get an IP address.

At the moment competition is over so the networks were deconstructed yesterday. But… what was it? Will I face this problem again? We have some potential wifi projects with Extreme…
Userlevel 7
Sorry but without further data no one could answer what the root cause was or whether it happen again.

My personal opionion.... a client problem - call the GTAC next time so they could take a closer look.

-Ron
Userlevel 7
Update on this... I had a customer with Ralink RT3290, they will only work with with the WPA v1 and WPA v2 settings configured for auto. It looks like there are some known issues with this NIC and only being able to use TKIP...
Userlevel 4
Thanks everybody!

That would be the second bug I've found personally with Extreme solutions)

Reply