Header Only - DO NOT REMOVE - Extreme Networks

AP-7522-67030-WR access point doesn't connect to the internet


Our Standalone access point (AP-7522-67030-WR with Wing V.5.9.1.2-006R) doesn't connect to the internet when using RF scanner (MC92N0 WIN CE 7.0) or any Android phone or Tablet.
But I can search the internet when using an i-phone or desktop WIN 10 pc with this AP 7522 WIFI connection. I am wondering if this is a firmware upgrade issue or some other setup issue?
Has anyone experienced this before or please share your thoughts on how to resolve this issue?

FYI: AP7522 is setup as Standalone with Static IP/ Default Gateway IP/ DNS IP.
WLAN is setup with WPA2-Personal/AES encryption.
All devices are configured as DHCP. to connect to AP7522 WIFI.system.

22 replies

Userlevel 3
Hi

The first thing to check is to confirm that the devises are connected and authenticated

If you log into the cli of the AP and do a show wireless client, It will list all the devices on the AP and their status. A status of "DATA READY" is what you want.

You can also do a "show event-history". You may need to scrol down a bit, but you ca see when the device tries to connect and authenticate
Hi Andy,

The RF scanner device error message is "The page cannot be displayed" with Cannot find server or DNS Error on Internet explorer, while the tablet error message is the timeout error on Chrome.
AP event history window does show the handshake to AP radio (connection completed/successful) on the iphone and desktop devices but no history of the devices that couldn't connect.
All devices are showing AP radio/WiFi as "connected", but going to google site was only successful on the 2 devices I've mentioned.
Userlevel 3
Hi Manual

Once a scanner is connected, confirm it has a valid I/P from the correct subnet. Also confirm the correct GW and DNS server is set
Andrew Holden wrote:


Hi Manual

Once a scanner is connected, confirm it has a valid I/P from the correct subnet. Also confirm the correct GW and DNS server is set

Hi Andy,

Yes the scanner connects properly to our WMS server with correct GW and subnet and valid IP (no issue using our WMS SW) . The scanner just couldn't access the internet with this AP7522 radio ...
FYI The scanner connects to the internet using our older AP 5131 no problem.
Userlevel 3
Hi Manuel

Please go to
https://gtacknowledge.extremenetworks.com/articles/Q_A/Where-can-I-find-best-practices-and-recommend...

and download the Best Practices document.

There is a section for the Firewall configuration. Please implement it
Andrew Holden wrote:

Hi Manuel

Please go to
https://gtacknowledge.extremenetworks.com/articles/Q_A/Where-can-I-find-best-practices-and-recommend...

and download the Best Practices document.

There is a section for the Firewall configuration. Please implement it

Hi Andy,

Thank you for your suggestion.

The AP firewall is enabled and when I added WLAN ACL rule for any source/destination the Android phone connects to the internet no problem.
But the RF scanners and industrial tablet still can't, even when I add the ACL rule with their respective IP addresses.
I agree it is a matter of the firewall settings either with the AP or RF devices.
I have asked our IT manager to confirm our firewall settings for AP 7522 but with other devices connecting to the internet using the AP radio, it may be an issue with the RF firewall unless there's an AP firewall policy on limited external access from RF devices?
I am also going to consult our RF device manufacturer for advice.
Hi Manual
make sure you can ping a remote server outside the network, such as 8.8.8.8.
Use the wirelees Options diagnostic tool.
if you connect to WMS Telnet, you may not be able to access outside resources, which can be understood for security reasons.


Yas wrote:


Hi Manual
make sure you can ping a remote server outside the network, such as 8.8.8.8.
Use the wirelees Options diagnostic tool.
if you connect to WMS Telnet, you may not be able to access outside resources, which can be understood for security reasons.


Hi Yas,

Yes I can ping IP 8.8.8.8 np from the RF device.
I am consulting with our RF device manufacturer regarding the internet options setup as when I added the IP for trusted sites, RF device still doesn't connect to the internet.
Manual
the AP firewall default-Policy allow the internet access, if you don't modifit this Policy = no problem.
But , check the router or the firewall device .your firewall rule adapted for the AP 5131 incense, are no longer relevant for your AP7522. ( AP IP address and MAC address different).
Yas wrote:


Manual
the AP firewall default-Policy allow the internet access, if you don't modifit this Policy = no problem.
But , check the router or the firewall device .your firewall rule adapted for the AP 5131 incense, are no longer relevant for your AP7522. ( AP IP address and MAC address different).

Hi Yas,

As I've mentioned earlier, other devices such as iPhone and desktop pc connects to the internet using AP 7522 with no issues. And I was able to use the android phone when I added a WLAN ACL rule on the AP 7522 Security/Firewall settings.
Hence it is not our router or firewall device since we can use other devices to connect. I think it comes down to the RF device firewall or internet options setup.
Hi Manual
I understood that you were using a WLAN ACL. this is not a problem because it is limited to the radio level. concerning the MC92N0, there are not many parameters, and by default with an IP address in DHCP = I have no problem of WEB connection ( same AP version, MC92N0 OS = 10.57.22).
The only options that could be problematic are Gateway and DNS configuration.
you can test that if you want.

Yas wrote:


Hi Manual
I understood that you were using a WLAN ACL. this is not a problem because it is limited to the radio level. concerning the MC92N0, there are not many parameters, and by default with an IP address in DHCP = I have no problem of WEB connection ( same AP version, MC92N0 OS = 10.57.22).
The only options that could be problematic are Gateway and DNS configuration.
you can test that if you want.

Hi Yas,

Thank you for your suggestion about the gateway and DNS configuration.
You're right about the limited parameters of the RF scanner MC92N0.

Have you tried using Android devices to connect to the Web with AP 7522?
As per our IT manager, the issue is the wireless connection is not stable with Android devices.
Maybe there's a better AP model for RF devices running on Android OS, with the same functionality, network capability and security level as AP 7522?

In warehousing, our customers don't require much functions on their access points as long their RF devices connects to their WMS system with normal WPA2 encryption setting, and at most about 30 APs in a big warehouse with one or two AP(s) as virtual controllers. Recently new customers want RF devices with Android OS.
Yas wrote:


Hi Manual
I understood that you were using a WLAN ACL. this is not a problem because it is limited to the radio level. concerning the MC92N0, there are not many parameters, and by default with an IP address in DHCP = I have no problem of WEB connection ( same AP version, MC92N0 OS = 10.57.22).
The only options that could be problematic are Gateway and DNS configuration.
you can test that if you want.

Thanks for the tip!
Currently we're testing TC70 and an industrial tablet on android OS using Telnet/velocity.
No problem with our WMS app with AP7522, just the wireless connectivity seems unstable, hence issue with web connection..
Follow the Best Practices and disable firewall (using the CLI)

firewall-policy default

no stateful-packet-inspection-l2

no ip dos smurf

no ip dos twinge

no ip dos invalid-protocol
Recommended Firewall Policy Configuration:
firewall-policy default
no ip dos
no ip-mac conflict
no ip-mac routing conflict
dhcp-offer-convert
no ipv6 strict-ext-hdr-check
no ipv6 unknown-options
no ipv6 duplicate-options
no ipv6 option strict-hao-opt-check
no ipv6 option strict-padding
no stateful-packet-inspection-l2
no ipv6-mac conflict
no ipv6-mac routing conflict
Pablo Moriconi wrote:

Recommended Firewall Policy Configuration:
firewall-policy default
no ip dos
no ip-mac conflict
no ip-mac routing conflict
dhcp-offer-convert
no ipv6 strict-ext-hdr-check
no ipv6 unknown-options
no ipv6 duplicate-options
no ipv6 option strict-hao-opt-check
no ipv6 option strict-padding
no stateful-packet-inspection-l2
no ipv6-mac conflict
no ipv6-mac routing conflict

Hi,

Firewall policy - default with ipv6 disabled, disabled auto PAC settings, disabled FIPS mode, etc. and the only options activated are the OP Mode Filtering and Regulatory where Country is Canada with disabled 802.11d and bandwidth for 2.4GHz only.
So the device setup is mostly by default with the AP 7522 firewall - enabled. >> still no internet access with the device MC92N0..
Pablo Moriconi wrote:

Recommended Firewall Policy Configuration:
firewall-policy default
no ip dos
no ip-mac conflict
no ip-mac routing conflict
dhcp-offer-convert
no ipv6 strict-ext-hdr-check
no ipv6 unknown-options
no ipv6 duplicate-options
no ipv6 option strict-hao-opt-check
no ipv6 option strict-padding
no stateful-packet-inspection-l2
no ipv6-mac conflict
no ipv6-mac routing conflict

Yesterday I have to test one AP-7522 from defaults.
I can only ping the AP but not the rest of network devices and internet
I had to disable this:
no stateful-packet-inspection-l2
no ip-mac conflict
no ip-mac routing conflict
Userlevel 1
HI,

Please make sure on the device the following:

go to settings>connections>advanced and ensure that on the two drop down menus you have either my network or my isp and not one of each.

Best Regards
Carlos Assunção wrote:

HI,

Please make sure on the device the following:

go to settings>connections>advanced and ensure that on the two drop down menus you have either my network or my isp and not one of each.

Best Regards

Hi, yes there's only one item in my connections tab but still no go on internet with mc92N0
Carlos Assunção wrote:

HI,

Please make sure on the device the following:

go to settings>connections>advanced and ensure that on the two drop down menus you have either my network or my isp and not one of each.

Best Regards

If you have WinCE7 you Will not see my network and my isp
I was able to connect to the internet using the MC92N0 (CE 7.0) by creating another Fusion profile pointing to the other AP that connects to the internet.
Not ideal but creating 2 fusion profiles, one for internet and one for WMS (AP7522) works for all RF devices with CE OS. For now this satisfy a customer requirement.

As for the Android devices, testing is still in progress but having 2 fusion profiles work as well.

Thank you team for all your suggestions!

Reply