Solved

Moving AP from RFS4000 to VX9000

  • 28 August 2019
  • 3 replies
  • 167 views

Hi all.
This is my scenario. I have 2 controllers: one RFS4000 with 42 APs (AP6522 in 1 RF-Domain) and one VX9000 with multiple RF-Domains.
RFS4000 version is 5.8.2.0-030R, VX9000 version is 5.9.1.3-007R
Two controllers are in a different networks connected to each other.

My ideas is to move all APs from the old RFS to the VX in a specific RF-Domain.
In order to do that I create all the configurations on the VX (rf-domain, adoption policy, profiles, etc), then I create on the network where RFS is a DHCP option 191 who points to the VX9000 (as I did for the other installations). My ideas is to reset to the factory defaults each AP on the RFS and then, once they will reboot to factory defaults, adopt in the VX and then upgrade to the 5.9 firmware.

First of all: does it make sense what I've written so far or is there a more recommended way to do this?

If it is correct, I don't know how to do that.
I mean: I tried to reset the AP to the factory default by erase the default-config but it does not work. After reboot the configuration remain the same.
I don't have the possibility to connect to each AP via console cable because they are installed in a warehouse at 13 meters high!

Any ideas?
Feel free to ask me more questions if needed.

Thanks,
icon

Best answer by Chris Kelly 28 August 2019, 15:13

Migrating APs from one controller to another seems to nearly always be an 'interesting' adventure. :)

As Rob alluded to, the 6522's still have their config because after you default them, they are still (guessing) learning via layer-2 the RFS's address and then re-adopt...and then the RFS gives them their config back.
Hence the recommendation for shutting down (or disconnecting from the network) the RFS4K. Whatever the case, they either are still knowing about the RFS4K and therefore adopting to it. At the very least, you need to add the step of removing the auto-provisioning rule that allows them to be adopted to it..

Another option I've used is to actually just add a config entry in the AP Profile that statically defines the address of the other controller. This gets pushed out then and is then part of the APs config itself. Depending on the setup though, it might still be necessary to actually disconnect the RFS4K from the network to make it work.

Or, you may not have seen this, but in the auto-provisioning policy, you can change the Operation value in the rule that adopts the APs from "allow" to "redirect"...and then input the VX9K's address in the "Controller" field. (Rob, does 5.8.2 have the 'redirect' options?)

Bottom line though, I'd do like what Robert said and simply somehow remove the RFS4K from the network and eliminate any possibility that the APs can re-adopt to it.
View original

3 replies

Userlevel 6
After you factory defaulted the APs, you have to make sure that the RFS4k controller is turned off. Further more you have to make sure that the APs from the RFS4k are able to upgrade firmware from 5.8.2.0-030R to 5.9.1.3-007R.

How to reset the config of a WiNG AP or Wireless Controller to Factory Defaults via CLI
Userlevel 5
Migrating APs from one controller to another seems to nearly always be an 'interesting' adventure. :)

As Rob alluded to, the 6522's still have their config because after you default them, they are still (guessing) learning via layer-2 the RFS's address and then re-adopt...and then the RFS gives them their config back.
Hence the recommendation for shutting down (or disconnecting from the network) the RFS4K. Whatever the case, they either are still knowing about the RFS4K and therefore adopting to it. At the very least, you need to add the step of removing the auto-provisioning rule that allows them to be adopted to it..

Another option I've used is to actually just add a config entry in the AP Profile that statically defines the address of the other controller. This gets pushed out then and is then part of the APs config itself. Depending on the setup though, it might still be necessary to actually disconnect the RFS4K from the network to make it work.

Or, you may not have seen this, but in the auto-provisioning policy, you can change the Operation value in the rule that adopts the APs from "allow" to "redirect"...and then input the VX9K's address in the "Controller" field. (Rob, does 5.8.2 have the 'redirect' options?)

Bottom line though, I'd do like what Robert said and simply somehow remove the RFS4K from the network and eliminate any possibility that the APs can re-adopt to it.
Thanks guys, in these days I'll try and let you know.

Reply