Solved

Upgrading remote site APS through RFDM AP

  • 22 October 2019
  • 20 replies
  • 1976 views

Userlevel 3

Hello guys,

In my lab I can’t make working the upgrading remote site APS through RFDM AP.

My upgrades are successful, but through VX9000 and not through the RFDM AP.

The test is very simple, VX9000 + 2 pieces of AP7532 in the same vlan.

VX running config:

!### show running-config
!
! Configuration of VX9000 version 7.2.1.1-006R
!
!
version 2.7
!
!
client-identity-group default
load default-fingerprints
!
ip access-list BROADCAST-MULTICAST-CONTROL
permit tcp any any rule-precedence 10 rule-description "permit all TCP traffic"
permit udp any eq 67 any eq dhcpc rule-precedence 11 rule-description "permit DHCP replies"
deny udp any range 137 138 any range 137 138 rule-precedence 20 rule-description "deny windows netbios"
deny ip any 224.0.0.0/4 rule-precedence 21 rule-description "deny IP multicast"
deny ip any host 255.255.255.255 rule-precedence 22 rule-description "deny IP local broadcast"
permit ip any any rule-precedence 100 rule-description "permit all IP traffic"
!
mac access-list PERMIT-ARP-AND-IPv4
permit any any type ip rule-precedence 10 rule-description "permit all IPv4 traffic"
permit any any type arp rule-precedence 20 rule-description "permit all ARP traffic"
!
ip snmp-access-list default
permit any
!
firewall-policy default
no ip dos tcp-sequence-past-window
!
!
mint-policy global-default
!
meshpoint-qos-policy default
!
wlan-qos-policy default
qos trust dscp
qos trust wmm
!
radio-qos-policy default
!
!
management-policy default
no telnet
no http server
https server
rest-server
ssh
user admin password 1 b3c4e90173bd1f030e821f04ee833f17e78b4133788ffb40f12928bfabba10c8 role superuser access all
snmp-server community 0 private rw
snmp-server community 0 public ro
snmp-server user snmptrap v3 encrypted des auth md5 0 admin123
snmp-server user snmpmanager v3 encrypted des auth md5 0 admin123
t5 snmp-server community public ro 192.168.0.1
t5 snmp-server community private rw 192.168.0.1
!
ex3500-management-policy default
snmp-server community public ro
snmp-server community private rw
snmp-server notify-filter 1 remote 127.0.0.1
snmp-server view defaultview 1 included
!
ex3500-qos-class-map-policy default
!
ex3500-qos-policy-map default
!
database-policy default
!
profile vx9000 default-vx9000
no autoinstall configuration
no autoinstall firmware
no device-upgrade auto
crypto ikev1 policy ikev1-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ikev2 policy ikev2-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
crypto ikev1 remote-vpn
crypto ikev2 remote-vpn
crypto auto-ipsec-secure
crypto load-management
crypto remote-vpn-client
interface xge1
interface xge2
interface xge3
interface xge4
interface ge1
interface ge2
use firewall-policy default
logging on
service pm sys-restart
router bgp
adoption-mode controller
!
profile ap7532 default-ap7532
autoinstall configuration
autoinstall firmware
crypto ikev1 policy ikev1-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ikev2 policy ikev2-default
isakmp-proposal default encryption aes-256 group 2 hash sha
crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
crypto ikev1 remote-vpn
crypto ikev2 remote-vpn
crypto auto-ipsec-secure
crypto load-management
crypto remote-vpn-client
interface radio1
interface radio2
interface ge1
interface vlan1
ip address dhcp
ip address zeroconf secondary
ip dhcp client request options all
interface pppoe1
use firewall-policy default
use client-identity-group default
logging on
controller host 172.17.8.3 pool 1 level 2
service pm sys-restart
router ospf
adoption-mode controller
!
rf-domain VXtest
country-code il
!
rf-domain default
no country-code
control-vlan 1
!
vx9000 08-00-27-1D-96-AB
use profile default-vx9000
use rf-domain VXtest
hostname vx9000-1D96AB
license AAP VX-DEMO-16AAP-LICENSE
license ADSEC DEFAULT-ADV-SEC-LICENSE
no mint mlcp vlan
autoinstall firmware
interface ge1
interface ge2
interface vlan1
ip address dhcp
!
ap7532 B8-50-01-71-C0-D4
use profile default-ap7532
use rf-domain default
hostname ap7532-71C0D4
!
ap7532 B8-50-01-74-3E-6C
use profile default-ap7532
use rf-domain default
hostname ap7532-743E6C
!
!
end

Info from VX:

vx9000-1D96AB#show mint ne
1 mint neighbors of 12.1D.96.AB:
1B.71.C0.D4 (ap7532-71C0D4) at level 2, best adjacency ip-172.17.8.4:24576

vx9000-1D96AB#show global domain managers
-----------------------------------------------------------------------------------------------------
RF-DOMAIN MANAGER HOST-NAME APS CLIENTS
-----------------------------------------------------------------------------------------------------
VXtest 08-00-27-1D-96-AB vx9000-1D96AB 0 0
default B8-50-01-71-C0-D4 ap7532-71C0D4 2 0
-----------------------------------------------------------------------------------------------------
Total number of RF-domain displayed: 2

vx9000-1D96AB#show device-upgrade history
-------------------------------------------------------------------------------------------------
Device RESULT TIME RETRIES UPGRADED-BY LAST-UPDATE-ERROR
-------------------------------------------------------------------------------------------------

ap7532-743E6C done 2019-10-22 09:23:31 0 vx9000-1D96AB -

ap7532-71C0D4 done 2019-10-22 09:24:42 0 vx9000-1D96AB -

Total number of entries displayed: 2

vx9000-1D96AB#show mint neighbors on ap7532-71C0D4
2 mint neighbors of 1B.71.C0.D4:
1B.74.3E.6C (ap7532-743E6C) at level 1, best adjacency vlan-1
12.1D.96.AB (vx9000-1D96AB) at level 2, best adjacency ip-172.17.8.3:24576

vx9000-1D96AB#show mint neighbors on ap7532-743E6C
1 mint neighbors of 1B.74.3E.6C:
1B.71.C0.D4 (ap7532-71C0D4) at level 1, best adjacency vlan-1

vx9000-1D96AB#show mint links
1 mint links on 12.1D.96.AB:
link ip-172.17.8.4:24576 at level 2, 1 adjacencies, (used)

What is wrong with my configuration?

Why I can’t make the upgrades working through RFDM AP?

 

Thanks,

 

Aviv

icon

Best answer by Chris Kelly 23 October 2019, 20:53

I can certainly testify that this works perfectly in WiNG-5.  (Can’t imagine how it would’ve gotten messed up in WiNG-7 though).  This topology is used for a HUGE number of deployments.  If something was fundamentally broken in this regard, we’d have heard about it long before now.

 

From the controller, my output looks like this:

NX(config)#sh device-upgrade history on LAB
-------------------------------------------------------------------------------------------------
            Device      RESULT                 TIME  RETRIES        UPGRADED-BY LAST-UPDATE-ERROR
-------------------------------------------------------------------------------------------------

   LAB-MCX            done  2019-03-13 13:15:37        0       8533-Floor-1      -

   8533-Floor-2      done  2019-03-13 13:14:39        0       8533-Floor-1      -

   8533-Floor-2      done  2018-11-09 12:39:30        0       8533-Floor-1      -
Total number of entries displayed: 3

 

 

On the RFDM AP, the output shows this (the non-RFDM AP output is empty)

(You can see in the first column (Device) the listing of non-RFDM APs that this RFDM AP had upgraded.

8533-Floor-1#sh device-upgrade history
-------------------------------------------------------------------------------------------------
            Device      RESULT                 TIME  RETRIES        UPGRADED-BY LAST-UPDATE-ERROR
-------------------------------------------------------------------------------------------------

  8533-Floor-2       done  2019-03-13 13:14:39        0       8533-Floor-1      -

  LAB-MCX             done  2019-03-13 13:15:37        0       8533-Floor-1      -

  8533-Floor-2       done  2018-11-09 12:39:30        0       8533-Floor-1      -
Total number of entries displayed: 3

 

View original

20 replies

Userlevel 3

Hi Avi,

  Everything looks good. And how the upgrade process looks like? You can monitor it with "watch 4 sh device-upgrade status". Also the devices can skip the update while already running requested release and without "force" option in upgrade command..

Misha

Userlevel 3

Hello Misha,

Upgrade process is looking OK, but I expecting to see from show device-upgrade history

something like: UPGRADED-BY - ap7532-743E6C, but I don’t see that.

Also I don’t see any temp firmware file stored on the flash of the RFDM AP, as expected.

So, I think the upgrade is accomplished through VX9000 without RFDM AP, so the file is transferred twice.

Thanks,

 

Aviv

 

Userlevel 5

Hello Aviv,

      Please use the attached when upgrading VX9 and adopted remote APs.

Userlevel 6

The results of the MINT links and neighbors looks correct.

 

Can you run the device upgrade history command directly on the AP’s themselves?

Specifically interested in the output from the non-RFDM AP.

 

Userlevel 3

Hello Aviv,

  Please note that

  1. Upgrade always happens with RFDM unless you specify “from-controlled” explicitly
  2. UPGRADED-BY shows device, who is actually handle the upgrade i.e. control the process, hosts the AP image etc
  3. In case you upgrading many RFD from active-active (not recommended) VX cluster - perhaps you will have these upgrading activities shared between nodes

vx9000-5566BE#device-upgrade rf-domain TEST all ?

  force             Force upgrade of devices in the rf-domain

  from-controller   Upgrade devices from the adopted device

  no-reboot         No reboot (manually reboot after the upgrade)

  reboot-time       Schedule a reboot time

  staggered-reboot  Reboot one at a time without network being hit

  upgrade-time      Schedule an upgrade time

  <cr>

 

Misha

Userlevel 3

Hello guys,

Logs from VX when device-upgrade rf-domain default all force executed :

vx9000-1D96AB#device-upgrade all force 
In progress ....
--------------------------------------------------------------------------------
CONTROLLER STATUS MESSAGE
--------------------------------------------------------------------------------
08-00-27-1D-96-AB Success Number of devices added for upgrade: 2
--------------------------------------------------------------------------------
Are you sure you want to proceed with the upgrade? (y/n): y
--------------------------------------------------------------------------------
CONTROLLER MESSAGE
--------------------------------------------------------------------------------
08-00-27-1D-96-AB Successfully started device upgrade
--------------------------------------------------------------------------------
vx9000-1D96AB#show device-upgrade status
Number of devices currently being upgraded : 2
Number of devices waiting in queue to be upgraded : 0
Number of devices currently being rebooted : 0
Number of devices waiting in queue to be rebooted : 0
Number of devices failed upgrade : 0
--------------------------------------------------------------------------------------------------------------
DEVICE STATE UPGRADE TIME REBOOT TIME PROGRESS RETRIES LAST UPDATE ERROR UPGRADED BY
--------------------------------------------------------------------------------------------------------------
ap7532-71C0D4 downloading immediate immediate 8 0 - vx9000-1D96AB
ap7532-743E6C downloading immediate immediate 8 0 - vx9000-1D96AB
--------------------------------------------------------------------------------------------------------------
vx9000-1D96AB#show gl domain managers
-----------------------------------------------------------------------------------------------------
RF-DOMAIN MANAGER HOST-NAME APS CLIENTS
-----------------------------------------------------------------------------------------------------
VXtest 08-00-27-1D-96-AB vx9000-1D96AB 0 0
default B8-50-01-71-C0-D4 ap7532-71C0D4 2 0
-----------------------------------------------------------------------------------------------------
Total number of RF-domain displayed: 2
vx9000-1D96AB#show device-upgrade status
Number of devices currently being upgraded : 2
Number of devices waiting in queue to be upgraded : 0
Number of devices currently being rebooted : 0
Number of devices waiting in queue to be rebooted : 0
Number of devices failed upgrade : 0
--------------------------------------------------------------------------------------------------------------
DEVICE STATE UPGRADE TIME REBOOT TIME PROGRESS RETRIES LAST UPDATE ERROR UPGRADED BY
--------------------------------------------------------------------------------------------------------------
ap7532-71C0D4 downloading immediate immediate 49 0 - vx9000-1D96AB
ap7532-743E6C downloading immediate immediate 49 0 - vx9000-1D96AB
--------------------------------------------------------------------------------------------------------------
vx9000-1D96AB#

logs from ap7532-71C0D4

2019-10-23 11:16:26     ap7532-71C0D4  SYSTEM     CONFIG_REVISION      Configuration revision updated to 4 from 3
2019-10-23 11:14:25 ap7532-71C0D4 SYSTEM WARM_START_RECOVER Warm Start Recover. Reason: Upgrade done, reloading... (user: system @ vx9000-1D96AB) Timestamp: Oct 23 11:11:57 2019
2019-10-23 11:14:23 ap7532-71C0D4 SYSTEM CONFIG_REVISION Configuration revision updated to 3 from 3
2019-10-23 11:14:23 ap7532-71C0D4 SYSTEM CONFIG_COMMIT Configuration commit by user 'cfgd' (update own config) from '127.0.0.1'
2019-10-23 11:14:27 ap7532-71C0D4 SYSTEM CLOCK_RESET System clock reset, Time: 2019-10-23 11:14:23
2019-10-23 11:14:26 ap7532-71C0D4 DEVICE ADOPTED_TO_CONTROLLER Joined successfully with controller 'vx9000-1D96AB'(12.1D.96.AB)
2019-10-23 11:14:26 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message adopted-event from module cfgd
2019-10-23 11:13:55 ap7532-71C0D4 NSM DHCPIP Interface vlan1 acquired IP address 172.17.8.4/24 via DHCP
2019-10-23 11:13:55 ap7532-71C0D4 NSM DHCPDEFRT Default route with gateway 172.17.8.254 learnt via DHCP
2019-10-23 11:12:54 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:54 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R2' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:54 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:54 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R2' changing state from 'Off' to 'Initializing'
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R1' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R1' changing state from 'Off' to 'Initializing'
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R2' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R2' changing state from 'Unconfigured' to 'Initializing'
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R1' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 RADIO RADIO_STATE_CHANGE Radio 'ap7532-71C0D4:R1' changing state from 'Unconfigured' to 'Initializing'
2019-10-23 11:12:53 ap7532-71C0D4 MESH MESHPOINT_LOOP_PREVENT_OFF Meshpoint loop prevention off (port ALL), all wired traffic is allowed
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message AP_LEDS_ON from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message LED_NO_COUNTRY_CODE_SET from module DOT11
2019-10-23 11:12:53 ap7532-71C0D4 MINT RFDM_MGR_UPDATE own_mint_id 1b.71.c0.d4 sitemgr_mint_id 1b.71.c0.d4
2019-10-23 11:12:52 ap7532-71C0D4 MINT RFDM_MGR_UPDATE own_mint_id 1b.71.c0.d4 sitemgr_mint_id 00.00.00.00
2019-10-23 11:12:52 ap7532-71C0D4 MINT RFDM_MGR_UPDATE own_mint_id 1b.71.c0.d4 sitemgr_mint_id 1b.71.c0.d4
2019-10-23 11:12:52 ap7532-71C0D4 MINT RFDM_MGR_UPDATE own_mint_id 1b.71.c0.d4 sitemgr_mint_id 00.00.00.00
2019-10-23 11:12:52 ap7532-71C0D4 DIAG NEW_LED_STATE LED state message LED_LOCATIONING_OFF from module cfgd

log from ap7532-743E6C

2019-10-23 11:16:27     ap7532-743E6C  SYSTEM     CONFIG_REVISION      Configuration revision updated to 4 from 3
2019-10-23 11:14:27 ap7532-743E6C SYSTEM WARM_START_RECOVER Warm Start Recover. Reason: Upgrade done, reloading... (user: system @ vx9000-1D96AB) Timestamp: Oct 23 11:11:58 2019
2019-10-23 11:14:26 ap7532-743E6C SYSTEM CONFIG_REVISION Configuration revision updated to 3 from 3
2019-10-23 11:14:26 ap7532-743E6C SYSTEM CONFIG_COMMIT Configuration commit by user 'cfgd' (update own config) from '127.0.0.1'
2019-10-23 11:14:29 ap7532-743E6C SYSTEM CLOCK_RESET System clock reset, Time: 2019-10-23 11:14:26
2019-10-23 11:14:29 ap7532-743E6C DEVICE ADOPTED_TO_CONTROLLER Joined successfully with controller 'vx9000-1D96AB'(12.1D.96.AB)
2019-10-23 11:14:29 ap7532-743E6C DIAG NEW_LED_STATE LED state message adopted-event from module cfgd
2019-10-23 11:14:02 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 1b.71.c0.d4
2019-10-23 11:14:01 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 1b.74.3e.6c
2019-10-23 11:13:56 ap7532-743E6C NSM DHCPIP Interface vlan1 acquired IP address 172.17.8.30/24 via DHCP
2019-10-23 11:13:56 ap7532-743E6C NSM DHCPDEFRT Default route with gateway 172.17.8.254 learnt via DHCP
2019-10-23 11:13:00 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 1b.71.c0.d4
2019-10-23 11:12:55 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:55 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R2' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:55 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:55 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R2' changing state from 'Off' to 'Initializing'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R1' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R1' changing state from 'Off' to 'Initializing'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R2' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_1_52G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R2' changing state from 'Unconfigured' to 'Initializing'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R1' changing state from 'Initializing' to 'Off(no country-code)'
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message WIOS_LED_NO_COUNTRY_0_24G from module DOT11
2019-10-23 11:12:54 ap7532-743E6C RADIO RADIO_STATE_CHANGE Radio 'ap7532-743E6C:R1' changing state from 'Unconfigured' to 'Initializing'
2019-10-23 11:12:54 ap7532-743E6C MESH MESHPOINT_LOOP_PREVENT_OFF Meshpoint loop prevention off (port ALL), all wired traffic is allowed
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message AP_LEDS_ON from module DOT11
2019-10-23 11:12:54 ap7532-743E6C DIAG NEW_LED_STATE LED state message LED_NO_COUNTRY_CODE_SET from module DOT11
2019-10-23 11:12:53 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 1b.74.3e.6c
2019-10-23 11:12:53 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 00.00.00.00
2019-10-23 11:12:53 ap7532-743E6C MINT RFDM_MGR_UPDATE own_mint_id 1b.74.3e.6c sitemgr_mint_id 00.00.00.00
2019-10-23 11:12:53 ap7532-743E6C DIAG NEW_LED_STATE LED state message LED_LOCATIONING_OFF from module cfgd
2019-10-23 11:12:51 ap7532-743E6C MGMT LOG_HTTP_START lighttpd started in external mode
2019-10-23 11:12:51 ap7532-743E6C SYSTEM SYSTEM_AUTOUP_ENABLE Autoupgrade enabled for ap7562
2019-10-23 11:12:51 ap7532-743E6C DIAG NEW_LED_STATE LED state message LED_LOCAL_LICENSE from module CFGD
2019-10-23 11:12:51 ap7532-743E6C SYSTEM SYSTEM_AUTOUP_ENABLE Autoupgrade enabled for ap7522
2019-10-23 11:12:51 ap7532-743E6C DIAG NEW_LED_STATE LED state message LED_LOCAL_LICENSE from module CFGD
2019-10-23 11:12:51 ap7532-743E6C SYSTEM SYSTEM_AUTOUP_ENABLE Autoupgrade enabled for ap7532
2019-10-23 11:12:51 ap7532-743E6C LICMGR LIC_INSTALL_DEFAULT AP default license installed, count: 64
2019-10-23 11:12:51 MGMT LOG_HTTP_START lighttpd started in external mode
2019-10-23 11:12:51 MGMT LOG_HTTP_START lighttpd started in external mode
2019-10-23 11:12:51 DHCPSVR DHCPSVR_STOP DHCP server is stopped
2019-10-23 11:12:53 NSM IFUP Interface ge1 is up
2019-10-23 11:12:50 SYSTEM CONFIG_REVISION Configuration revision updated to 3 from 2
2019-10-23 11:12:50 SYSTEM CONFIG_REVISION Configuration revision updated to 2 from 1
2019-10-23 11:12:51 NSM IFDOWN Interface ge1 is down
2019-10-23 11:12:50 SYSTEM CONFIG_COMMIT Configuration commit by user 'cfgd' (read startup-config) from '127.0.0.1'
2019-10-23 11:12:51 NSM IFUP Interface vlan1 is up

show upgrade from AP:

ap7532-71C0D4#show upgrade?
upgrade-status Display last image upgrade status

ap7532-71C0D4#show upgrade

Regards,

 

Aviv

Userlevel 3

Log from VX when executed device-upgrade rf-domain default all force from-controller

vx9000-1D96AB#device-upgrade rf-domain default all force from-controller 
In progress ....
--------------------------------------------------------------------------------
CONTROLLER STATUS MESSAGE
--------------------------------------------------------------------------------
08-00-27-1D-96-AB Success Number of devices added for upgrade: 2
--------------------------------------------------------------------------------
vx9000-1D96AB#show device-upgrade status
Number of devices currently being upgraded : 2
Number of devices waiting in queue to be upgraded : 0
Number of devices currently being rebooted : 0
Number of devices waiting in queue to be rebooted : 0
Number of devices failed upgrade : 0
--------------------------------------------------------------------------------------------------------------
DEVICE STATE UPGRADE TIME REBOOT TIME PROGRESS RETRIES LAST UPDATE ERROR UPGRADED BY
--------------------------------------------------------------------------------------------------------------
ap7532-71C0D4 downloading immediate immediate 30 0 - vx9000-1D96AB
ap7532-743E6C downloading immediate immediate 30 0 - vx9000-1D96AB
--------------------------------------------------------------------------------------------------------------
vx9000-1D96AB#

Its looks like the same procedure, the image is uploaded from VX to the APS simultaneously, without the RFDM AP :(

 

Thanks

 

Aviv

Userlevel 6

Aviv, please see my previous request.

Userlevel 3

Aviv, please see my previous request.

 

This is only option to see the upgrade history info:

ap7532-71C0D4#show upgrade?
upgrade-status Display last image upgrade status

Upgrade history of the APS is clear on these APS.

Please look into event-histories attached in my previous message.

 

Thanks,

Aviv

Userlevel 6

The command I’m wanting to see the results of are:

show device-upgrade status

Userlevel 3

The command I’m wanting to see the results of are:

show device-upgrade status

 

Userlevel 3

 

Userlevel 6

My fault on the command - as you correctly replied with, I was looking for the command ‘history’.

But yeah...something’s not right here.  Not sure what though.

Wondering if something in WiNG-7 changed with this RFDM-AP distributed firmware upgrade process.

As seen in your earlier MINT link outputs, the RFDM AP has its level-2 MINT link and the non-RFDM AP just has its single level-1 MINT link with the RFDM AP.   That’s exactly as it should be.  

 

In my lab on a WiNG-5 distributed setup, I clearly see the RFDM AP and non-RFDM APs both showing device-upgrade history info….. and the non-RFDM AP indicates that it was upgraded by the RFDM AP.

 

In addition, you can run this command on the controller and it will also (should) tell you the APs that were upgrade and *which* RFDM AP performed it.

show device-upgrade history on <RFD>

Userlevel 3

Chris,

Can you please share the correct output from the controller ?

In the near past tried to make this feature to work with ALL the same topology, but with WING 5.9.3.3 and RFS4000, but with no luck.

So, maybe, we are talking about some very old bug ?

I need this feature working, for our customer with VX and have about 400 branches, so this feature is very important, since WAN links are  pretty slow.

Thanks,

Aviv

Userlevel 6

I can certainly testify that this works perfectly in WiNG-5.  (Can’t imagine how it would’ve gotten messed up in WiNG-7 though).  This topology is used for a HUGE number of deployments.  If something was fundamentally broken in this regard, we’d have heard about it long before now.

 

From the controller, my output looks like this:

NX(config)#sh device-upgrade history on LAB
-------------------------------------------------------------------------------------------------
            Device      RESULT                 TIME  RETRIES        UPGRADED-BY LAST-UPDATE-ERROR
-------------------------------------------------------------------------------------------------

   LAB-MCX            done  2019-03-13 13:15:37        0       8533-Floor-1      -

   8533-Floor-2      done  2019-03-13 13:14:39        0       8533-Floor-1      -

   8533-Floor-2      done  2018-11-09 12:39:30        0       8533-Floor-1      -
Total number of entries displayed: 3

 

 

On the RFDM AP, the output shows this (the non-RFDM AP output is empty)

(You can see in the first column (Device) the listing of non-RFDM APs that this RFDM AP had upgraded.

8533-Floor-1#sh device-upgrade history
-------------------------------------------------------------------------------------------------
            Device      RESULT                 TIME  RETRIES        UPGRADED-BY LAST-UPDATE-ERROR
-------------------------------------------------------------------------------------------------

  8533-Floor-2       done  2019-03-13 13:14:39        0       8533-Floor-1      -

  LAB-MCX             done  2019-03-13 13:15:37        0       8533-Floor-1      -

  8533-Floor-2       done  2018-11-09 12:39:30        0       8533-Floor-1      -
Total number of entries displayed: 3

 

Userlevel 3

Chris,

I will test also it with 5.9.4.1+ and update you.

RFD without country code and ap profile without rf domain manager capable… I’ll check it...

Thanks,

Aviv

Userlevel 6

The AP profile needs to have the RFDM-capable option enabled for this Distributed setup.  Otherwise, none of the APs in the ‘remote’ RFD will be able to be elected...and the test won’t work.

From what I can tell, your configuration looks correct, based on the MINT queries you’ve supplied.  So you just would want to re-test this again but with 5.9.x

 

Also….if it still doesn’t work as expected with 5.9.x, try setting the county-code for the “default” RFD.  It shouldn’t be necessary, but it’s also very unusual to have an RFD for APs where it isn’t configured.  Just want to make sure that this isn’t some sort of weird bug/restriction.

Userlevel 3

Hello Chris,

Just validated with 5.9.4.1 and working well with the same configuration, so I suggest to test it in your LAB and open case about WING 7.2.1.1 bug. I continue tests with WING5.

But It's important to consider that the first adoption of APS with different OS version from controller requires an upgrade from VX because the aps firstly are without control vlan.

But I think, I can workaround it:

  1. I can set an enforce-version adoption none +  device-upgrade auto on VX.
  1. after 1 AP at remote site adopted and configured manually with high RFDM priority, all other APS at the remote site receive the L3 adoption site from dhcp option and VX add to the APS a control vlan. Than VX should upgrade and configure the other APS through RFDM automatically.
     

I right?

 

Thanks,

Aviv

Userlevel 6

Aviv,

Are you saying that your initial test here with 7.2 involved an initial adoption scenario where all of the APs needed to be upgraded?  If that’s the case, then it is *expected/known* that the 1st upgrade for a remote site WILL require that each AP be upgraded individually by the controller (each AP using its initial level-2 MINT link).  Like you mentioned, in this *initial deployment* scenario, the APs are not yet adopted….so they don’t yet have their config...and they don’t have their config yet because they first have to have a matching WiNG firmware version.  Once the firmware match requirement is met, they get their config, and then the tear-down from level-2 MINT links to level-1 MINT links (for the non-RFDM APs) is performed and the RFDM is elected.  Then going forward, the firmware updates are performed by the RFDM AP.

Trying to circumvent this though by relaxing the version matching requirements is not something you should be doing in a production environment...unless you first thoroughly test the specific setup and accept the responsibility of anything going wrong.

In some cases, doing this might not cause any problems.   But doing this can have unexpected results.  Using the ability to have non-matching WiNG firmware on the APs should only be used in special cases, and is meant to be a *short-term temporary* solution.

What you are suggesting may in fact work.  But if you run into any problems while doing this, it won’t be supported and will not be considered a bug. 

 

Userlevel 3

Thanks a lot :grinning:

Reply