Header Only - DO NOT REMOVE - Extreme Networks

Wireless Bridge ( AP7532 to AP7532 )


Userlevel 1
I have two AP7532 setup as a wireless bridge, The bridge is working, On the remote side I have installed an ap7131 - I can see the SSID and connect units will get an IP, however the AP is not checking into the RFS7000, If I connect the AP to the local network it does check in

On the AP I have 3 SSID's 1 on vlan1 ( same as the RFS7k ) and 2 on Vlan 10 which leaves the network via a different route.

I can connect to the SSID on VLAN1 and get an IP, the two wifi networks on VLAN 10 are not operational at present as I have to add the VLAN info to the network switch where the AP is

Have I missed something when setting the bridge up ?

20 replies

Userlevel 4
Do you use local bridging for traffic? If yes, are booth VLANs added to the bridge?
Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi Steve,

where on the AP 7131 ?
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Configuration>System Profile>Adoption: scroll down to Controller Hostnames and add the address of the RF7X and set to use Routing Level 2. Obviously if this works and it gets adopted you will need to mirror this in the AP Profile is receives from the RF7X.

Alternatively CLI to the AP:

enable

config self

controller host xxx.xxx.xxx.xxx level 2
Userlevel 4
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

It's just L1 adoption, not L1 traffic.

Enter the IP and do level 1, if it's local RF Domain. Not mix L1 and L2.

Alternative you can do DHCP adoption
Option 191=pool1=[i],[i];level=1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Thanks Timo for the clarification - Level 2 is intended for centralised deployments so I was wrong about L2 being needed
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Still not working, So the Bridge AP's is set as a trunk with allowed Vlans 1,4096

On the Ethernet switch ( Avaya 5520 ) the port is set to Trunk with allowed vlans 1,10

the controller is on Vlan1. At the remote site there is another AVAYA 5520, The port the AP is connected to is set as trunk with allowed vlans 1,10, The AP on the Ethernet port is set to allow vlans 1,4096. then on the wifi side there are to wlans one for vlan1 and the other for Vlan 2

I tried setting the adoption on the AP with the IP of the controller, but as its not checking in I'm not sure it would pickup the change ?
Userlevel 4
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

What VLANs you use for local traffic?

VLAN 1 -> controller and wifi
VLAN 2 -> wifi (bridge or local?)
VLAN 4096 -> for what?

If you use VLAN 2 local, you need to allow this on the switch and bridge. If you use it as tunnel, you don't need it on booth.

For adoption, do you use the DHCP or static?

What neighbors you can see from the AP7131? show mint neighbor
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi and thanks for all the replies,

The AP is now visible on the RFS, I can see the WLAN on VLAN 1 has clients attached which is great, I do have another WLAN on VLAN 10, VLAN10 works fine in the main building but although the WLAN is visible in the remote building the devices do not get an IP address. The IP is provided by an ADSL router in the main building so its not passing over the bridge, but it passes VLAN 1 traffic. Is there something else I need to check ?
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi Phil

I think you might need a Trunk VLAN1, VLAN10 interface on the RFS assuming that WLAN10 on the AP is tunnelling traffic
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Ge1 is a trunk and the port on the Avaya is a trunk, VlLAN10 Its working in the main building just not in the remote building
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi Timo

The wifi networks are tunnelled, To the RFS. The AP's and the Bridge are set for any VLAN 1-4094, on the trunk port or the Ethernet switch it is set as a trunk port with VLAN 1,10, On the RFS GE1 is also set as a trunk port with VLAN's 1,10

So from the AP in the remote building, I can ping the gateway on Vlan 10, But not from the remote AP, so it would seem something is missing from the Bridge setup
Userlevel 4
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi,

if you would tunnel the traffic for VLAN 10, don't add VLAN 10 to the AP as interface. Just configure it under the WLAN, not at the AP. If you do this and configure tunnel for the WLAN with VLAN 10, it'S tunnel.

If you make vlan 10 local at the AP available, it bridge the traffic local.

But if you need vlan 10 local at the switch, you can configure VLAN 10 with IP at all APs remote and try to ping. With this you can check, if VLAN 10 works remote and the problem is the bridge.
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

I have tested the VLAN 10 at the remote building, If I give myself a static IP and set the DNS etc VLAN 10 works fine, if I then set my device back to DHCP, it gets a new address on VLAN 10 and works, Then I selected forget this network, and set it up on my device, it sees the SSID for VLAN 10 then fails to get an IP address, So for some reason its not getting an IP address quick enough, 😞
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Assuming the WLAN is tunnelled - I would suggest adding the VLAN10 Router's address as a static route or D/G on the RFS under Configuration>Network>Routing as it appears that the client's DHCP requests are not being forwarded by the RFS as it does not know how to reach the VLAN10 Router?
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hi Steve

under Configuration>Network>Routing is this policy based routing ? or do you mean Devices-configuration- network-Routing ?
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

On the RFS Device>network>routing
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

Hmm

It no likey, as there is already default gateway, this is under wing5.8.5
Userlevel 4
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

I think router and DHCP are two complete different parts.

You can do a packet capture on the ethernet interface from the AP and check filter for DHCP. Is DHCP forwarded to the LAN, is a response from LAN available?

Additional you can check drop and deny.

Other option, configure multicast to unicast DHCP, if you have a problem with to much broadcast is an option.
Userlevel 1
steve kemball wrote:

Hi Phil, If you are using a MESH config' for the bridge it doesn't forward Layer 2 (Level 1) mint adoption requests. Try configuring the AP7131 to use L2 adoption

The Router is a an ADSL router that is also the DHCP server, I'll try and get wireshark running later today

Reply