2.4ghz speed slow

I’m having issues with the 2.4ghz network. At first when connecting to an SSID it says connected, no internet. Shortly after that it starts working, but extremely slow. Speed tests have it at .016mbps download and 1mbps upload. Using a wifi analyzer I notice the only channel it stays on is 11. I have a smart rf policy that has channel 1,6, and 11 for the 2.4ghz network but it looks like it’s stuck on 11. 


I need some help getting the 2.4ghz network working. If I enable the same SSID on the same AP connected to the same port but enable it on the 5ghz radio it works great. Upload and download speeds are both about 200mbps.

This topic has been closed for comments

20 replies

Userlevel 6

Are there any other WiNG APs involved here or is this a standalone AP?

Is radio 1 possibly hard set for channel 11 in the AP’s Profile? (Device override?)

Show the output for: show smart-rf history | in R1

Eventually there will be more, right now I’m just testing it on a single AP310E. I just checked it’s device settings and there’s nothing hard coded into it. 


I have AP7632s that have the same settings at a different building that work great on both 2.4 and 5ghz. I’m just having issues with the AP310E with the latest firmware.

Userlevel 6

What is the WiNG version?

Show the output for: show smart-rf history | in R1

I was mistaken I thought I was on the all downloads page but it was the download history page. I have Wing, version is out now that may or may not fix some the issue.



Userlevel 6

So smart-rf could be just doing its job and landing on channel 11 because it thinks it’s the best of the three choices….and maybe all three channels are bad in the area, but channel 11 is the least bad. (log output does show a channel change from ch1 to ch11 due to an interference recovery)

With this being a 310e, I’m assuming here that you have antennas attached. (Are the antennas that are connected to the 2.4GHz connectors 2.4GHz antennas??

Do you have another AP model you can use for testing in the same exact area as the 310e? If you do, how is the 2.4GHz throughput when it’s also operating on channel 11? (Force it to channel 11 if you have to)

Curious to see what the output of this is too:

show smart-rf radio energy all-11bgn

I do have antennas attached the model is Extreme Networks ml-2452-apa2-02.

I can try getting an old AP-6521 going to test that out for you and I’ll reply soon letting you know the throughput.


Here’s the output you wanted:


Userlevel 6

Okay, so those antennas are dual-band, so no issue there.

The energy graph doesn’t indicate a problem with non-wifi interference...and it does appear that smart-rf selecting channel 11 makes sense based on the output.

Be very curious to see how the 6521 behaves.


Can you post the output of these while the client is associated?

show wireless client statistics detail

show wireless client statistics rf

Command 1:

Command 2:




It will still be a little bit before I can test out the 6521

Userlevel 6

Everything looks very good on those stats.

At this point, I’d still want to see how the 6521 compares.

@Chris Kelly I plugged the old 6521 in, setup the ssid the same way. I don’t believe smart rf is being used on it, and it’s on channel 1 which seems to be used by a lot of wireless networks around here, I’m not sure how to force it onto channel 11 with the CLI. The throughput and speed works decently with 50 download and 50 upload. Even that would be acceptable on the new system.


Here’s those last 2 commands run on the 6521:


Command 1:



Command 2: 




And for reference this is plugged in to the same port the AP310e was plugged into. It’s also not adopted by a controller.

Userlevel 6 as a last check, to get the 6521 to channel 11, in the CLI:


  • enable
  • self
  • interface radio 1
  • channel 11
  • commit

That worked, I can confirm it’s on channel 11 now. The speed / throughput is the same as when it was on channel 1. I’m at a big loss as to why the 2.4ghz is working so terribly on any of the 310e’s I have.

Userlevel 6

The only thing I can think of right now is that there’s something with the 11ax functionalities on the 310e that is causing this.

To test:


  • enable
  • self
  • interface radio 1
  • no 11axSupport
  • no 11axOFMDA
  • no 11axBSScolor
  • no 11axTWT
  • no 11axUmuschedBrcmOnly
  • commit

Test client again.

I ran those commands and committed them. It’s still having throughput issues.

Do you think upgrading the controller and APs to from would fix any issues?

Userlevel 6

Out of curiosity, what does the client connection speed indicate?

Even though speeds are slow, can the client get a consistent set of PING replies to the AP or something behind it?


I’m not sure what else might be causing this. If I had a 310 I’d try to replicate it. This isn’t something I’ve run across before.

At this point though, GTAC will need to do a deeper dive.

That was a good question. It looks like if I ping the AP from the client or even the switch behind the AP that packets are getting dropped, and the response time is high, 600-1000ms for some packets. HOWEVER if I run traceroute and ping commands on the AP pinging various devices on the network and internet the replies come back at a normal rate of around 1ms. It’s something weird with the 2.4ghz because it works fine on 5ghz. 


I’ll reach out to GTAC. If we get it working I’ll reply with the solution in case anyone else down the road runs into this as well. 

Userlevel 6

If you want, grab a copy of the running-config and strip out anything you don’t want seen and post it. I’ll look through it and see if there’s anything in the actual config that might have something to do with this behavior.

Here is the running config for the AP. It’s connected to a controller in a different broadcast domain.


!### show running-config
! Configuration of AP310 version
version 2.7
ip snmp-access-list default
 permit any
firewall-policy default
 no ip dos smurf
 no ip dos twinge
 no ip dos invalid-protocol
 no ip dos router-advt
 no ip dos router-solicit
 no ip dos option-route
 no ip dos ascend
 no ip dos chargen
 no ip dos fraggle
 no ip dos snork
 no ip dos ftp-bounce
 no ip dos tcp-intercept
 no ip dos broadcast-multicast-icmp
 no ip dos land
 no ip dos tcp-xmas-scan
 no ip dos tcp-null-scan
 no ip dos winnuke
 no ip dos tcp-fin-scan
 no ip dos udp-short-hdr
 no ip dos tcp-post-syn
 no ip dos tcphdrfrag
 no ip dos ip-ttl-zero
 no ip dos ipspoof
 no ip dos tcp-bad-sequence
 no ip dos tcp-sequence-past-window
 no ip-mac conflict
 no ip-mac routing conflict
 no stateful-packet-inspection-l2
mint-policy global-default
wlan-qos-policy default
 qos trust dscp
 qos trust wmm
radio-qos-policy default
wlan SethTest
 ssid SethTest
 vlan 1
 bridging-mode local
 encryption-type ccmp
 authentication-type none
 no multi-band-operation
 no protected-mgmt-frames
 wpa-wpa2 psk 0 testing1
smart-rf-policy default
 assignable-power 2.4GHz min 10
 channel-list 5GHz 36,40,44,48,149,153,157,161,165
 no select-shutdown
 no smart-sensor
 smart-sensor auto-trigger
 smart-sensor band smart-band-5GHz
 no smart-sensor tri-radio-only
management-policy default
 no telnet
 no http server
 https server
 no ftp
 user admin password 1 censored role superuser access all
 snmp-server community 0 private rw
 snmp-server community 0 public ro
 snmp-server user snmptrap v3 encrypted des auth md5 0 admin123
 snmp-server user snmpmanager v3 encrypted des auth md5 0 admin123
profile ap310 "8120 - AP310"
 ip name-server
 ip name-server
 ip domain-name censored
 no autoinstall configuration
 no autoinstall firmware
 device-upgrade auto ap310 ap360
 crypto ikev1 policy ikev1-default 
  isakmp-proposal default encryption aes-256 group 2 hash sha 
 crypto ikev2 policy ikev2-default 
  isakmp-proposal default encryption aes-256 group 2 hash sha 
 crypto ipsec transform-set default esp-aes-256 esp-sha-hmac
 crypto ikev1 remote-vpn
 crypto ikev2 remote-vpn
 crypto auto-ipsec-secure
 crypto load-management
 crypto remote-vpn-client
 interface radio1
  data-rates bgn
  wlan SethTest bss 1 primary
 interface radio2
 interface bluetooth1
  mode le-sensor
 interface ge1
 interface ge2
 interface vlan1
  ip address dhcp
  ip dhcp client request options all
 interface pppoe1
 use firewall-policy default
 ntp server 
 ntp server 
 rf-domain-manager capable
 controller vlan 1
 service pm sys-restart
 router ospf
 adoption-mode controller
rf-domain 8120
 location 8120
 timezone America/New_York
 country-code us
 use smart-rf-policy default
 ad-wips-wireless-mitigation disable
 ad-wips-wired-mitigation disable
 channel-list dynamic
 control-vlan 1
ap310 20-9E-F7-FB-78-EF
 use profile "8120 - AP310"
 use rf-domain 8120
 hostname 8120-Planning-310e
 area "8120 Planning"
 controller host