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Dragon: EMS Client does not Connect Due to a Lack of Diskspace


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Article ID: 11603

Products
Dragon IDS

Changes
Attempting to launch and log into the EMS Client.

Symptoms
The EMS Client fails to connect.
No errors or entries written to the /opt/dragon/logs/jboss.log file.

Cause
This issue is caused by a lack of diskspace on the /opt partition on the Dragon EMS server machine.

Solution/Workaround
The command df -k will display the amount of diskspace that is currently in use for each partition.

To recover diskspace on the EMS server machine, here are the common steps to remove some non-critical files:

  1. ./dragon-shutdown.sh
  2. rm /opt/dragon/logs/*.log
  3. rm /opt/dragon/logs/jboss*
  4. rm /opt/dragon/.cache/ring*
  5. rm /opt/dragon/.cache/agent*
If more diskspace is needed to recover, you may need to delete files within the/opt/dragon/DB directory. Please note that these files are your event data, and deleting a selected range of these files will prohibit you from running a report on those deleted ranges.

Once diskspace utilization on the /opt partition is less than 98%, the EMS client should now successfully connect.

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