Header Only - DO NOT REMOVE - Extreme Networks

History of default port adminEdge settings on the SecureStacks


Userlevel 3
Article ID: 5756

Products
SecureStack C2
Firmware 3.03.33 and higher
SecureStack B2
Firmware 3.00.14 and higher
SecureStack A2
Firmware 1.02.12 and higher

Symptoms
'set spantree adminedge'
Spanguard / Securespan failing to block ports
Port link state changes trigger Spanning Tree respan

Cause
The default adminEdge settings have changed, since release of the product.

On the SecureStack C2; by default adminEdge="true" through firmware 3.03.27, and adminEdge="false" with firmware 3.03.33 and higher.

On the SecureStack B2; by default adminEdge="true" through firmware 2.01.10, and adminEdge="false" with firmware 3.00.14 and higher.

On the SecureStack A2; by default adminEdge="true" through firmware 1.01.46, and adminEdge="false" with firmware 1.02.12 and higher.

Solution
For optimal automated adminEdge behavior:
  • On the SecureStack C2, upgrade to firmware 3.03.38 or higher.
  • On the SecureStack B2, upgrade to firmware 3.00.14 or higher.
  • On the SecureStack A2, upgrade to firmware 1.02.12 or higher.
As of the stated firmware versions, the default adminEdge behavior begins with the value set to "false" initially, after the device is powered up. If a Spanning Tree BDPU is not received on the port within a few seconds, the adminEdge setting changes to "true". This process should take approximately four seconds, in line with the behavior displayed on the DFE product line.

As desired...

With earlier firmware, on InterSwitch Link ports configure 'set spantree adminedge <port_string> false' to override the default setting.

With later firmware, on Edge ports configure 'set spantree adminedge <port_string> true' to override the default setting.

Any such operation must be performed via the CLI or WebView, as SNMP access is not yet supported for the dot1dStpPortAdminEdgePort=1.3.6.1.2.1.17.2.19.1.2 MIB, on the SecureStack line.

See also: 5258 and 5759.

0 replies

Be the first to reply!

Reply