Header Only - DO NOT REMOVE - Extreme Networks

N-Series may not Form an OSPF Adjacency with X-Series using a Large MTU Size


Userlevel 3
Article ID: 10313

Products
Matrix X-Series, Matrix N-Series DFE

Changes
Configured routing with OSPF.
On the X-Series, enabled jumbo frame support on Layer 3 ('mtu 9000') to prevent packet fragmentation.
On the N-Series, enabled jumbo frame support on Layers 2 and 3 ('set port jumbo enable <port#>') to match.

Symptoms
The forming of OSPF adjacencies is disrupted on the N-Series.
OSPF Neighbors stuck in Exchange Start / Exchange State.
Loss of routes in the forwarding table.

Cause
The Interface Maximum Transmission Unit (MTU) settings are mismatched on adjacent routers.

Background regarding X-Series design:
  • The X supports ethernet jumbo frames by default on all ports for layer 2 traffic; however, in order to maintain the larger packet size when routing between VLANs the MTU size should be maximized on the interface:
    mtu 9000
  • This command allows jumbo frames to pass unfragmented on layer 2 and layer 3, changing the actual MTU size and the L3 interface's capability to receive frames larger than 1500 bytes.
  • Packets originating from the X will always be sent with a 1500-byte packet size, at most.
Background regarding N-Series design:
  • The N supports standard ethernet with a 1500-byte MTU size. If it is necessary to send jumbo frames across the N, this must be enabled at the port level:
    set port jumbo enable <port#>
  • This command allows jumbo frames to pass unfragmented on layer 2 and layer 3 but does not change the actual MTU size or the L3 interface's capability to receive frames larger than 1500 bytes.
  • Packets originating from the N will always be sent with a 1500-byte packet size, at most.
If the above configuration changes are made in an OSPF environment, the X-Series and N-Series lose OSPF adjacency, resulting in loss of routes in the forwarding table.

This is because, as part of the OSPF process, neighboring routers exchange OSPF Database Descriptor information including their respective operational MTU sizes. In order to attain an OSPF adjacency with other routers, the MTU size reported by those other routers must not exceed the MTU size that the receiving router will accept. In this example, the X with an MTU setting of 9000 has no issue with the 1500 MTU size reported by the N. The N, on the other hand, sees the larger than acceptable MTU size reported by the X and drops back to an "Exchange Start" state.

Solution/Workaround
If the recycling router can be configured with a matching interface MTU, then that would be one possible solution; however, the N does not allow modification of the MTU size on the layer 3 interface.

In order to resolve this MTU mismatch, configure the N to ignore the MTU size reported in the Database Descriptor:
ip ospf ignore-mtu

What follows is a set of sample router configurations of an X-Series and N-Series, with this advice applied.

** X-Series **

interface vlan.1.152
ip address 10.26.152.1 255.255.255.252
mtu 9000
no shutdown

router ospf 1
network 10.26.152.0 0.0.0.3 area 0.0.0.0
network 10.26.255.200 0.0.0.3 area 0.0.0.0
exit

** N-Series **

interface vlan 152
ip address 10.26.152.2 255.255.255.252
ip ospf ignore-mtu
no shutdown

router ospf 1
network 10.26.152.0 0.0.0.3 area 0.0.0.0
redistribute connected subnets

set port jumbo enable ge.1.1[/code]

0 replies

Be the first to reply!

Reply