Header Only - DO NOT REMOVE - Extreme Networks

[SOLVED] V2110 issues after upgrade to

  • 3 March 2015
  • 4 replies

Userlevel 4
  • Extreme Hero
  • 125 replies
After upgrading V2110 form to some configurations got messed, requiring manual reconfiguration for proper operation

4 replies

Userlevel 7
What type of access points do you have on the controller, any 26xx series?

Userlevel 4
[edit] Sorry about pressing the "submit" button before completing the description =)

After upgrading V2110 from to some configurations got messed, requiring manual reconfiguration for proper operation.

In my lab I have V2110 (one WS-AP3620) and NAC running with no problems using

After upgrading to it stopped working as expected:

  • 802.1x/MAC authentication (NAC) not working
  • Device Down on NMS (showing the new version on Console and NAC Manager, but Contact Lost)
  • VNS with WPA-PSK not working
Doing some reviews I found that something gone wrong on upgrade...

Mar 03 11:11:33 IdentiFi-01 smt: Component [22][SNMP Agent] connected to Langley
Mar 03 11:11:33 IdentiFi-01 smt: Component [22][SNMP Agent] connected to Langley
Mar 03 11:11:43 IdentiFi-01 smt: Component [22][SNMP Agent] is down.
Mar 03 11:11:43 IdentiFi-01 smt: Restarting component: [SNMP Agent] cmd:snmpagent -D 1 &
Mar 03 11:11:43 IdentiFi-01 events: Startup Manager Component [SNMP Agent] is down. Component will be restarted. 1[/code]The SNMP Agent refused to start... Trying manually at IdentiFI shell (snmpagent -D 3) the process simply dies with the message "Floating point exception"...

Trying to start the process with logging enabled and debug level set to trace (snmpagent -l /var/logs/snmp.log -D 3) I got the same error, but now with some logging info:

@@@@@ Inside PrintOid() @@@@@ 18 128 0 16 233 4 49 50 51 52 53 54 55 56 57 48 49 50 50 8 115 110 109 112 117 115 101 114
@@@@@ Inside CreateAndAddSnmpUsmUserTableEntry() @@@@@
@@@@@ Inside GetProtocolType @@@@@
The security level is 3
@@@@@ Inside PasswordToLocalKey() @@@@@ [/code]It stops after this log message, with the good old "Floating point exception"...

I managed to look at the IdentiFI SNMP config (the same I've been using before upgrade), and oddly, looking at the Web Interface at SNMP credentials, instead of having my SNMPv3 Auth & Privacy Credentials, I got something like "[Object ...]" on both fields... SNMP Username and all other configs still there.

Reconfiguring my Auth & Priv SNMPv3 credentials and saving config made it work like a charm again! SNMP Agent UP and Running, and NAC Auth back online!

The WPA-PSK Wlan still not working... Looking at the Privacy tab of that WLAN Service, the PSK was replaced by many odd chars... Reconfiguring it again made it work again.

Maybe there's something wrong with the upgrade process (some script?). I'm sure the Engineering will take a look.

Now it's all UP and Running... Maybe this tip will be useful for our community.


Userlevel 7
Did you see any errors in the upgrade log in the controller GUI > Logs > S/W upgrade > Detail.

I always check that log after upgrading the controller to see whether the configutation was imported without an error.....
Userlevel 4
No errors reported... I've checked it already...

From To
Mar 03 10:31:47 BRT 2015 V2110 Upgrading From Release 8_32
Mar 03 10:33:08 BRT 2015 Successfully Restored the Internal Configuration
Mar 03 10:33:26 BRT 2015 Successfully Restored the Configuration
Mar 03 10:33:32 BRT 2015 Successfully Imported Special Configuration[/code]