Question

Pass vrf routes from Cisco to Brocade

  • 18 March 2019
  • 1 reply
  • 298 views

Hello,

I’m a Cisco guy with a Brocade router, and my ignorance is showing. I am trying to get vrf routes passed from my Cisco router to my Brocade router. While I feel like I’m incredibly close, I’m still missing the clue. Outputs are below, and please let me know if there is more info that would be useful. The routes appear on the Brocade via BGP, but do not show up in vrf routes. They just do not get put into the routing table. If you could please assist me in getting these routes to show up properly I would be forever grateful.

##########
SHOW VER…
##########
System: NetIron CER (Serial #: CKM2513M05S, Part #: 40-1000859-14)
License: RT_SCALE, ADV_SVCS_PREM (LID: emoHKGIoFKu)
Boot : Version 6.0.0T185 Copyright (c) 1996-2015 Brocade Communications Systems, Inc.
Compiled on Jun 7 2016 at 16:10:10 labeled as ceb06000
(465568 bytes) from boot flash
Monitor : Version 6.0.0T185 Copyright (c) 1996-2015 Brocade Communications Systems, Inc.
Compiled on Jun 7 2016 at 16:10:10 labeled as ceb06000
(465568 bytes) from code flash
IronWare : Version 6.1.0aT183 Copyright (c) 1996-2015 Brocade Communications Systems, Inc.
Compiled on Mar 23 2017 at 11:25:38 labeled as ce06100a
(18454569 bytes) from Primary
CPLD Version: 0x00000001
Micro-Controller Version: 0x0000000d
Extended route scalability
PBIF Version: 0x0161
800 MHz Power PC processor 8544 (version 8021/0023) 400 MHz bus
512 KB Boot Flash (MX29LV040C), 64 MB Code Flash (MT28F256J3)
2048 MB DRAM
System uptime is 5 days 5 hours 50 minutes 44 seconds

##########
All the routes that I want show up on the router via BGP, which is what makes my believe (hope) I am close…
##########

SSH@MY_ROUTER#show ip bgp vrf CUSTOMER
Total number of BGP Routes: 17
Status codes: s suppressed, d damped, h history, * valid, > best, i internal, S stale, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop RD MED LocPrf Weight Path
* 0.0.0.0/0 10.190.109.2 65200:4 100 0 65200 ?
* 10.12.12.0/30 10.190.109.2 65200:4 100 0 65200 ?
* 10.16.16.1/32 10.190.109.2 65200:4 100 0 65200 ?
* 10.16.16.2/32 10.190.109.2 65200:4 0 100 0 65200 ?
*> 10.16.16.11/32 0.0.0.0 0 100 32768 ?
* 10.16.16.32/30 10.190.109.2 65200:4 0 100 0 65200 ?
* 10.99.99.16/30 10.190.109.2 65200:4 100 0 65200 ?
* 10.99.99.24/30 10.190.109.2 65200:4 100 0 65200 ?
* 10.160.0.0/16 10.190.109.2 65200:4 0 100 0 65200 i
* 10.161.0.0/16 10.190.109.2 65200:4 0 100 0 65200 i
* 10.163.0.0/16 10.190.109.2 65001:4 100 0 65200 65001 ?
* 10.165.0.0/16 10.190.109.2 65200:4 100 0 65200 ?
* 10.166.0.0/16 10.190.109.2 65200:4 100 0 65200 i
* 10.199.189.0/30 10.190.109.2 65200:4 0 100 0 65200 ?
* 10.199.189.4/30 10.190.109.2 65001:4 100 0 65200 65001 ?
* 10.199.189.12/30 10.190.109.2 65200:4 0 100 0 65200 ?
* 172.18.30.0/24 10.190.109.2 65200:4 100 0 65200 ?

##########
They do not show up in vrf routes however…
##########

SSH@MY_ROUTER#show ip route vrf CUSTOMER
Total number of IP routes: 1
Type Codes - B:BGP D:Connected I:ISIS O:OSPF R:RIP S:Static; Cost - Dist/Metric
BGP Codes - i:iBGP e:eBGP
ISIS Codes - L1:Level-1 L2:Level-2
OSPF Codes - i:Inter Area 1:External Type 1 2:External Type 2 s:Sham Link
STATIC Codes - d:DHCPv6
Destination Gateway Port Cost Type Uptime src-vrf
1 10.16.16.11/32 DIRECT loopback 17 0/0 D 5d3h -

##########
CUSTOMER vrf configuration. Static routes are to local interfaces that won’t be live until I can cut over to this router, which is why they don’t show up in the vrf routes now. They do show up when the interfaces are active…
##########

vrf CUSTOMER
rd 65011:4
route-target export 65011:4
route-target import 65200:4
route-target import 65001:4
address-family ipv4
ip route 0.0.0.0/0 172.18.30.1 distance 201
ip route 10.99.99.24/30 10.99.99.17
ip route 10.165.0.0/16 10.12.12.2
ip route 10.166.0.0/16 10.99.99.17
bgp next-hop loopback 17
exit-address-family
exit-vrf

##########
BGP configuration…
##########

router bgp
local-as 65011
neighbor 10.190.109.2 remote-as 11123
neighbor 10.190.109.2 next-hop-self

address-family ipv4 unicast
redistribute connected
redistribute static
neighbor 10.190.109.2 allowas-in 5
exit-address-family

address-family ipv4 multicast
exit-address-family

address-family ipv6 unicast
exit-address-family

address-family ipv6 multicast
exit-address-family

address-family vpnv4 unicast
neighbor 10.190.109.2 activate
neighbor 10.190.109.2 allowas-in 5
neighbor 10.190.109.2 send-community both
exit-address-family

address-family vpnv6 unicast
exit-address-family


address-family ipv4 unicast vrf CUSTOMER
neighbor 10.190.109.2 remote-as 65200
neighbor 10.190.109.2 update-source loopback 17
redistribute connected
redistribute static
always-propagate
exit-address-family

##########
VLAN. S-tagged by provider…
##########
vlan 105 name LOCAL_TO_REMOTE
tagged ethe 2/2
router-interface ve 105

##########
VE interface linking to remote router. Connectivity between two locations works great, as evidenced also by the BGP routes…
##########
interface ve 105
port-name LOCAL_TO_REMOTE
ip address 10.190.109.1/30

##########
Loopback (Added in desperation… doesn’t seem to do a thing for me)…
##########

interface loopback 17
port-name CUSTOMER_MPLS_B
vrf forwarding CUSTOMER
ip address 10.16.16.11/32

1 reply

Userlevel 1
Hello Kevin,

Is this an MPLS L3VPN use case, or is it something else? I don't see any MPLS configuration for the CER but did see MPLS mentioned in the description for loopback17

Steve

Reply