Header Only - DO NOT REMOVE - Extreme Networks

Ridgeline 4.0 and CentOS

Userlevel 4
Create Date: Oct 22 2013 3:27PM

I know some people say that CentOS isn't Redhat Enterprise. Still though, there are claims that Ridgeline runs on CentOS.

I have a VM (vmwareESX) with CentOS 6.4, 64bit - minimal install with X Windows. Everything works until I import a device , then I get JBoss SEGV faults.
Tried CentOS 5.10, 64 bit, quite minimalistic with X Windows. Same thing.

4GB RAM, 6GB swap, 1 CPU (Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz)

Those of you who have CentOS running with Ridgeline 4.0 Patched twice (for PL2) - what's your CentOS version that you're running this successfully on?

I really don't want to run it on Windows, but will if I have to 😞


Frank (from Frank_M.)

2 replies

Userlevel 4
Create Date: Oct 28 2013 2:22PM

Hi Frank,

I didn't manage to get it working in CentOS5.10 either. I didn't try it on 6.x. I tried to install the 32 bit and 64 bit versions, with and without the 2 patches. My config is also on vSphere 5.1. Read all available material like 10 times by now 😞

As CentOS is 99.9% binary compatible I can't imagine this is a CentOS problem! I only use mainstream software but never had incompatibility issues. B

Here are my findings, don't know if it's simular with you?
Can anyone please comfirm Ridgeline 100% working with RHEL5 ? Is this 5.0 or did you update to ... -> 5.10 ?

* Check /opt/ExtremeNetworks/Ridgeline4.0/logs/Ridgeline4.0_InstallLog.log, and grep on ERROR. In my log file there's one ERROR - unable to locate ASCII text file to be manipulated. Deferring. I'm curious if you got the same error?

After rebooting and running Ridgeline, I also get lot's of warnings and a few errors in RidgelineServer40.log. Even before discovering devices!

Error 1
2013.10.28 13:31:02,824 ERROR [com.extremenetworks.epicenter.server.common.beans.impl.RequestRouterServiceBean] (EJB default - 1) Can't route the request | Request : ReportRequest | PARENT_REQUEST_ID : -1 | REQUEST_ID : 1 | Sender : java:global/epicenter/epicenter/ClientRequestExecutorManagerBean com.extremenetworks.epicenter.common.beans.interfaces.ClientRequestExecutorManager | StartTime : 10/28/2013 13:31:02Error 2
2013.10.28 13:31:24,916 ERROR [com.extremenetworks.epicenter.server.admin.beans.impl.properties.ServerPropertiesHelper]

(extremenetworksAdminManagerMDB_354) Property MacDatabasePollLoadFactor not present

Error 3
2013.10.28 13:31:24,916 ERROR [com.extremenetworks.epicenter.server.admin.beans.impl.AdminManagerBean](extremenetworksAdminManagerMDB_354) GetPropertiesRequest: properties: ConfigUpdater...Failed: com.extremenetworks.epicenter.server.common.exceptions.AdminServiceException: The property with the provided name is not present

Error 4
2013.10.28 14:10:31,550 ERROR [org.jboss.as.ejb3.invocation] (EJB default - 6) JBAS014134: EJB Invocation failed on component ClientSessionBean for method public abstract void com.extremenetworks.epicenter.common.beans.interfaces.ClientSessionInterface.logout(): javax.ejb.NoSuchEJBException: JBAS014300: Could not find EJB with id {[88, -91, -4, -90, 57, 7, 66, 118, -125, -92, -97, -79, 113, 114, 71, -107]}

Error 5
2013.10.28 14:10:32,171 ERROR [org.jboss.remoting.remote.connection] (Remoting "" read-1) JBREM000200: Remote connection failed: java.io.IOException: Connection reset by peer

Since the free version is unsupported, I suppose it's no use contacting Extreme for it?

(from bbibber)
Userlevel 4
Create Date: Nov 5 2013 2:25PM

I installed CentOS 5.10 from scratch / network install. Basically a minimal install plus X11.

Yes, I have that install error as well about the RidgelineServer.conf. Added the file manually after install (via " :>filename " to create an empty file )

I wonder if I should try creating that file and reinstall / install from scratch...

And yes, I see the same errors in RidgelineServer40.log

We actually paid for our version, but I'm a firm believer in "use forums before you open a ticket". Might have to start a ticketing process, though, but want to try a few more things. I still haven't given up hope that someone from Ridgeline/Extreme lurks in the forums 😉
(from Frank_M.)