BFD on LAG

  • 4 October 2016
  • 9 replies
  • 370 views

Hi Experts,
We are planning to implement BFD on LAG using X670 Switches and CISCO Nexus. I couldn't find any reference of Micro BFD sessions or BFD on LAG on XOS 15.X or 21.X. Do you now if it is supported?



BR
Rigoberto

9 replies

Userlevel 6
Hi Rigoberto, BFD is applied per vlan to an specific client like OSPF/MPLS/Static route.

You can configure BFD on a vlan even if the uplink is a LAG.
Hi,

I knew it can be configured , but as per rfc72130, BFD over a LAG has a specific operation (Micro-BFD Sessions). On other vendors I found this implementations supported on the documentation, but I could not find any reference on XOS docs. Do you know if there any document were I can find it?



BR
Rigo
Userlevel 6
Hi,

I knew it can be configured , but as per rfc72130, BFD over a LAG has a specific operation (Micro-BFD Sessions). On other vendors I found this implementations supported on the documentation, but I could not find any reference on XOS docs. Do you know if there any document were I can find it?



BR
Rigo

Hi,

Unfortunately I didn't find any information in the XOS docs.

I have configured that in a simple environment (OSPF point-to-point with BFD in a VLAN/LAG) and worked as expected.

Please see below some outputs:

LACP Sharing:



OSPF neighbor:



BFD session (3x 150ms):

Userlevel 2
Hi,

I knew it can be configured , but as per rfc72130, BFD over a LAG has a specific operation (Micro-BFD Sessions). On other vendors I found this implementations supported on the documentation, but I could not find any reference on XOS docs. Do you know if there any document were I can find it?



BR
Rigo

Hi Henrique,

In this case to enable BFD for OSPF is there anything else that I have to do or just enable BFD over the vlans were included on OSPF?

Thks
Userlevel 7
Hi,

I knew it can be configured , but as per rfc72130, BFD over a LAG has a specific operation (Micro-BFD Sessions). On other vendors I found this implementations supported on the documentation, but I could not find any reference on XOS docs. Do you know if there any document were I can find it?



BR
Rigo

All you need to do is enable BFD on the VLAN, then turn BFD on for the OSPF interface. See the commands below:
enable bfd vlan ospf_1 configure ospf vlan ospf_1 bfd on[/code]
Hi Henrique, I’ve seen same topology working between 2 routers (same vendor), but they use BFD Single session. It also works, but when there is another vendor on the other site, it must be running independent micro BFD sessions to monitor the status of individual member links. Have you tested this scenario with other vendor equipment?. Thanks in advance

BR
Rigo
Userlevel 6
Hi Henrique, I’ve seen same topology working between 2 routers (same vendor), but they use BFD Single session. It also works, but when there is another vendor on the other site, it must be running independent micro BFD sessions to monitor the status of individual member links. Have you tested this scenario with other vendor equipment?. Thanks in advance

BR
Rigo

Hi Rigoberto, I was not able to test this scenario with other vendor equipment.

However, I have just sent an email to our engineering team to confirm if we support "per-LAG-member-link BFD sessions (micro-BFD sessions)" based on RFC 7130.

I will let you know as soon as I get an update.
Userlevel 6
Hi Henrique, I’ve seen same topology working between 2 routers (same vendor), but they use BFD Single session. It also works, but when there is another vendor on the other site, it must be running independent micro BFD sessions to monitor the status of individual member links. Have you tested this scenario with other vendor equipment?. Thanks in advance

BR
Rigo

Hi Rigoberto,

I have just received a reply from our engineering team and currently we do not support this RFC in EXOS.
Userlevel 7
Hi,

Afaik we do no support rfc7130 (BFD on every single-link of a LAG). For interoperability with other vendor supporting it, you might need to turn it off on the other side. If the plan is to shut the LAG once a member fails, you can configure it on your LAG (minimum-active).

Reply