Cannot make iBGP peering over IPv6 across two Extreme X770 switches running 21.1.2.14


Hi Experts

I can't make an IPv6 iBGP peering up across Extreme switches, connected back to back. IPv4 peering is working fine. It appears Extreme has some recurring issues with IPv6 configuration.

I tried turning on and off BFD options, still it doesn't work. The BGP state is stuck in Active and there is no TCP connection coming up with ports (Remote Port/Local Port). Can anyone suggest if this is an OS bug or some other issue? BGP nei details below. Ping works fine across the switches.

Peer Description :
IBGP Peer : fe80::204:96ff:fe99:75b0 AS : 65139
Enabled : Yes OperStatus : Up
Weight : 1 Shutdown-Priority : 1024
ConnectRetry : 120 MinAsOrig : 5
HoldTimeCfg : 180 KeepaliveCfg : 60
Source Interface : Not configured RRClient : No
EBGP-Multihop : No Remove Private AS : No
BFD : Off BFD Status : Not Required
Capabilities Config : 4-Byte-As,route-refresh (old & new),ipv6-unicast
Policy for NLRI Type ipv4-unicast
In Policy : None
Out Policy : None
NextHopSelf : Disabled Send Communities : No
Soft Input Recfg : Disabled Allow Looped AS-Path: No
Policy for NLRI Type ipv4-multicast
In Policy : None
Out Policy : None
NextHopSelf : Disabled Send Communities : No
Soft Input Recfg : Disabled Allow Looped AS-Path: No
Policy for NLRI Type ipv6-unicast
In Policy : None
Out Policy : None
NextHopSelf : Disabled Send Communities : No
Soft Input Recfg : Disabled Allow Looped AS-Path: No
Policy for NLRI Type ipv6-multicast
In Policy : None
Out Policy : None
NextHopSelf : Disabled Send Communities : No
Soft Input Recfg : Disabled Allow Looped AS-Path: No
State : ACTIVE
FSM Down since : Thu Dec 1 01:56:32 2016
(Duration: 0:0:00:00)
Remote Addr : fe80::204:96ff:fe99:75b0 Local Addr : ::
Remote Port : 0 Local Port : 0
Remote RouterId : 0.0.0.0 Local RouterId : 10.174.61.90
HoldTimeNegotiated : 0 KeepAliveNegotiated : 0
FsmTransitions : 0
InUpdateElapsedTime : 00:00:12:32 InMsgElapsedTime : 0:0:12:32
InUpdates : 0 OutUpdates (in TxQ) : 0 (0)
InTotalMsgs : 0 OutTotalMsgs : 0
InRouteRefreshes : 0 OutRouteRefreshes : 0
Capabilities Tx : None
Capabilities Rx : None
NLRI for the session: None
Last State : CONNECT Last Event : TCP_CLOSED
LastError : 'None'

BGP Peer Statistics
Total Peers : 8
EBGP Peers : 2 IBGP Peers : 6
RR Client : 0 EBGP Multihop : 0
Enabled : 8 Disabled : 0

9 replies

Userlevel 2
Hi Sumanta Ghosh,

Can you please provide the Show configuration BGP output and , let me know whether are you able to ping the IPv6 peer ipaddress ?
Baskar wrote:

Hi Sumanta Ghosh,

Can you please provide the Show configuration BGP output and , let me know whether are you able to ping the IPv6 peer ipaddress ?

Is it due to using LLA for IPv6 having fe80:: range?
Baskar wrote:

Hi Sumanta Ghosh,

Can you please provide the Show configuration BGP output and , let me know whether are you able to ping the IPv6 peer ipaddress ?

Hi Baskar

I have updated the BGP configuration.
Hi Baskar

Please see attached.

Sumanta Ghosh wrote:

Hi Baskar

Please see attached.


Getting new error while enable/disable BGP nei.

"Configuration for family 0X41000002 and index 55 failed with rc 4"
Userlevel 2
Hi Sumanta Ghosh,

thank you for the response,

Please enable the IPv6 neighbor to work following are example command

en bgp neighbor 2001:db8:1::2 capability ipv6-unicast
Userlevel 2
Hi Sumanta,

By using the link local address, i am able to connect the BGP peer, please have a look and please share the full BGP configuration. so i can help on that

* X450G2-48t-10G4.17 # sh bgp neighbor
Peer AS Weight State InMsgs OutMsgs(InQ) Up/Down
-----------------------------------------------------------------------------------
Ie-- fe80::204:96ff:fe99:e089%vlan1 1 1 ESTABLISHED 2 2 (0 ) 0:0:00:02
Userlevel 2
Hi Sumanta,

I think I got the issue in your configuration you must specify the
link-local address in the following format , I have shared the sample Configuration below please have a look.

Sw2
===

configure bgp AS-number 1
configure bgp routerid 2.2.2.2
create bgp neighbor fe80::204:96ff:fe99:c8c2%vlan1 remote-AS-number 1
enable bgp neighbor fe80::204:96ff:fe99:c8c2%vlan1
disable bgp neighbor fe80::204:96ff:fe99:c8c2%vlan1 capability ipv4-unicast
disable bgp neighbor fe80::204:96ff:fe99:c8c2%vlan1 capability ipv4-multicast
enable bgp neighbor fe80::204:96ff:fe99:c8c2%vlan1 capability ipv6-unicast
enable bgp

Sw1:
===

configure bgp AS-number 1
configure bgp routerid 1.1.1.1
create bgp neighbor fe80::204:96ff:fe99:e089%vlan1 remote-AS-number 1
enable bgp neighbor fe80::204:96ff:fe99:e089%vlan1
disable bgp neighbor fe80::204:96ff:fe99:e089%vlan1 capability ipv4-unicast
disable bgp neighbor fe80::204:96ff:fe99:e089%vlan1 capability ipv4-multicast
enable bgp neighbor fe80::204:96ff:fe99:e089%vlan1 capability ipv6-unicast
enable bgp

By execute the command "show ipconfig ipv6 " you get the IPv6 prefix for the link-local address.

sh ipconfig ipv6

Route Sharing : Disabled
Route Compression : Enabled
ICMP Redirect for Fast Path : Disabled
Max Shared Gateways : Current: 4 Configured: 4
Route Sharing Hash : CRC Lower
Ping Protection : Enabled for static routes Interval: 2 Misses: 3

Interface IPv6 Prefix Flags

vlan1 fe80::204:96ff:fe99:e089%vlan1/64 -EUfP--R-

Flags : D - Duplicate address detected on VLAN, T - Tentative address
E - Interface enabled, U - Interface up, f - IPv6 forwarding enabled,
i - Accept received router advertisements enabled,
R - Send redirects enabled, r - Accept redirects enabled
P - Prefix address

sh bgp neighbor

Peer AS Weight State InMsgs OutMsgs(InQ) Up/Down
-----------------------------------------------------------------------------------
Ie-- fe80::204:96ff:fe99:c8c2%vlan1 1 1 ESTABLISHED 12 13 (0 ) 0:0:07:04

Flags: (d) disabled, (e) enabled, (E) external peer, (I) internal peer
(m) EBGP multihop, (r) route reflector client

please let me know if you have any question or concern
Userlevel 7
Since link-local addresses (LLA) are only valid on one specific link, the interface where to use an LLA needs to specified explicitly.
Hello All

Thanks for your responses. It got fixed by changing the interface IPv6 address to the below:-

"fc00::/127"

Reply