Header Only - DO NOT REMOVE - Extreme Networks

Extreme Summit X440 to Cisco Catalyst C2960X Spanning tree


Hi.
I need to add and connect a X440 stack to an on-production Cisco switch ring.
Somebody can help me to know the right spanning tree configuration for the X440 to be compatible with the existing Cisco spanning tree configuration?
This is the spanning tree an uplink interfaces config at the Cisco switches:

spanning-tree mode rapid-pvstspanning-tree loopguard default
spanning-tree portfast default
spanning-tree extend system-id
spanning-tree vlan 1-4094 priority 61440

interface GigabitEthernet1/0/25
switchport mode trunk
switchport nonegotiate
load-interval 30
storm-control broadcast level 30.00
end

interface GigabitEthernet1/0/26
switchport mode trunk
switchport nonegotiate
load-interval 30
storm-control broadcast level 30.00
end

Exos version: 15.3.1.4

Thanks!

8 replies

Userlevel 4
Hi Edgar,

Here is a sample EXOS configuration that should work with what you have on the Cisco Side:

#Extreme Configuration (EXOS)#
conf vlan default delete port 1,3
create vlan test
config vlan test tag 10
config vlan test add ports 1,3 tagged
disable edp port 1,3

create stpd domain_test
conf stpd "domain_test" add vlan "test" ports 1,3 pvst-plus
conf stpd "domain_test" tag 10
configure stpd "domain_test" mode dot1w
conf stpd "domain_test" default-encapsulation pvst-plus
conf stpd "domain_test" ports link-type point-to-point 1,3
enable stpd "domain_test"
Hi Dorian, and thanks for the reply.
Some questions:

1. The Extreme pvst-plus is compatible with the Cisco rapid-past?
2. About the sample, the what is the VLAN 10?
3. I must create a stpd domain for each VLAN y my network?

Bests
Userlevel 4
1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus
Dorian Perry wrote:

1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus

a) then if I have 25 vlans, I can use your example config and just add a line 'configure stpd "domain_test" add vlan' for each of the 25 vlans. Right?

b) The parameter refers to the uplink ports?
Userlevel 4
Dorian Perry wrote:

1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus

a) Yes that should work
b) Yes these would be the uplink/ring ports
Dorian Perry wrote:

1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus

Must I create the VLAN 10 (carrier VLAN) on all the CISCO Switches, or just in the CISCO Switches near to the X440 (Neighbors) ?
Userlevel 4
Dorian Perry wrote:

1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus

VLAN 10 does not need to be created at all. The carrier VLAN can be an existing VLAN of your choosing.
See GTAC Knowledge article: What is a STP Carrier vlan?
Dorian Perry wrote:

1.Yes the Extreme XOS configuration I provided is compatible with "spanning-tree mode rapid-pvstspanning-tree" on the Cisco side.

2. VLAN 10 in the example is the carrier VLAN for STPD "domain_test".

3. You should be able to add additional VLANs to same stpd using the command:
configure stpd "domain_test" add vlan ports pvst-plus

Must I specify the carrier VLAN at the Cisco configuration?

Reply