Extreme switch and Sonicwall Firewall

  • 13 May 2015
  • 9 replies
  • 316 views

Has anyone converted from Cisco to Extreme that had a Sonicwall Firewall? I am trying to figure out how to configure the port that our Sonicwall is connected to on the Extreme to allow max internet connections speeds. When we had the same Sonicwall connected to our Cisco switch we were getting 85-95Mbps in our Download speeds and now we are only getting 2-3 Mbps speeds. If port is set to auto negotiate, our internet is down. I currently have the port set to Auto off speed 100 duplex full. Anyone have some ideas?

9 replies

Userlevel 6
Hi Beth,
Extreme switch port by default do not restrict the traffic flow. Since the port speed is set to 100 Mbps, flow control could be in picture here. can you try the following command and check if that helps.

disable flow-control rx-pause ports
Userlevel 7
Hi Beth,

do you know the speed of the Sonicwall port? What state does the port on the extreme switch go into when you turn auto-negotiate on? What type of switch is this? Is this a stack?

Thanks,

Patrick
Hello Beth,

Try set speed manual on both devices, last week i saw one similar problem with Fortigate between mikrotik device. Check MTU interface and erros on both sides too...

Thanks,

Tavares
Userlevel 4
Hello Beth,

Could you copy paste the interface configuration and interface extensive output
from both the devices.

Regards,
Parthiban Chinnaya
Userlevel 1
Hi Beth,

What you are describing is usually caused by a mismatch in configuration between the two devices. Auto is a setting that must be used on both devices for it to work. This would be the preferred setting. You obviously know how to set it on the switch port, but you must also set it on the Sonicwall IF. If auto is not an available setting on the SonicWall, then you will need to set both sides manually. They must match. This includes speed, duplex and flow. If you have a tool such as NetSight, you can inspect the switch port for both sides capabilities and find the best match. If not, you will need to reference documentation for each device. If that is not available, try setting the switch to 100Mbps, Half duplex, No flow control. I suspect the duplex is currently the mismatched item causing the speed issue. If one side is Full and the other Half, the link will just crawl. Of course you will also need to confirm all the pieces and parts are good. A bad cable or interface can cause trouble as well.
Charlie...thanks for the reply. This is our Main Core switch which is a Stacked switch. The Sonicwall port is setup to 100Mbps duplex half, so I changed Port 1:1 on the stack to 100Mbps duplex half as well, but still a speed test is still only getting 4Mbps for downloads. Any other suggestions? Beth
Userlevel 7
Charlie...thanks for the reply. This is our Main Core switch which is a Stacked switch. The Sonicwall port is setup to 100Mbps duplex half, so I changed Port 1:1 on the stack to 100Mbps duplex half as well, but still a speed test is still only getting 4Mbps for downloads. Any other suggestions? BethHi Beth,
You should be using full duplex. Does the Sonicwall do 1G connections, or only 100M?

At full duplex at line rate 100 Mbps, the best you can expect to see is 12.5 MB/s. Half duplex effectively cuts that to 6.25 MB/s, minus any protocol overhead. That's probably why you're only able to get to ~4MB/s. 1MB/s = 8Mbps (bits vs. bytes).
Userlevel 2
Beth,

It was nice talking to you today. Please reference the GTAC article:

http://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-the-port-that-SonicWall-is...
Userlevel 2
Just to chime in here... I have a setup with a X450e connected to a Sonic NSA 220 running SonicOS 5.8.1.14-48o. I have the interfaces set to auto negotiate everything; speed and duplex... Both sides sync up at 1000/Full and appear error free and speed tests are acceptable. This same firewall was previously connected to a Cisco that was also set up as auto everything.

Reply