p2p OSPF convert to OSPF+(VRRP+MLAG)

  • 6 July 2015
  • 7 replies
  • 698 views

Ok we used to have a pretty simple setup
Site 1 -> OSPF p2p -> Core
Site 2 -> OSPF p2p
Site 3 -> OSPF p2p

That way we could redistribute our customers (/30) back to our Core so that the Core would be able to send traffic to the proper site, Worked Great.

Now our core is a MLAG of 2 switches, We spun up a VRRP on the vlan to the site betweent he mlag'd switches, set the default route on our Site switch to point at the VRRP and that works...

Put static routes for the /30's on both core switches in the mlag and customer traffic passes fine.

Now for the life of me i can't figure out what i'm doing wrong with the OSPF to get it working like it used to before, i can't use P2P because well it's 3 switches not 2.

All i want is for the remote sites to advertise their routes to both core switches.

I tried just leaving off the link-type point-to-point and the 3 switches appeared to get stuck in 2WAY and didn't receive/advertise anything.

The config i tried

Remote site had....
create ospf area 1.1.1.0
configure ospf area 1.1.1.0 stub summary stub-default-cost 10
configure ospf area 1.1.1.0 authentication simple-password Passwordy
configure ospf area 1.1.1.0 restart-helper both
configure ospf add vlan SITE1_BACKBONE area 1.1.1.0
configure ospf vlan SITE1_BACKBONE neighbor add 1.1.1.1
configure ospf vlan SITE1_BACKBONE neighbor add 1.1.1.2
configure ospf add vlan CUSTOMER1 area 1.1.1.0 link-type point-to-point passive

Core switch both had....
create ospf area 1.1.1.0
configure ospf area 1.1.1.0 stub summary stub-default-cost 10
configure ospf area 1.1.1.0 authentication simple-password Passwordy
configure ospf area 1.1.1.0 restart-helper both
configure ospf add vlan SITE1_BACKBONE area 1.1.1.0 link-type point-to-point
configure ospf vlan SITE1_BACKBONE neighbor add 1.1.1.3

7 replies

Userlevel 2
Have you tried restarting the osof process?
Userlevel 3
what licence do you have? you'll need a core licence to enable DR/BDR negotiation.
Userlevel 5
As Stephen said above, in your case you will HAVE to have a core license on at least one of your XOS switches in order for the DR to be elected otherwise your will just sit in waiting mode.
ah ok, luckily i had 2 core licenses waiting to be loaded on to those 2 very core switches, because we will have more than 4 active areas 🙂 I missed that it was required for DR election.

So basically stick to same config, just add the core licenses onto the Core1/2 first?
Userlevel 5
Yes, if your just apply the license "enable license " and it will turn on, no reboot required. If you need to get your license code to the specific hardware, take the voucher # with the SN# of the switch enter them on this web page.. http://tech.extremenetworks.com/services/license-generation.aspx

Let me know if you need anything else!
Ya i did that confirmed active core licenses now, and then readded the OSPF code above (minus the point-to-point) but still i'm only seeing the neighbors as 2way /DROTHER

EDIT: Nevermind, to others whoever run into this ... Make sure the priority on the core routers is set to >0 so they can be eligible to be DR/BDR 🙂
Userlevel 5
Sorry... did not look at the config above, you need to remove the area above as a stub and the neighbor configurations. Assuming you have area 1.1.1.0 just add the vlans. Clear your ospf on each vlan first and then add back without qualifications...

configure ospf del vlan

configure ospf add vlan area 1.1.1.0
enable ospf

If you are still having issues get them the full config... "show config ospf"

Reply