get 'destination host unreachable' with a simple connection (ethernet cable) between a PC and server

  • 30 December 2015
  • 6 replies
  • 3031 views

Doing a simple connection (ethernet cable) at home between a PC and server. I get 'destination host unreachable' - I have configured both Ethernet connections with static IP - both are on the same subnet. I have the sharkwire trace output of the ping, but can't make out what's wrong. I'm short on network understanding - (a DBA)

6 replies

Userlevel 4
Seems that the pinging device believes that it is not on the same subnet.
See Hub article "Troubleshooting IP Default Gateway issues".
Userlevel 3
Check the ARP Cache/Table in oith Endpoints and verify the used MAC addresses.
Paul, I put a router between the two servers, but I still get host unreachable. the 1st host has this for IPv4 Address. . . . . . . . . . . : 169.254.104.10
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 169.254.104.1
-- the 2nd host this -
IPv4 Address. . . . . . . . . . . : 169.254.104.198
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 169.254.104.1

Still get unreachable for 104.1 (gateway) , and for address. Still don't understand why
Userlevel 4
169.254.x.x is a "link-local" addressing scheme that can be acquired by devices unable to reach a DHCP server. Such a scheme is relatively useless in practical terms. (Read about it on the web.)

Since you say that you've statically set these devices, try using some other network such as 10.20.x.x.
Thanks for your help. Sorry but I'm still not 'getting' this. I have to two machines - a PC, and a server. The PC has a wireless adaptor already for internet, etc. I want to use a different Ethernet adaptor on a separate network, to connect directly with the Server (over Ethernet cable - no router between). What do I need to do to - ? I tried, as you said not using 169.254, instead setting static IP using 10.20.1.1 (PC) and 10.20.1.2(Server). It still does not work - Also, I'm not sure what to put for the gateway. I though assigning static IPs on the same subnet should work fine.. I really think I should train on this stuff, as it's not the first it's aggravated me to no end.. 😞
Userlevel 6
So your PC can get to the internet but not the server? Have you tried cutting the internet connection? It might be getting confused and trying to reach the server through the internet...

Reply