Header Only - DO NOT REMOVE - Extreme Networks

In Priority Flow Control, Pause for Priority greater than 3 Pauses everything just like normal ethernet frame control Pause


Userlevel 1
In Priority Flow Control, Pause for Priority greater than 3 Pauses everything just like normal ethernet frame control Pause. I want that lets say pause for priority 4 pauses only priorty 4 traffic but currently it pauses everything.

14 replies

Userlevel 6
What switch and version? By default Priority 0-6 are mapped to QP1. PFC uses the same mapping that dot1p uses.
Userlevel 1
I am using 670v and currently i have 0 mapped to qp1 , 1 mapped to qp2 and so on..
Userlevel 6
That's good. What version of EXOS are you running?
Userlevel 1
* X670V-48x.51 # show versionSwitch : 800399-00-12 Rev 12.0 BootROM: 2.0.2.1 IMG: 15.3.1.4
PSU-1 : Internal PSU-1 800462-00-04
PSU-2 : Internal PSU-2 800462-00-04

Image : ExtremeXOS version 15.3.1.4 v1531b4-patch1-36 by release-manager
on Thu May 1 18:09:10 EDT 2014
BootROM : 2.0.2.1
Diagnostics : 5.10
* X670V-48x.52 #
Userlevel 6
Danial,

Because PFC 0-2 works I would say that it's a bug with the limited information collected. I would upgrade to the Engineering recommended code "16.1.3.6-patch1-9" because 15.3 is no longer supported.
Userlevel 1
@stephen, that makes sense. can u help me in how to upgrade it to the new patch? i mean from where do i get it?
Userlevel 6
Take a look at the below article. Let us know if you have any questions.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Obtain-and-Upgrade-EXOS
Userlevel 1
Secondly whenever i changing the mapping using configure dot1p type command .. which ever priority i give to qp4,qp5,qp6 the same problem is there.. i mean for example if i assign priority 1 to qp4 then if i intend to pause priority 1 the priorities assigned to qp5, qp6 regardless of their value are also paused. so its not the priority i think its the QOS profile that has a bug. because any priority value assigned to QP4,qp5, qp6, shows the same problem.. what do u think?
Userlevel 1
Could there be any other reason apart from old patch?
Userlevel 1
I updated the Firmware but the issue still persists? any help please?
Userlevel 6
Danial Jalil wrote:

I updated the Firmware but the issue still persists? any help please?

Hi Danial, what EXOS version you are using now?

Did you already opened a GTAC case?

When using PFC with priority >=4 , you say that the every queue is paused. Did you perform a packet capture to confirm that the switch is sending the PFC packets with wrong PFC priority values?
Userlevel 1
guyss ?????
Userlevel 1
Waiting for your help guys?
Userlevel 6
Danial,

If your in need of a faster response I would recommend opening a TAC case. Saying that this issue looks like a bug i would open also open a case.

Reply