What is port congestion?


what is Congestion Port ? what is the normal value of per port?

15 replies

Userlevel 6
If you are referring to the "show port congestion" output it is referring to packet drops on the device. This command is used as a troubleshooting tool and accumulates over the up time of the device. If the counters increment on a port then there is typically some type of issue and would have to be investigate per incident using other tools on the device. If you run the command and the counters do not increment then it is impossible to find out why or when there were drops.
Userlevel 6
Remember this is ethernet ... The way we use this command is looking for micro-bursts of max interface traffic that overruns an single interface thus creating congestion and packet drops... in the perfect world all ports should be ZERO.... any port that has counters going up on it is dropping frames and being over run ....

i have this value in my switch? how i can fixing that.
Userlevel 6
Hi Munir,

Are they increasing? If not you can clear them and monitor moving forward. As EtherMAN mentioned you ideally want the packet drops to be at zero but sometimes these counters will increase overtime and typically not an amount that is detrimental to the network. They almost always increase because of over utilizing bandwidth on a port. Hitting the "0" (Zero) key while the output is present will clear all the counters.

Hope this helps.
thank you for your response. but what did you mean hitting 0? that's mean click on zero on my PC, or what ?
Userlevel 6
Yes, hitting the "0" (Zero) key while the output is being displayed will clear the counters. You can also run the command "clear counters".
Patrick Voss wrote:

Yes, hitting the "0" (Zero) key while the output is being displayed will clear the counters. You can also run the command "clear counters".



i did this task to hitting 0 , but i got about this result, this is normal or not ? thank you
Userlevel 4
Munir,

The congestion output looks to be very close as far as the amount of dropped packets on those ports. This would indicated that you may have some type of flooding occurring such as broadcast or unicast.

As Patrick mentioned, I would clear out these counters and start from zero. Keep an eye on them and if they are increasing at a similar rate, mirror one of the ports ingress and egress to see what the majority of traffic is. Broadcast traffic will of course flood to every port in the vlan but unicast traffic should only be sourced or destined from the device on that port (you should not see unicast traffic egress that port with a destination mac other that the mac that shows in show fdb port <#> output.

Cheers!
Userlevel 5
By chance do you have Aruba in the network and do you have Jumbo-Frames turned on? If so I have run across this in these deployments and if you enable jumbo-frames on all of the switches the congestion counters will clear.
Bill Stritzinger wrote:

By chance do you have Aruba in the network and do you have Jumbo-Frames turned on? If so I have run across this in these deployments and if you enable jumbo-frames on all of the switches the congestion counters will clear.

thank for your response.... the Jumbo-Frame turned off in all switches network? what is a value of Jumbo-Frame recommend in per switch? what is Aruba?
Userlevel 5
Bill Stritzinger wrote:

By chance do you have Aruba in the network and do you have Jumbo-Frames turned on? If so I have run across this in these deployments and if you enable jumbo-frames on all of the switches the congestion counters will clear.

I have seen certain devices that work better with jumbo-frames enabled - check out the documentation here it can explain it:http://documentation.extremenetworks.com/exos/EXOS_All/Slots_and_Ports/c_jumbo-frames.shtml

Aruba is a wireless manufacturer.

I would enable jumbo-frames, clear counters and see if it makes any difference.
Bill Stritzinger wrote:

By chance do you have Aruba in the network and do you have Jumbo-Frames turned on? If so I have run across this in these deployments and if you enable jumbo-frames on all of the switches the congestion counters will clear.

thank for your response , but which the framesize range it's better for switch it has from 1523 to 9216?
Userlevel 5
Bill Stritzinger wrote:

By chance do you have Aruba in the network and do you have Jumbo-Frames turned on? If so I have run across this in these deployments and if you enable jumbo-frames on all of the switches the congestion counters will clear.

When I configure them I leave them on the default setting which is 9216 and I enable it across the network.
Userlevel 5
Hi,

Add "Port Congestion" on the hub for the reference.
https://community.extremenetworks.com/extreme/topics/port-congestion

Best regards,
Bin

Reply