Header Only - DO NOT REMOVE - Extreme Networks
Solved

ntp shows wrong time on XMC and NAC-Gateway

  • 13 August 2019
  • 4 replies
  • 426 views

Userlevel 2
Hello,
we are using XMC and NAC version 8.2.6.5 at VMWare and from time to time I see that the time is wrong (2h in the future).
If I check the output of "systemctl status ntp.service" I see that the service ist exited:
root@xmc.test.net:~$ systemctl status ntp.service
● ntp.service - LSB: Start NTP daemon
Loaded: loaded (/etc/init.d/ntp; bad; vendor preset: enabled)
Active: active (exited) since Thu 2019-08-08 20:20:27 CEST; 4 days ago
Docs: man:systemd-sysv-generator(8)
Process: 9344 ExecStop=/etc/init.d/ntp stop (code=exited, status=0/SUCCESS)
Process: 9423 ExecStart=/etc/init.d/ntp start (code=exited, status=0/SUCCESS)

And the ntpd is not running (checked with "ps aux | grep ntpd"):

If I restart the ntpd with "systemctl stop ntp.service" and "systemctl start ntp.service" everything is fine for the next fre days.

If I check the /var/log/syslog I found:
<6>Aug 12 18:17:01 xmc(127.0.0.1) CRON[23925]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
<6>Aug 12 20:17:56 xmc(127.0.0.1) systemd[27215]: Time has been changed
<6>Aug 12 20:17:56 xmc(127.0.0.1) systemd[1]: Time has been changed
<6>Aug 12 20:17:57 xmc(127.0.0.1) CRON[23955]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

So I know the time has changed from 18:17:01 to 20:17:56 but I didn't know why.

Has anybody an idea how to find out the reason for this?

I have a second NAC Gateway running on a KVM Hypervisor and there I didn't saw any time problems.

Regards,
Axel
icon

Best answer by Zdenek Pala 28 August 2019, 08:17

My experience is that vmware can be configured to periodically modify time on the virtual machine through vm-tools.

if you stop vm-tools you loose some important features...
View original

4 replies

Userlevel 7
I suggest you check the time and timezone on your VMware hypervisor. You can also disable the time update done by VMware tools.
Userlevel 2
Hi Zdenek,
I have checked time and timezone settings many times.
I have found out that the problem has something to to with the open-vmware-tools because since I have stoped them (systemctl stop open-vm-tools.service) the time is correct.
I will check again the log files.Maybe something was going wrong at the last XMC update.

I didn't know enough about VMware but I thought if I use ntp on the virtual machine then the time setting on the hypervisor is not necessary. Or get the virtual server the time information from the hypervisor, too?
Thanks for your answer.
Axel
Userlevel 7
My experience is that vmware can be configured to periodically modify time on the virtual machine through vm-tools.

if you stop vm-tools you loose some important features...
Userlevel 7

Reply