Header Only - DO NOT REMOVE - Extreme Networks

CAPTIVE PORTAL HTTPS


Userlevel 2
I have a problem with captive portal when the customer home page have https. If the initiall client page is https then captive portal don´t open, if page http works good. Anybody have an idea how i resolve this problem.

8 replies

Userlevel 7
This is functioning as designed. The HTTP redirect is done on HTTP requests not HTTPS. Regards, Doug Hyde Sr Support Engineer Extreme Networks
Userlevel 2
Do you have any prevision about this feature with https on captive portal or not have future implementation of this
Userlevel 7
I will check with our Product Management Team to see but at this time I have not seen it on our product roadmap. Regards, Doug Hyde Sr Support Engineer Extreme Networks
Userlevel 4
This feature enhancement is our roadmap and will be delivered in 2014.
Userlevel 2
Aguilar, William wrote:

This feature enhancement is our roadmap and will be delivered in 2014.

Today the google or facebook have the initial page on HTTPS and the customers have this sites with initial page. Have any idea to work with https or its necessary wait for correction on controllers?
Userlevel 7
Aguilar, William wrote:

This feature enhancement is our roadmap and will be delivered in 2014.

You would have to wait for the code changes on the controller. -Doug
If I'm understanding the question correctly, in our deployments of NAC we mark the HTTPS traffic and add a PBR for Https on the router to also redirect https traffic, we do this to cover the bases for both http and https. The access list would look something like this: permit tcp any any eq 80 dscp cs2 permit tcp any any eq 443 dscp cs2
Userlevel 2
If I'm understanding the question correctly, in our deployments of NAC we mark the HTTPS traffic and add a PBR for Https on the router to also redirect https traffic, we do this to cover the bases for both http and https. The access list would look something like this: permit tcp any any eq 80 dscp cs2 permit tcp any any eq 443 dscp cs2

Reply