V2110 in vmware workstation

  • 27 November 2014
  • 6 replies
  • 488 views

Userlevel 1
Can V2110 work in vmware workstation? If yes, can you please share any config resources?

6 replies

Userlevel 6
Karthik,

I have a V2110 installed in my Macbook Pro (i7, 16 BG RAM) using Fusion, so I guess it is possible to run it in Workstation. I haven't done much testing, other than connecting an AP and letting the controller discover and adopt it.

Remember this is NOT a supported configuration, and it is not meant to be used in production. But if you want to practice or do a quick lab, it will probably work.
Userlevel 1
Thanks Daniel, If its working in Fusion pro it should also working in Vmware player. I have tried with player, but I have had hard time connecting esa0 and esa1 ports with existing network. Do you have any vmware networking config resources to get data ports up?

I am having a esxi installation already working. But vmware workstation/player is for demo purposes only.
Userlevel 6
I haven't done anything special to connect the controller to networks.

The management port (network adapter in Settings) is connected to a Host-Only networking adapter (sorry, my Fusion is in Spanish...)



The esa0 port (network adapter 2 in Settings) is connected to a bridged network using one of the available Etehrrnet adapters



Here's the topology used

Userlevel 1
For some reason I am not able to connect v2110's esa0. But in the same config I was able to use C25. Must be some kind of vmware player config issue. Can you Pl post your switch config.

Userlevel 6
Karthik,

Here's the snapshots of the configuration for Workstation:

Management adapter (edit VMnet1 subnet accordingly):



Esa0 adapter:



Esa1 adapter:



If you have several active ethernet adapters in your PC and want to specify one, configure esa0 to use VMnet0 and edit VMnet0 to use the connection you want:

Userlevel 1
Hi Daniel,

Sorry for Late reply.
It worked. Thanks for the help. But I hope there are some bug. If I run installation wizard, esa ports are not working. But if I do CLI based topology config and avoid initial installation wizard, its working.

Reply