Header Only - DO NOT REMOVE - Extreme Networks

Openflow meters not working on X440

  • 21 July 2016
  • 3 replies

We have a deployment of extreme switches on-site and I am trying to test the Openflow capabilities of the switch with a demo setup I have in the lab.
One of the features we are looking to use is the Openflow meters (supported since 16.1.1) to apply rate limit to flows. I am currently on version patch1-8
The issue I am facing is that I cannot add a new meter (tested with different meter_ids) and the switch returns an OFPT_ERROR with code OFPMMFC_OUT_OF_METERS.
Any idea what might be wrong?


3 replies

Userlevel 7
Hello Koubee,

Would it be possible to send your openflow configuration along with the model and the output showing this error?
Hi Patrick,

Thanks for the reply. Here is the switch configuration:

440-lab01.8 # show switch
SysName: X440-lab01
SysContact: support@extremenetworks.com, +1 888 257 3000
System MAC: 00:04:96:99:36:70
System Type: X440-48p
SysHealth check: Enabled (Normal)
Recovery Mode: All
System Watchdog: Enabled
Current Time: Tue Aug 9 08:57:33 2016
Timezone: [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time: Mon Aug 1 09:49:27 2016
Boot Count: 13
Next Reboot: None scheduled
System UpTime: 7 days 23 hours 8 minutes 6 seconds
Press to continue or to quit: [60;D
Current State: OPERATIONAL
Image Selected: primary
Image Booted: primary
Primary ver:
Secondary ver:
Config Selected: primary.cfg
Config Booted: primary.cfg
primary.cfg Created by ExtremeXOS version
272916 bytes saved on Tue Aug 9 08:46:17 2016[/code]
and the oppenflow vlan:

X440-lab01.6 # show openflow "of_test01" OpenFlow: Enabled
Versions: OpenFlow10, OpenFlow13
Mode: Standard
Access-list width: Double
Controller : Primary
Datapath ID : 0000000496993670
VR : VR-Default
Mode : out-of-band Active
Target : tcp:
Uptime(secs) : 0
Controller : Secondary
Not configured.
VLAN VID Mode Ports Active Error
-------------------------------- ---- -------- ----- ------ ------
of_test01 4089 Standard 4 0 0
Total number of VLAN(s): 1[/code]
I am testing the switch features with RYU openflow controller. So as described in the previous message the Openflow agent at the switch fails to create a meter_id for specified openflow port. The switch does not print anything at CLI, so the error messages I am describing comes from Openflow (captured with Wireshark).
Userlevel 4
Hello Koubie,

I can see you are trying to create meter function via EXOS cli for open flow. You are running with Exos 16.1.1 and as per user guide it is allowed. But let me tell you it has been wrongly added there and the concerned SDN Team is looking into this for removing this notice from there.

For more information please refer to the below article:


So in a nut shell creation of meter for open flow session not supported.

Please let me know if you have any further queries.