Adding a new node to stack failed - no neighbor


Hi,
im trying to add a new x440p to an existing x440p stack of 2 devices.
Unfortunaly the stack doesnt see the new member in his list of show stacking.

i have already tried mayn times the steps in the concept guide and enabled switching, set slot number and license level. I have also checked that the same image from the same slot will be loaded.Stacking leds are all green.

But the new device doesnt come up in the stack.



on the new device

* Slot-1 Stack.2 # sh stacki
Stack Topology is a Daisy-Chain
Active Topology is a Daisy-Chain
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:97:be:09 1 Active Master CA-



On the existing stack

Slot-1 Stack.20 > sh stacking
Stack Topology is a Daisy-Chain
Active Topology is a Daisy-Chain
Node MAC Address Slot Stack State Role Flags
------------------ ---- ----------- ------- ---
*00:04:96:97:bf:30 1 Active Backup CA-
00:04:96:97:be:0a 2 Active Master CA-



Slot-1 Stack.3 > sh stacki stack
Stack Topology is a Daisy-Chain
Slot Port Select Node MAC Address Port State Flags Speed
---- ---- ------ ----------------- ----------- ----- -----
*1 1 Native 00:04:96:97:bf:30 No Neighbor -- 10G
*1 2 Native 00:04:96:97:bf:30 Operational C- 10G
2 1 Native 00:04:96:97:be:0a Operational C- 10G
2 2 Native 00:04:96:97:be:0a No Neighbor -- 10G

18 replies

i too have similar issue facing if we enable stacking in the new switch then it will be visible in the existing stack summary
Userlevel 6
Did you try following this method ?
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-add-a-node-to-a-stack

If that does not work, check the logs on each slot as it might tell you why it is not working.
yes, but this doesnt work, because the new member ist shown in the stacking list
yes, but this doesnt work, because the new member ist shown in the stacking list

run cmd enable stacking with node address then reboot and try
yes, but this doesnt work, because the new member ist shown in the stacking list

this doesnt work when the MAC of the member isnt listed in show stacking
thats what i have already done many times. unconf stack and unconf switch and tryied it again with enable stacking. but it isnt shown in the list of the stack.
Userlevel 6
Hi Denu,

I am suspecting the issue might be related to the stacking protocols as you are not able to see the new switch when connected to the existing stack. Please check the following output.

show stacking detail

in both the existing stack and the new switch.
Check the stacking protocol under this output and make sure that the stacking protocol in the new switch is same as the existing stack.

command to configure the stacking protocol is,

configure stacking protocol .

Hope this helps!
hi all,

i get this error

Error: the target slot's partitions are not compatible with the Master's for synchronize.

Stack Topology is a RingSlot Port Select Node MAC Address Port State Flags Speed
---- ---- ------ ----------------- ----------- ----- -----
*1 1 Native 00:04:96:99:25:3d Operational C- 10G
*1 2 Native 00:04:96:99:25:3d Operational C- 10G
3 1 Native 00:04:96:98:ff:4e Operational C- 10G
3 2 Native 00:04:96:98:ff:4e Operational CB 10G
2 1 Native 00:04:96:82:43:b5 Operational CB 10G
2 2 Native 00:04:96:82:43:b5 Operational C- 10G
* - Indicates this node
Flags: (C) Control path is active, (B) Port is Blocked

Stacking Node 00:04:96:82:43:b5 information:
Current:
Stacking : Enabled
Role : Standby
Priority : Automatic
Slot number : 2
Stack state : Active
Master capable? : Yes
Stacking protocol : Enhanced
License level restriction :
In active topology? : Yes
Factory MAC address : 00:04:96:82:43:b5
Stack MAC address :
Alternate IP address :
Alternate gateway :
Stack Port 1:
State : Operational
Blocked? : Yes
Control path active? : Yes
Stack Port 2:
State : Operational
Blocked? : No
Control path active? : Yes
Configured:
Stacking : Enabled
Master capable? : Yes

how do i make this as allowed and get it worked
Userlevel 6
What does show stacking stack-ports show on the new node ?
What does show log say from the new node.
Userlevel 6
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-change-the-stacking-protocol/

The above article should help you with the protocol configuration change.
Userlevel 6
hi all,

i get this error

Error: the target slot's partitions are not compatible with the Master's for synchronize.

Stack Topology is a RingSlot Port Select Node MAC Address Port State Flags Speed
---- ---- ------ ----------------- ----------- ----- -----
*1 1 Native 00:04:96:99:25:3d Operational C- 10G
*1 2 Native 00:04:96:99:25:3d Operational C- 10G
3 1 Native 00:04:96:98:ff:4e Operational C- 10G
3 2 Native 00:04:96:98:ff:4e Operational CB 10G
2 1 Native 00:04:96:82:43:b5 Operational CB 10G
2 2 Native 00:04:96:82:43:b5 Operational C- 10G
* - Indicates this node
Flags: (C) Control path is active, (B) Port is Blocked

Stacking Node 00:04:96:82:43:b5 information:
Current:
Stacking : Enabled
Role : Standby
Priority : Automatic
Slot number : 2
Stack state : Active
Master capable? : Yes
Stacking protocol : Enhanced
License level restriction :
In active topology? : Yes
Factory MAC address : 00:04:96:82:43:b5
Stack MAC address :
Alternate IP address :
Alternate gateway :
Stack Port 1:
State : Operational
Blocked? : Yes
Control path active? : Yes
Stack Port 2:
State : Operational
Blocked? : No
Control path active? : Yes
Configured:
Stacking : Enabled
Master capable? : Yes

how do i make this as allowed and get it worked
Hi Nagaraj,

The error is seen because the EXOS images are installed in different partitions of master and the node which you are trying to synchronise. (For example, master booted with primary partition and the new switch booted with secondary partition). During the sync, the XOS image will also be synchronised with the target switch. So, it is necessary that the partitions are same.

To overcome this situation, please try to download and install the same image to the new switch in the partition same as the master's.

Command:
download image [i] [i]
thanks, after setting any node to standard it finally works
hi all

from sujit parab to All Participants:The stack MAC is either not configured or its configuration is not
consistent within the stack. The stack can not operate properly in this
condition. Please correct and reboot.

what would be the issue

please hep
Userlevel 7
You need to run the command "configure stack mac" and then reboot the entire stack. This should remove that message. "synchronize stacking" should also work as well.
Userlevel 6
Hope this article helps!

https://gtacknowledge.extremenetworks.com/articles/Solution/The-stack-MAC-is-either-not-configured-or-its-configuration-is-not-consistent-within-the-stack-The-stack-cannot-operate-properly-in-this-condition-Please-correct-and-reboot/?q=stack+mac+not+configured&l=en_US&fs=Search&pn=1
Userlevel 7
The article Oscar posted earlier provides preliminary checks that should be looked at on the switch you are adding.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-add-a-node-to-a-stack

Before adding a node to the stack the primary and secondary image should match. The running partition should match the stack. The stacking protocol needs to match. If the new node is master-capable the license needs to match as well.

If all this is checked before adding or even replacing a node then the process will be a whole lot easier.
Userlevel 7
Hi,

Prashanth gave the most likely reason for this "issue".
This is the very typical problem people may face when adding a new node into an existing stack.

When you setup a stack with "easy stacking", the stacking protocol is set to "enhanced". If you add a new member, it will not be with the same protocol and thus you won't be able to add it.

Following Oscar's link is the best way to have no problem when dealing with stacking.

Reply