debug packet capture not working

  • 11 September 2017
  • 3 replies
  • 575 views

Userlevel 5
Hi,

Just trying to run a debug packet capture on the following:

Stack of 4 x X450G2-48P-10G4, running version 22.2.1.5-patch1-4

As per the following GTAC articles:

https://gtacknowledge.extremenetworks.com/articles/How_To/Perform-a-packet-capture-in-the-EXOS-CLI-u... (This article is slightly wrong in that I had to use 'ports' not 'port' as shown.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-perform-a-local-packet-capture-on-a...

Have tried the following commands:

debug packet capture ports 1:21 on vlan B20_23-L-GND-Voice cmd-args "-c 1000"
debug packet capture ports 1:21 on count 1000

These both take OK but the only file produced in the /usr/local/tmp is a file called capture.log

When I look at that file capture.log it contains the following:

tcpdump: can't add port 10015 on packet socket: Protocol not available

Maybe there is some restriction, perhaps on a stack, model or version that is causing that issue that I've missed?

Appreciate any help in advance.

Many thanks

3 replies

Userlevel 3
Hi Martin,

This appears to be related to the "CR xos0066839 : When debug packet capture is enabled for a port, pcap file is not created in internal-memory". This CR has been fixed in EXOS 22.3.1.4.
Please let us know if you have any other questions.
Thank you.

Best regards,
Andrew
Userlevel 5
Hi Martin,

This appears to be related to the "CR xos0066839 : When debug packet capture is enabled for a port, pcap file is not created in internal-memory". This CR has been fixed in EXOS 22.3.1.4.
Please let us know if you have any other questions.
Thank you.

Best regards,
Andrew

Thanks Andrew - that sorted it.
Userlevel 5
Hi,
There is one article to explain this CR#.
https://gtacknowledge.extremenetworks.com/articles/Solution/Enabling-Debug-Packet-Capture-on-a-port-...

Reply