Header Only - DO NOT REMOVE - Extreme Networks

How can I correct a stack mac address


We have a stack of 1 x460 and 3 x440s running summitX-15.5.3.4-patch1-2.xos

Over the weekend the building they are in lost power and apparently power was restored 1 phase at a time.

Slot 4 has rebooted several additional times with the reason (no master) and the stack mac address on slot 4 is not correctly configured.

Slot-1 MCEC_MDF.2 # sho stacking configuration Stack MAC in use: 02:04:96:99:2c:1c
Node Slot Alternate Alternate
MAC Address Cfg Cur Prio Mgmt IP / Mask Gateway Flags Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:99:2c:1c 1 1 Auto CcEeMm-Nn --
00:04:96:98:ab:18 2 2 Auto --EeMm-Nn --
00:04:96:98:aa:e0 3 3 Auto --EeMm-Nn --
00:04:96:98:ab:38 4 4 Auto --Ee--iNn --
* - Indicates this node

I have not tried on this switch yet, but have tried to configure the stack mac on switches on other stacks and never had any luck. In the past I have always had to unconfigure switch all, run easy stacking and reload the config.

Any thoughts,

5 replies

Userlevel 6
Hi David,

The stack mac can be resolved with the "configure stacking mac" from the master. A reboot is required after this command is implemented. The "synchronize stacking" command may been needed as well.

As far as the slot rebooting that is a mystery. I do notice that the stack only has one master capable node. This means if slot 1 dies the entire stack dies. Was this intended?
Patrick,

Thanks for the suggestion, that is the command I used in the past without success I will try that on this stack and see if I have better luck. This switch is in the same district I am going to be replacing switches at this afternoon and will look into this issue more at that time.

Also thank you for pointing out the lack of a backup. That is very odd because I know these were stacking using the easy stacking command. It is sort of irrelevant because if the 460 goes down there will be no uplinks anyway. But I will enable master capability on slot 2 this afternoon just to keep things consistent.
Userlevel 6
This may have something to do with the licensing on each slot. Make sure the slots you are enabling master-capability on are using the same license level.
Patrick,

I have tried the following.
configure stacking mac-add slot 4
synce stacking node address
Reboot.

and

sync stacking node-address 00:04:96:8b:b3:c4 y

configure stacking node-address 00:04:96:8b:b3:c4 slot 3
enable stacking node-address 00:04:96:8b:b3:c4
reboot node-address 00:04:96:8b:b3:c4
y

neither worked

Slot-1 MCEC_MDF.17 # sho stacking configuration Stack MAC in use: 02:04:96:99:2c:1c
Node Slot Alternate Alternate
MAC Address Cfg Cur Prio Mgmt IP / Mask Gateway Flags Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:99:2c:1c 1 1 Auto CcEeM-iNn --
00:04:96:98:ab:18 2 2 Auto --EeM-iNn --
00:04:96:98:aa:e0 3 3 Auto --EeM-iNn --
00:04:96:98:ab:38 4 4 Auto --Ee--iNn --
* - Indicates this node
David Coglianese wrote:

Patrick,

I have tried the following.
configure stacking mac-add slot 4
synce stacking node address
Reboot.

and

sync stacking node-address 00:04:96:8b:b3:c4 y

configure stacking node-address 00:04:96:8b:b3:c4 slot 3
enable stacking node-address 00:04:96:8b:b3:c4
reboot node-address 00:04:96:8b:b3:c4
y

neither worked

Slot-1 MCEC_MDF.17 # sho stacking configuration Stack MAC in use: 02:04:96:99:2c:1c
Node Slot Alternate Alternate
MAC Address Cfg Cur Prio Mgmt IP / Mask Gateway Flags Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:99:2c:1c 1 1 Auto CcEeM-iNn --
00:04:96:98:ab:18 2 2 Auto --EeM-iNn --
00:04:96:98:aa:e0 3 3 Auto --EeM-iNn --
00:04:96:98:ab:38 4 4 Auto --Ee--iNn --
* - Indicates this node

Just wanted to let the group know. I ended up calling tech and after none of the show stack-port commands worked from slot 4 the tech rebooted the entire stack and that resolved the issue.

Thanks

Reply