How to uninstall SSH xmod


  • New Member
  • 25 replies
So I have been trying to install the SSH xmod to our 460G2 stack. XOS ver is 15.6.2.12patch1-6
I downloaded the SSH xmod for this version then ran the download image command on the server. It downloaded the xmod to primary image for the slots in the stack except for the stack master then when I do the run update it returned errors: slot 3 failed to install image - already exists. it gave that error for slots 2, 3, and 4. no error for slot-1 (the stack master) all switches are running on the same primary version. Slot 1 is a 460G2 the other slots are a 440. when I check the processes it shows exsshd running on slot 2. I trying to figure out how to uninstall the ssh xmod from the images and in particular slot 2 without having to take down or reboot the stack. and then I have no idea why it is not installing the xmod to the stack master primary partition. My show images does not show the ssh xmod as being installed on slot-1 at all. and the sh managment does not indicate ssh is installed or enabled. I get an invalid input error when I try running ssh access command.

So whats the trick to uninstalling the xmod from all the slots in the stack and then how do I get it to install in the stack master primary image. the "download image IP filename vr-default primary" command is not installing correctly on the stack. And now I have to uninstall form the other slots.
I would prefer a method that I could do without disrupting the stack. this stack in question is the primary stack for the whole complex. I am still not sure why our original install contractor did not install ssh on this stack correctly. All of others stacks are configured correctly, and it is too late to have them come back in, so now I trying to resolve it, and I not sure why it is out of wack.

11 replies

Userlevel 5
Hi Joe, did you try the command "uninstall image .xmod" ?
Sorry forgot to include that part. I get the msg : Uninstallation of the moduleError: Module summitX-15.6.2.12-patch1-6-ssh.xmod is not installed

but it still shows as being part of the primary for the slots 2,3,and 4.
Userlevel 5
Hi Joe,

In that case, you can use the command "uninstall image .xmod {slot slot-number} {reboot}"

Specifying reboot will reboot the switch after the package is uninstalled.
how do I stop the thttpd processs on a slot
Ok figured that termination out.. I had to command wrong and then I discovered I had to terminate 4 proccesses
xmlc, techsupport, snmpMaster and thttpd
Userlevel 7
You can also specify a slot to install to. This way, you can install the image to just the switches that don't already have it.
ok Now I have them all removed and the services restarted.
Should I do an after hourse stack reboot before attempting to install the ssh mod
Userlevel 7
ok Now I have them all removed and the services restarted.
Should I do an after hourse stack reboot before attempting to install the ssh mod

That shouldn't be required, Joe.
Ok so install appeared to work fine. I restarted the services thttpd and snmpMaster got some errors and noticed that on slots 3 and 4 the services are stopped or the stat is loadcfg. I assume this is normal? Slot 2 is the current standby
All is good now. And don't you know I came across some of the info used to do the removal in the concepts guide, could not find it when I was looking but afterwards when I was verifying the SSH install I noticed some of the commands to undo things.
Userlevel 5
Glad to hear you got it working!

Reply