Header Only - DO NOT REMOVE - Extreme Networks

X440-G2-24p-10GE4 High Fan speed


I have 2 of these Switches stacked on eachother.
The top one is more under load most of the time and is currently running at 89F(31C)
All 4 fans are between 8000RPM and 9000 RPM

Why is it that they would be spinning at that rate? and why only this one switch?
Would it be due to the temp, or higher usage?
the Switch below this one is noisy at all. and is also running at 87F(30C)
Fan speed: 2160RPM

Any feedback would be greatly appreciated.

X440-G2-24p-10GE4
version 21.1.1.4 21.1.1.4

Thanks

8 replies

Userlevel 3
Hi Marcel,

Do you have any impact like too noisy or over heat on that particular switch?
Otherwise it could be a bug. Please check the below article:

https://gtacknowledge.extremenetworks.com/articles/Solution/Wrong-temperature-output-and-fan-behavio...

Can you please provide us the below output from the stack:

show temperature
show fan
show log
debug hal show platform platforminfo

Regards,
Karthikeyan
Thanks Karthikeyan,

The log does not contain any errors only link up and down status and log in logs.

Not sure how to go about the last step you requested.


Userlevel 3
Hi Marcel,

I had a similar issue with an X440G2-12p-10G4 and the problem resolved itself when I updated the switch firmware to version 22.3.1.4.

Hope that helps.

Darrel.
Userlevel 3
I also ensured I updated the Programmable Logic Firmware following the main software update by issuing the CLI command: install firmware

Thanks,
Darrel.
Userlevel 3
Hi Marcel,

Yes. As Darrel said upgrade might solve this issue. It looks to be a cosmetic issue.
In X440-G2-24p-10GE4 (version 21.1.1.4), there is a bug wherein output displays incorrect value.

Regards,
Karthikeyan
Narayanan, Karthikeyan wrote:

Hi Marcel,

Yes. As Darrel said upgrade might solve this issue. It looks to be a cosmetic issue.
In X440-G2-24p-10GE4 (version 21.1.1.4), there is a bug wherein output displays incorrect value.

Regards,
Karthikeyan

ZA-Edge-Switch-Eth-004.4 # debug hal show platform platforminfo

PlatformName: X440G2-24p-10G4
PlatformId: 138 Type: 1
HAL_SELF_SLOT: 1
HAL_AM_I_PRIMARY: 1
HAL_GET_NUM_MAC_ADDR: 1
MAC[0]: 00 04 96 9b dd d1
HAL_GET_NUM_IO_SLOT: 1
HAL_GET_NUM_FM_SLOT: 0
HAL_GET_NUM_SWFB_SLOT: 0
HAL_GET_NUM_IO_SWFB_SLOT: 1
HAL_GET_NUM_MSM_SLOT: 0
HAL_GET_NUM_TOTAL_SLOT: 1

HAL_FIRST_SW_CAP_SLOT: 1
HAL_LAST_SW_CAP_SLOT: 1

HAL_GET_NUM_FAN_SLOT: 1
HAL_GET_NUM_PS_SLOT: 2

=======Environmental Data========
Fan Slot: 1 State OPERATIONAL

Fan Part Info:
Name:
SerialNum:
PartNum:
Revision: 0.0
Flags: 1
FailureCode: 0
PowerOnDate: Sat Feb 11 10:40:22 2017

Fimware Rev: BuildTag:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 5.00W
Fan#0: State: OPERATIONAL Location:
Fan#1: State: OPERATIONAL Location:
Fan#2: State: OPERATIONAL Location:
Fan#3: State: OPERATIONAL Location:
Odometer: not supported
Temperature: 0 Celsius
RpmLow 1500 RpmHigh 18000
Fan1: 5760 rpm
Failed 0 FailedCount 0
Fan2: 5940 rpm
Failed 0 FailedCount 0
Fan3: 5820 rpm
Failed 0 FailedCount 0
Fan4: 5760 rpm
Failed 0 FailedCount 0
Fan control period: 5000 msec
Desired temperature: 30
Fan Power Level: 100 errorSum: 210000000

Power Supply Slot: 1 State: POWER_ON

Power Supply Part Info:
Name: Internal Power Supply
SerialNum:
PartNum:
Revision: 0.0
Flags: 1
FailureCode: 0
PowerOnDate: Thu Jan 1 00:00:00 1970

Fimware Rev: 1.1 BuildTag: Turbine on 10/1/2004
Nominal line voltage: 120 V
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 200.00W

Redundant Power Info:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 190.00W

Redundant N+N Power Info:
gridId: 0 Number of voltage line to monitor: 1
Volt: 12.00V Watts: 190.00W
Odometer: not supported
Temperature: not supported
(Range 0 - 0)
Fan Speeds: (Range 0 - 0)
InputVoltage: 0 V Current: 0 A
OutputVoltage: 0 V Current: 0 A
Eff : 89

Chassis Odometer: 22206600 sec

Num Card Type Supported: 1
CardTypeName:
X440G2-24p-10G4
Reading phy version information for slot 1 gunit 1
Phy version : 0x00000000 (starting at port 25)

We moved a few LAN cables to the lower switch.

How does one upgrade the firmware? is there a guide somewhere one can follow?
Userlevel 3
Hi Marcel,

you can follow the below article for the upgrade procedure.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-Obtain-and-Upgrade-EXOS

Please let us know if you have any further queries.

Regards,
Karthikeyan
Userlevel 3
Hi Marcel,

Did you get a chance to check the article?
Please let us know if you have any further queries?

Regards,
Karthikeyan

Reply