Question

b3 vlan


Hi Friends,

I have two switches Enterasys and four computers as below:

switch 1 - Enterasys B3 with:

Computer A in port ge.1.1
Computer B in port ge.1.2

switch 2 - Entreasys B3 with:

Computer C in port ge.1.1
Computer D in port ge.1.2

The two switches are linked by port ge.1.48.

All computers are in same network 10.0.0.X/255.255.255.0.



I need this result:

Among Computer A, B and 😨 comunication it's permited

Between Computer A and C: comunication it's permited too

But among Computer B, C and 😨 no comunication it's permited



In ohter words:

If in machine A I type "ping 10.0.0.A" or "ping 10.0.0.B" or "ping 10.0.0.D" or "ping 10.0.0.C", the result must to be a answer

If in machine A or B or D, I type "ping 10.0.0.C", the result must to be no answer

If in machine C I type "ping 10.0.0.A", the result must to be a answer

If in machine C I type "ping 10.0.0.B" or "ping 10.0.0.D", the result must to be no answer



The question:

I tried to create a VLAN for machines A, B e D and other for C, but the result it isn't the above.

What I have to type in each switch for get the objective with success?



Thanks,

Rogerio

3 replies

Hi Rogerio,
It is easy show you the part of the configuration of VLANs?
You're from Brazil?

Thank's,
Edson.
Hi Edson,
I eliminate host D and change number of ports, but the question is the same.

I need that: Host A talk with B and C, but B don't talk with C.

With the configuration below, when in host A I do a ping to B, I have a answer, it's right, but if I do a ping to C, I have no answer, it's unexpected.

Follow the commands that I have typed and the output of "show vlan" on both switches.

And I am from Brazil.

Thanks,
Rogerio

===================

Port of Host A (switch 1 ge.1.7):
set port vlan ge.1.7 1 mod
set vlan egress 101 ge.1.7 untagged
set vlan egress 102 ge.1.7 untagged

Port of Host B (switch 1 ge.1.10):
set port vlan ge.1.10 101 mod
set vlan egress 1 ge.1.10 untagged

Port of Host C (switch 2 ge.1.24):
set port vlan ge.1.24 102 mod
set vlan egress 1 ge.1.24 untagged

Uplink ports (ge.1.48 on both switches):
set vlan egress 1 ge.1.48 tagged
set vlan egress 101 ge.1.48 tagged
set vlan egress 102 ge.1.48 tagged

================

Switch_1(su)->show vlan

VLAN: 1 NAME: DEFAULT VLAN
VLAN Type: Default
Egress Ports
ge.1.1, ge.1.3-10, ge.1.13-15, ge.1.19-26, ge.1.28, ge.1.30, ge.1.32-34, ge.1.36-39, ge.1.45-48
Forbidden Egress Ports
None.
Untagged ports
ge.1.1, ge.1.3-10, ge.1.13-15, ge.1.19-26, ge.1.28, ge.1.30, ge.1.32-34, ge.1.36-39, ge.1.45-47

VLAN: 101 NAME:
VLAN Type: Permanent
Egress Ports
ge.1.7, ge.1.10, ge.1.48
Forbidden Egress Ports
None.
Untagged ports
ge.1.7, ge.1.10

VLAN: 102 NAME:
VLAN Type: Permanent
Egress Ports
ge.1.7, ge.1.48
Forbidden Egress Ports
None.
Untagged ports
ge.1.7

================

Switch_2(su)->show vlan

VLAN: 1 NAME: DEFAULT VLAN
VLAN Type: Default
Egress Ports
ge.1.3-4, ge.1.6-9, ge.1.11, ge.1.13-22, ge.1.24-26, ge.1.35-36, ge.1.38, ge.1.48
Forbidden Egress Ports
None.
Untagged ports
ge.1.3-4, ge.1.6-9, ge.1.11, ge.1.13-22, ge.1.24-26, ge.1.35-36, ge.1.38

VLAN: 101 NAME:
VLAN Type: Permanent
Egress Ports
ge.1.48
Forbidden Egress Ports
None.
Untagged ports
None.

VLAN: 102 NAME:
VLAN Type: Permanent
Egress Ports
ge.1.24, ge.1.48
Forbidden Egress Ports
None.
Untagged ports
ge.1.24
Hi Edson
This problem is solved.
The switches configuration are correct. The problem was in the interface of host ethernet of host C. I correct it and then all is OK.
Thanks,
Rogerio

Reply