loop detection on port of extreme x250e-24t

  • 13 June 2016
  • 9 replies
  • 4738 views

There is physical loop detected on Extremex250e-24t switch,due to this entire network went down at one of our customer site.
Is anybody can help me how to block the port if the loop is detected on the switch?

So that in future if physical loop detected on the switch then port will automatically blocked it.

please let me know the procedure for the same.

Thanks in advanced!!!

9 replies

Userlevel 6
Hi Gunvant,

You could use ELRP in this case to disable the ports.

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-ELRP-to-disable-ports

Here is the article to help on how to configure it.
Userlevel 7
ELRP is proprietary and many times better, but you can use standard MSTP (spanning tree) 802.1s based protection
Or setup STP: (Stole this from a few friends of mine. But this is a good working STP config)

# Module stp configuration. #
configure mstp region Perlman
create stpd Perlman_stm
configure stpd Perlman_stm mode dot1w
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
configure stpd Perlman_stm add vlan Perlman ports 1:1 emistp

#Each edge port should be configured with edge-safegaurd and bpdu-restrict
configure stpd Perlman_stm ports mode emistp 1:1
configure stpd Perlman_stm ports cost auto 1:1
configure stpd Perlman_stm ports port-priority 128 1:1
configure stpd Perlman_stm ports link-type edge 1:1
configure stpd Perlman_stm ports edge-safeguard enable 1:1
configure stpd Perlman_stm ports bpdu-restrict enable 1:1
enable stpd Perlman_stm ports 1:1
enable stpd Perlman_stm
Or setup STP: (Stole this from a few friends of mine. But this is a good working STP config)

# Module stp configuration. #
configure mstp region Perlman
create stpd Perlman_stm
configure stpd Perlman_stm mode dot1w
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
configure stpd Perlman_stm add vlan Perlman ports 1:1 emistp

#Each edge port should be configured with edge-safegaurd and bpdu-restrict
configure stpd Perlman_stm ports mode emistp 1:1
configure stpd Perlman_stm ports cost auto 1:1
configure stpd Perlman_stm ports port-priority 128 1:1
configure stpd Perlman_stm ports link-type edge 1:1
configure stpd Perlman_stm ports edge-safeguard enable 1:1
configure stpd Perlman_stm ports bpdu-restrict enable 1:1
enable stpd Perlman_stm ports 1:1
enable stpd Perlman_stm
Thanks Jeremy,

I have tried with this also but didnot work.I am if anybody is connecting cable back to back on the switch then port should be blocked on untaged port.

if you can help me in step by step configuration then that will be really great for me.
i was trying to configure elrp on extrem switch as per given commands below:-
enable elrp-client
configure elrp-client periodic elrp_test ports 2 log disable-port egress duration 15​
but i can only able to type command "configure elrp-client periodic elrp_test ports 2 log" there is no further command disable-port egress duration 15 and
"configure elrp-client disable-port exclude 21"

please suggest
Can anybody please help me step by step configuration and how to monitor testing on extreme xos switch.due to disable-port command is not available i am stucked now.

Thanks in advanced!!!

Regards,
Gunvant Desai
Userlevel 7
Hi,

the x250e is supported by EXOS 15.3, but not by newer EXOS versions. In 15.3, ELRP is configured with:
configure elrp-client periodic VLANNAME ports PORTLIST interval 1 log disable-port duration 300 enable elrp-client [/code]This configuration can disable every port on which an ELRP PDU is received.
configure elrp-client disable-ports exclude PORTLIST[/code]If you have an older EXOS version, the commands might be a bit different, but in this case you should upgrade to the supported EXOS 15.3 anyway.

Best regards,
Erik
i am doing simulation in our lab with x150-24t switch version 12.0.2.25.But some of the commands are not supported like "disable-port duration 300" is not taking it after log.

"configure elrp-client disable-ports exclude PORTLIST" and this is also not taking it.

Could you please suggest what should i do to complete this testing?

Regards,
Gunvant Desai
Userlevel 7
Hi,

to complete the testing you need to update EXOS to a version that actually supports disabling ports via ELRP. EXOS version 12.0 does not provide this feature. The first EXOS version to provide this feature was 12.5.3.

The recommended EXOS version for X150 and X250 switches is EXOS 15.3.5.2-patch1-9 (see http://documentation.extremenetworks.com/hw_sw_compatibility/HardwareSoftwareCompatibility/r_exos-re...). You should consider upgrading to that firmware version.

Best regards,
Erik

Reply