lost operational code / firmware due to internal battery replacement ?

  • 1 October 2014
  • 28 replies
  • 1137 views


Show first post

28 replies

Solved !!

Symptom:

On C3 system if you replace internal battery CR2032 with the switch off you lost some boot flag or data that makes the device does not boot anymore to op code, remaining on this status.

Enterasys C3-Series Boot Code...
SDRAM Circuit Test of 255MB
100%

Solution

With a cable we use oscilloscope prove make connection between ground on any point at the board and the pin 28 of U19 Intel JS28F128J3D75 flash memory this pin is A1 address bus pin, this make the Freescale processor jump to some instruction with result like this.

ERROR! Did not read a valid board type from PCA9555 Monitor. Read -1
Unknown box topology

cfiscsByteWrite:Flash MTD: CFISCS write failed in verification.tffsDevCreate failed.
usrTffsConfig of drive 1 returned 0xffffffff, formatting 33554432 bytes...

Format complete. Please power cycle the box.

After make the power cycle make it again and get something like this.....

Enterasys C3-Series Boot Code...SDRAM Circuit Test of 255MB
100%

Version 01.00.53 01-16-2012

Computing MD5 Checksum of operational code...
Operational code CRC is invalid.

Boot Menu Version 01.00.53 01-16-2012

Options available
1 - Start operational code
2 - Change baud rate
3 - Retrieve event log using XMODEM (64KB).
4 - Load new operational code using XMODEM
5 - Display operational code vital product data
6 - Update Boot Code
7 - Delete operational code
8 - Reset the system
9 - Restore Configuration to factory defaults (delete config files)
10 - Set new Boot Code password
[Boot Menu] 9
[Boot Menu] 5

ERROR: Operational code CRC is not valid.
[Boot Menu]

Proceed like the normal XMODEM upload procedure.
After loaded firmware and CRC OK, save config and restart, that's all.

I have tried with no luck.
thank you so much for your help!!
Userlevel 3
Are you even supposed to take these units apart? If there is a problem, perform an RMA?
Userlevel 2
Are you even supposed to take these units apart? If there is a problem, perform an RMA?

I don't think that we were/are permitted to open unit, perform cleanup and replace battery. Battery is not user replaceable part, so we don't have claim to RMA. I think, that this thread is usefull for some user with this old units.

Reply